summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Schanzenbacher <ryan@rschanz.org>2024-03-08 14:05:30 -0500
committerRyan Schanzenbacher <ryan@rschanz.org>2024-03-08 14:05:30 -0500
commit3967227c74df474d85a25c94c3bf32d6f96e50c3 (patch)
treedddb535b0b226489997e06519a3e8482ec127d9f
parent8d9871bd1f3cfd3d57545c91da5e7f9166328f12 (diff)
added local bin to path and fixed shepherd issue
-rw-r--r--home-config/bash_profile2
-rwxr-xr-xhome-config/hypr/autostart.sh2
-rw-r--r--modules/ryan-config/base-system.scm3
3 files changed, 3 insertions, 4 deletions
diff --git a/home-config/bash_profile b/home-config/bash_profile
index 1aa335f..6bc7def 100644
--- a/home-config/bash_profile
+++ b/home-config/bash_profile
@@ -5,7 +5,7 @@ export XDG_SESSION_DESKTOP=sway
5export _JAVA_AWT_WM_NONREPEATING=1 5export _JAVA_AWT_WM_NONREPEATING=1
6 6
7export XDG_DATA_DIRS=$XDG_DATA_DIRS:~/.nix-profile/share 7export XDG_DATA_DIRS=$XDG_DATA_DIRS:~/.nix-profile/share
8export PATH=$PATH:~/.nix-profile/bin 8export PATH=~/.local/bin:$PATH:~/.nix-profile/bin
9 9
10# Honor per-interactive-shell startup file 10# Honor per-interactive-shell startup file
11if [ -f ~/.bashrc ]; then . ~/.bashrc; fi 11if [ -f ~/.bashrc ]; then . ~/.bashrc; fi
diff --git a/home-config/hypr/autostart.sh b/home-config/hypr/autostart.sh
index 5d7363d..7b327df 100755
--- a/home-config/hypr/autostart.sh
+++ b/home-config/hypr/autostart.sh
@@ -1,7 +1,5 @@
1#!/usr/bin/env bash 1#!/usr/bin/env bash
2 2
3hash dbus-update-activation-environment 2>/dev/null && dbus-update-activation-environment DISPLAY WAYLAND_DISPLAY SWAYSOCK XDG_CURRENT_DESKTOP &
4
5waybar & 3waybar &
6 4
7mako & 5mako &
diff --git a/modules/ryan-config/base-system.scm b/modules/ryan-config/base-system.scm
index 6ecae35..dc589c9 100644
--- a/modules/ryan-config/base-system.scm
+++ b/modules/ryan-config/base-system.scm
@@ -212,7 +212,8 @@
212 (inherit config) 212 (inherit config)
213 (handle-power-key `ignore) 213 (handle-power-key `ignore)
214 (handle-suspend-key `ignore) 214 (handle-suspend-key `ignore)
215 (handle-lid-switch `ignore))) 215 (handle-lid-switch `ignore)
216 (kill-user-processes? #t)))
216 (delete pulseaudio-service-type) 217 (delete pulseaudio-service-type)
217 (delete gdm-service-type) 218 (delete gdm-service-type)
218 (delete avahi-service-type) 219 (delete avahi-service-type)