diff options
-rw-r--r-- | home-config/bash_profile | 3 | ||||
-rw-r--r-- | home-config/home-configuration.scm | 8 | ||||
-rw-r--r-- | home-config/nix-channels | 2 | ||||
-rw-r--r-- | home-config/nix-home-manager/home.nix | 83 | ||||
-rw-r--r-- | system.scm | 3 |
5 files changed, 94 insertions, 5 deletions
diff --git a/home-config/bash_profile b/home-config/bash_profile index 319a0ca..d58e435 100644 --- a/home-config/bash_profile +++ b/home-config/bash_profile | |||
@@ -4,5 +4,8 @@ export XDG_CURRENT_DESKTOP=sway | |||
4 | export XDG_SESSION_DESKTOP=sway | 4 | export XDG_SESSION_DESKTOP=sway |
5 | export _JAVA_AWT_WM_NONREPEATING=1 | 5 | export _JAVA_AWT_WM_NONREPEATING=1 |
6 | 6 | ||
7 | export XDG_DATA_DIRS=$XDG_DATA_DIRS:~/.nix-profile/share | ||
8 | export PATH=$PATH:~/.nix-profile/bin | ||
9 | |||
7 | # Honor per-interactive-shell startup file | 10 | # Honor per-interactive-shell startup file |
8 | if [ -f ~/.bashrc ]; then . ~/.bashrc; fi | 11 | if [ -f ~/.bashrc ]; then . ~/.bashrc; fi |
diff --git a/home-config/home-configuration.scm b/home-config/home-configuration.scm index 64d1236..10c8374 100644 --- a/home-config/home-configuration.scm +++ b/home-config/home-configuration.scm | |||
@@ -40,8 +40,6 @@ | |||
40 | "lsof" | 40 | "lsof" |
41 | "pavucontrol" | 41 | "pavucontrol" |
42 | "bind:utils" | 42 | "bind:utils" |
43 | "firefox" | ||
44 | "irssi" | ||
45 | "font-cns11643" | 43 | "font-cns11643" |
46 | "syncthing" | 44 | "syncthing" |
47 | "perl" | 45 | "perl" |
@@ -97,13 +95,15 @@ | |||
97 | ("nvim/after/ftplugin/markdown/custom.vim" ,(local-file "nvim/config/after/ftplugin/markdown/custom.vim")) | 95 | ("nvim/after/ftplugin/markdown/custom.vim" ,(local-file "nvim/config/after/ftplugin/markdown/custom.vim")) |
98 | ("sway" ,(local-file "sway" #:recursive? #t)) | 96 | ("sway" ,(local-file "sway" #:recursive? #t)) |
99 | ("waybar" ,(local-file "waybar" #:recursive? #t)) | 97 | ("waybar" ,(local-file "waybar" #:recursive? #t)) |
100 | ("alacritty" ,(local-file "alacritty" #:recursive? #t)) )) | 98 | ("alacritty" ,(local-file "alacritty" #:recursive? #t)) |
99 | ("home-manager" ,(local-file "nix-home-manager" #:recursive? #t)) )) | ||
101 | (service home-files-service-type | 100 | (service home-files-service-type |
102 | `((".local/share/nvim/site/autoload/plug.vim" ,(local-file "nvim/plugin-manager/plug.vim")) | 101 | `((".local/share/nvim/site/autoload/plug.vim" ,(local-file "nvim/plugin-manager/plug.vim")) |
103 | (".ssh/config" ,(local-file "ssh/config")) | 102 | (".ssh/config" ,(local-file "ssh/config")) |
104 | ;(".gnupg/sshcontrol" ,(local-file "gnupg/sshcontrol")) | 103 | ;(".gnupg/sshcontrol" ,(local-file "gnupg/sshcontrol")) |
105 | ;(".gnupg/gpg-agent.conf" ,(local-file "gnupg/gpg-agent.conf")) | 104 | ;(".gnupg/gpg-agent.conf" ,(local-file "gnupg/gpg-agent.conf")) |
106 | (".fonts" ,(local-file "fonts" #:recursive? #t)))) | 105 | (".fonts" ,(local-file "fonts" #:recursive? #t)) |
106 | (".nix-channels" ,(local-file "nix-channels")))) | ||
107 | (service home-pipewire-service-type) | 107 | (service home-pipewire-service-type) |
108 | (service home-dbus-service-type) | 108 | (service home-dbus-service-type) |
109 | (service home-gpg-agent-service-type | 109 | (service home-gpg-agent-service-type |
diff --git a/home-config/nix-channels b/home-config/nix-channels new file mode 100644 index 0000000..0df3852 --- /dev/null +++ b/home-config/nix-channels | |||
@@ -0,0 +1,2 @@ | |||
1 | https://github.com/nix-community/home-manager/archive/master.tar.gz home-manager | ||
2 | https://nixos.org/channels/nixpkgs-unstable nixpkgs | ||
diff --git a/home-config/nix-home-manager/home.nix b/home-config/nix-home-manager/home.nix new file mode 100644 index 0000000..39a8c0e --- /dev/null +++ b/home-config/nix-home-manager/home.nix | |||
@@ -0,0 +1,83 @@ | |||
1 | { config, pkgs, ... }: | ||
2 | |||
3 | { | ||
4 | # Home Manager needs a bit of information about you and the paths it should | ||
5 | # manage. | ||
6 | home.username = "ryan"; | ||
7 | home.homeDirectory = "/home/ryan"; | ||
8 | |||
9 | # This value determines the Home Manager release that your configuration is | ||
10 | # compatible with. This helps avoid breakage when a new Home Manager release | ||
11 | # introduces backwards incompatible changes. | ||
12 | # | ||
13 | # You should not change this value, even if you update Home Manager. If you do | ||
14 | # want to update the value, then make sure to first check the Home Manager | ||
15 | # release notes. | ||
16 | home.stateVersion = "22.11"; # Please read the comment before changing. | ||
17 | |||
18 | # This value will set some environment variables to allow home-manager to | ||
19 | # function better outside of NixOS | ||
20 | nixpkgs.config.allowUnfree = true; | ||
21 | targets.genericLinux.enable = true; | ||
22 | fonts.fontconfig.enable = true; | ||
23 | |||
24 | # The home.packages option allows you to install Nix packages into your | ||
25 | # environment. | ||
26 | home.packages = with pkgs; [ | ||
27 | # # Adds the 'hello' command to your environment. It prints a friendly | ||
28 | # # "Hello, world!" when run. | ||
29 | # pkgs.hello | ||
30 | firefox | ||
31 | dejavu_fonts | ||
32 | cantarell-fonts | ||
33 | liberation_ttf | ||
34 | noto-fonts | ||
35 | noto-fonts-cjk | ||
36 | noto-fonts-emoji | ||
37 | |||
38 | # # It is sometimes useful to fine-tune packages, for example, by applying | ||
39 | # # overrides. You can do that directly here, just don't forget the | ||
40 | # # parentheses. Maybe you want to install Nerd Fonts with a limited number of | ||
41 | # # fonts? | ||
42 | # (pkgs.nerdfonts.override { fonts = [ "FantasqueSansMono" ]; }) | ||
43 | |||
44 | # # You can also create simple shell scripts directly inside your | ||
45 | # # configuration. For example, this adds a command 'my-hello' to your | ||
46 | # # environment: | ||
47 | # (pkgs.writeShellScriptBin "my-hello" '' | ||
48 | # echo "Hello, ${config.home.username}!" | ||
49 | # '') | ||
50 | ]; | ||
51 | |||
52 | # Home Manager is pretty good at managing dotfiles. The primary way to manage | ||
53 | # plain files is through 'home.file'. | ||
54 | home.file = { | ||
55 | # # Building this configuration will create a copy of 'dotfiles/screenrc' in | ||
56 | # # the Nix store. Activating the configuration will then make '~/.screenrc' a | ||
57 | # # symlink to the Nix store copy. | ||
58 | # ".screenrc".source = dotfiles/screenrc; | ||
59 | |||
60 | # # You can also set the file content immediately. | ||
61 | # ".gradle/gradle.properties".text = '' | ||
62 | # org.gradle.console=verbose | ||
63 | # org.gradle.daemon.idletimeout=3600000 | ||
64 | # ''; | ||
65 | }; | ||
66 | |||
67 | # You can also manage environment variables but you will have to manually | ||
68 | # source | ||
69 | # | ||
70 | # ~/.nix-profile/etc/profile.d/hm-session-vars.sh | ||
71 | # | ||
72 | # or | ||
73 | # | ||
74 | # /etc/profiles/per-user/ryan/etc/profile.d/hm-session-vars.sh | ||
75 | # | ||
76 | # if you don't want to manage your shell through Home Manager. | ||
77 | home.sessionVariables = { | ||
78 | # EDITOR = "emacs"; | ||
79 | }; | ||
80 | |||
81 | # Let Home Manager install and manage itself. | ||
82 | programs.home-manager.enable = true; | ||
83 | } | ||
@@ -20,7 +20,7 @@ | |||
20 | (use-modules (srfi srfi-1)) | 20 | (use-modules (srfi srfi-1)) |
21 | (use-modules (ryan-packages freedesktop)) | 21 | (use-modules (ryan-packages freedesktop)) |
22 | (use-package-modules security-token) | 22 | (use-package-modules security-token) |
23 | (use-service-modules cups desktop networking xorg ssh sound security-token docker virtualization) | 23 | (use-service-modules cups desktop networking xorg ssh nix sound security-token docker virtualization) |
24 | 24 | ||
25 | ; Define package that installs my root ca public keys | 25 | ; Define package that installs my root ca public keys |
26 | (define my-ca-certs | 26 | (define my-ca-certs |
@@ -146,6 +146,7 @@ | |||
146 | (service openssh-service-type) | 146 | (service openssh-service-type) |
147 | (service pcscd-service-type) | 147 | (service pcscd-service-type) |
148 | (service docker-service-type) | 148 | (service docker-service-type) |
149 | (service nix-service-type) | ||
149 | (service libvirt-service-type | 150 | (service libvirt-service-type |
150 | (libvirt-configuration | 151 | (libvirt-configuration |
151 | (unix-sock-group "libvirt"))) | 152 | (unix-sock-group "libvirt"))) |