summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--channels.scm2
-rw-r--r--home-config/home-configuration.scm1
-rwxr-xr-xhome-config/hypr/autostart.sh8
-rw-r--r--home-config/hypr/hyprland.conf4
-rw-r--r--home-config/hypr/kanshi.conf4
-rwxr-xr-xhome-config/hypr/wallpaper.sh6
-rw-r--r--home-config/nix-home-manager/home.nix3
-rw-r--r--modules/ryan-packages/freedesktop.scm4
8 files changed, 28 insertions, 4 deletions
diff --git a/channels.scm b/channels.scm
index e91cfa7..a3f2b8c 100644
--- a/channels.scm
+++ b/channels.scm
@@ -25,7 +25,7 @@
25 (url "https://codeberg.org/hako/rosenthal.git") 25 (url "https://codeberg.org/hako/rosenthal.git")
26 (branch "trunk") 26 (branch "trunk")
27 (commit 27 (commit
28 "6b1a540e247ad31c9b06488119f986966ee37015") 28 "417dd04e821084a7137872d3bf16f10379017a18")
29 (introduction 29 (introduction
30 (make-channel-introduction 30 (make-channel-introduction
31 "7677db76330121a901604dfbad19077893865f35" 31 "7677db76330121a901604dfbad19077893865f35"
diff --git a/home-config/home-configuration.scm b/home-config/home-configuration.scm
index 89a4511..9dd47a2 100644
--- a/home-config/home-configuration.scm
+++ b/home-config/home-configuration.scm
@@ -98,6 +98,7 @@
98 "git" 98 "git"
99 "password-store" 99 "password-store"
100 "node" 100 "node"
101 "kanshi"
101 "git-lfs")) 102 "git-lfs"))
102 (list my-neovim wl-mirror firefox-wayland-new))) 103 (list my-neovim wl-mirror firefox-wayland-new)))
103 104
diff --git a/home-config/hypr/autostart.sh b/home-config/hypr/autostart.sh
index c53aeee..b05b71d 100755
--- a/home-config/hypr/autostart.sh
+++ b/home-config/hypr/autostart.sh
@@ -6,8 +6,14 @@ waybar &
6 6
7mako & 7mako &
8 8
9swaybg -i ~/.config/hypr/Wallpapers/above-clouds.jpg & 9#swaybg -i ~/.config/hypr/Wallpapers/above-clouds.jpg &
10
11swww init &
10 12
11swayidle -w timeout 300 'swaylock --screenshots --clock --indicator --grace 3 --fade-in 1 --effect-blur 7x5 --effect-greyscale' timeout 600 'hyprctl dispatch dpms off' resume 'hyprctl dispatch dpms on' before-sleep 'swaylock -f -c 000000' & 13swayidle -w timeout 300 'swaylock --screenshots --clock --indicator --grace 3 --fade-in 1 --effect-blur 7x5 --effect-greyscale' timeout 600 'hyprctl dispatch dpms off' resume 'hyprctl dispatch dpms on' before-sleep 'swaylock -f -c 000000' &
12 14
13syncthing serve --no-browser & 15syncthing serve --no-browser &
16
17wl-clip-persist -c regular &
18
19kanshi -c ~/.config/hypr/kanshi.conf
diff --git a/home-config/hypr/hyprland.conf b/home-config/hypr/hyprland.conf
index 7367d6c..a3545b8 100644
--- a/home-config/hypr/hyprland.conf
+++ b/home-config/hypr/hyprland.conf
@@ -197,6 +197,9 @@ bind = $mainMod SHIFT, Print, exec, grimblast edit area
197bind = $mainMod, N, exec, makoctl dismiss 197bind = $mainMod, N, exec, makoctl dismiss
198bind = $mainMod SHIFT, N, exec, makoctl dismiss -a 198bind = $mainMod SHIFT, N, exec, makoctl dismiss -a
199 199
200# Color picker
201bind = $mainMod SHIFT, C, exec, hyprpicker -a
202
200# Window Rules 203# Window Rules
201 204
202# Firefox PiP 205# Firefox PiP
@@ -222,4 +225,5 @@ exec-once = ~/.config/hypr/autostart.sh
222 225
223misc { 226misc {
224 disable_hyprland_logo = true 227 disable_hyprland_logo = true
228 force_default_wallpaper = 0
225} 229}
diff --git a/home-config/hypr/kanshi.conf b/home-config/hypr/kanshi.conf
new file mode 100644
index 0000000..6a2cbfe
--- /dev/null
+++ b/home-config/hypr/kanshi.conf
@@ -0,0 +1,4 @@
1profile {
2 output * enable
3 exec ~/.config/hypr/wallpaper.sh
4}
diff --git a/home-config/hypr/wallpaper.sh b/home-config/hypr/wallpaper.sh
new file mode 100755
index 0000000..7d9ea21
--- /dev/null
+++ b/home-config/hypr/wallpaper.sh
@@ -0,0 +1,6 @@
1#!/bin/sh
2
3# Eventually allow for multiple animated backgrounds to be rotated.
4# Right now just reset the current image for when outputs are changed
5
6swww img ~/.config/hypr/Wallpapers/above-clouds.jpg
diff --git a/home-config/nix-home-manager/home.nix b/home-config/nix-home-manager/home.nix
index c535157..c6aed16 100644
--- a/home-config/nix-home-manager/home.nix
+++ b/home-config/nix-home-manager/home.nix
@@ -34,6 +34,9 @@
34 gcc 34 gcc
35 pkg-config 35 pkg-config
36 wttrbar 36 wttrbar
37 swww
38 hyprpicker
39 wl-clip-persist
37 40
38 # # It is sometimes useful to fine-tune packages, for example, by applying 41 # # It is sometimes useful to fine-tune packages, for example, by applying
39 # # overrides. You can do that directly here, just don't forget the 42 # # overrides. You can do that directly here, just don't forget the
diff --git a/modules/ryan-packages/freedesktop.scm b/modules/ryan-packages/freedesktop.scm
index b8be19b..1dd5d0d 100644
--- a/modules/ryan-packages/freedesktop.scm
+++ b/modules/ryan-packages/freedesktop.scm
@@ -44,7 +44,7 @@
44(define-public xdg-desktop-portal-hyprland-ryan 44(define-public xdg-desktop-portal-hyprland-ryan
45 (package 45 (package
46 (name "xdg-desktop-portal-hyprland") 46 (name "xdg-desktop-portal-hyprland")
47 (version "1.2.2") 47 (version "1.2.4")
48 (source (origin 48 (source (origin
49 (method git-fetch) 49 (method git-fetch)
50 (uri (git-reference 50 (uri (git-reference
@@ -53,7 +53,7 @@
53 (file-name (git-file-name name version)) 53 (file-name (git-file-name name version))
54 (sha256 54 (sha256
55 (base32 55 (base32
56 "1s458wg9zl76nj2ya8iw5qfjsrpawp78ldilkwyqi4cn2kzjhqsh")))) 56 "1m82rrir2fg7h2cpch6wm3h1rkpnbh9pawlw1wdknw75mi6139r0"))))
57 (build-system meson-build-system) 57 (build-system meson-build-system)
58 (arguments 58 (arguments
59 (list 59 (list