diff options
-rw-r--r-- | home-config/home-configuration.scm | 1 | ||||
-rw-r--r-- | home-config/nix-home-manager/home.nix | 1 | ||||
-rw-r--r-- | mainlaptop.scm | 24 |
3 files changed, 26 insertions, 0 deletions
diff --git a/home-config/home-configuration.scm b/home-config/home-configuration.scm index 3b0cd58..22a9399 100644 --- a/home-config/home-configuration.scm +++ b/home-config/home-configuration.scm | |||
@@ -74,6 +74,7 @@ | |||
74 | "python-lsp-server" | 74 | "python-lsp-server" |
75 | "kdenlive" | 75 | "kdenlive" |
76 | "sqlite" | 76 | "sqlite" |
77 | "mpv" | ||
77 | "git")) | 78 | "git")) |
78 | (list my-neovim))) | 79 | (list my-neovim))) |
79 | 80 | ||
diff --git a/home-config/nix-home-manager/home.nix b/home-config/nix-home-manager/home.nix index 39a8c0e..d883f04 100644 --- a/home-config/nix-home-manager/home.nix +++ b/home-config/nix-home-manager/home.nix | |||
@@ -34,6 +34,7 @@ | |||
34 | noto-fonts | 34 | noto-fonts |
35 | noto-fonts-cjk | 35 | noto-fonts-cjk |
36 | noto-fonts-emoji | 36 | noto-fonts-emoji |
37 | yt-dlp | ||
37 | 38 | ||
38 | # # It is sometimes useful to fine-tune packages, for example, by applying | 39 | # # It is sometimes useful to fine-tune packages, for example, by applying |
39 | # # overrides. You can do that directly here, just don't forget the | 40 | # # overrides. You can do that directly here, just don't forget the |
diff --git a/mainlaptop.scm b/mainlaptop.scm new file mode 100644 index 0000000..11650bc --- /dev/null +++ b/mainlaptop.scm | |||
@@ -0,0 +1,24 @@ | |||
1 | (use-modules (ryan-config base-system) | ||
2 | (gnu)) | ||
3 | |||
4 | (operating-system | ||
5 | (inherit base-operating-system) | ||
6 | (host-name "RyanLaptop") | ||
7 | (mapped-devices (list (mapped-device | ||
8 | (source (uuid | ||
9 | "4de50ae4-e6f5-4f0c-ba4b-dd97b44a2ef2")) | ||
10 | (target "sysroot") | ||
11 | (type luks-device-mapping)))) | ||
12 | (file-systems (cons* (file-system | ||
13 | (mount-point "/") | ||
14 | (device "/dev/mapper/sysroot") | ||
15 | (type "ext4") | ||
16 | (dependencies mapped-devices)) | ||
17 | (file-system | ||
18 | (mount-point "/boot/efi") | ||
19 | (device (uuid "4C53-D400" | ||
20 | 'fat32)) | ||
21 | (type "vfat")) %base-file-systems)) | ||
22 | (swap-devices | ||
23 | (list | ||
24 | (swap-space (target (uuid "6758bed3-9ff2-49a0-9cc3-7c48eaee6c4a")))))) | ||