diff options
-rw-r--r-- | home-config/hypr/kanshi.conf | 15 | ||||
-rw-r--r-- | modules/ryan-config/base-system.scm | 4 | ||||
-rw-r--r-- | modules/ryan-packages/wm.scm | 36 |
3 files changed, 52 insertions, 3 deletions
diff --git a/home-config/hypr/kanshi.conf b/home-config/hypr/kanshi.conf index db7d45a..92eed88 100644 --- a/home-config/hypr/kanshi.conf +++ b/home-config/hypr/kanshi.conf | |||
@@ -2,7 +2,20 @@ profile { | |||
2 | output "AU Optronics 0x103D Unknown" enable | 2 | output "AU Optronics 0x103D Unknown" enable |
3 | } | 3 | } |
4 | 4 | ||
5 | profile { | 5 | profile tylerdesk { |
6 | output "AU Optronics 0x103D Unknown" disable | 6 | output "AU Optronics 0x103D Unknown" disable |
7 | output "Dell Inc. DELL U3421WE 6WK8753" enable | 7 | output "Dell Inc. DELL U3421WE 6WK8753" enable |
8 | } | 8 | } |
9 | |||
10 | profile emilydesk { | ||
11 | output "AU Optronics 0x103D Unknown" disable | ||
12 | output "Dell Inc. DELL U2422H JN4SF83" position 0,0 mode 1920x1080 | ||
13 | output "Dell Inc. DELL U2414H R9F1P5C59WDL" position 1920,0 mode 1920x1080 | ||
14 | output "Dell Inc. DELL U2422H 5S9SF83" position 3840,0 mode 1920x1080 | ||
15 | } | ||
16 | |||
17 | profile justindesk { | ||
18 | output "AU Optronics 0x103D Unknown" position 0,0 mode 1920x1080 | ||
19 | output "Dell Inc. DELL U2417H XVNNT7CDC80L" position 1920,0 mode 1920x1080 | ||
20 | output "Dell Inc. DELL U2417H XVNNT82M978L" position 3840,0 mode 1920x1080 | ||
21 | } | ||
diff --git a/modules/ryan-config/base-system.scm b/modules/ryan-config/base-system.scm index 11329e7..6ecae35 100644 --- a/modules/ryan-config/base-system.scm +++ b/modules/ryan-config/base-system.scm | |||
@@ -112,7 +112,7 @@ | |||
112 | ;; under their own account: use 'guix search KEYWORD' to search | 112 | ;; under their own account: use 'guix search KEYWORD' to search |
113 | ;; for packages and 'guix install PACKAGE' to install a package. | 113 | ;; for packages and 'guix install PACKAGE' to install a package. |
114 | (packages (append (map specification->package (list "sway" | 114 | (packages (append (map specification->package (list "sway" |
115 | "hyprland" | 115 | ;"hyprland" |
116 | "swaybg" | 116 | "swaybg" |
117 | "swayidle" | 117 | "swayidle" |
118 | ;"swaylock-effects" | 118 | ;"swaylock-effects" |
@@ -150,7 +150,7 @@ | |||
150 | "wireplumber" | 150 | "wireplumber" |
151 | "wireshark" | 151 | "wireshark" |
152 | "zsh")) | 152 | "zsh")) |
153 | (list my-ca-certs swaylock-effects-new xdg-desktop-portal-hyprland-ryan waybar-new virt-manager-ovmf bluez-ryan blueman-ryan) | 153 | (list my-ca-certs swaylock-effects-new waybar-new xdg-desktop-portal-hyprland-ryan hyprland-temp virt-manager-ovmf bluez-ryan blueman-ryan) |
154 | %my-base-packages )) | 154 | %my-base-packages )) |
155 | 155 | ||
156 | ;; Below is the list of system services. To search for available | 156 | ;; Below is the list of system services. To search for available |
diff --git a/modules/ryan-packages/wm.scm b/modules/ryan-packages/wm.scm index 8f3be42..73973fd 100644 --- a/modules/ryan-packages/wm.scm +++ b/modules/ryan-packages/wm.scm | |||
@@ -16,6 +16,7 @@ | |||
16 | #:use-module (gnu packages check) | 16 | #:use-module (gnu packages check) |
17 | #:use-module (guix git-download) | 17 | #:use-module (guix git-download) |
18 | #:use-module (guix utils) | 18 | #:use-module (guix utils) |
19 | #:use-module (rosenthal packages wm) | ||
19 | #:use-module (ryan-packages gtk) | 20 | #:use-module (ryan-packages gtk) |
20 | #:use-module (gnu packages wm)) | 21 | #:use-module (gnu packages wm)) |
21 | 22 | ||
@@ -52,3 +53,38 @@ | |||
52 | #:configure-flags #~(list "--wrap-mode=nodownload" "-Dexperimental=true"))) | 53 | #:configure-flags #~(list "--wrap-mode=nodownload" "-Dexperimental=true"))) |
53 | (inputs (modify-inputs (package-inputs waybar) (delete "gtkmm") (prepend gtkmm-ryan))))) ;(prepend python cava catch2 gtkmm))))) | 54 | (inputs (modify-inputs (package-inputs waybar) (delete "gtkmm") (prepend gtkmm-ryan))))) ;(prepend python cava catch2 gtkmm))))) |
54 | ;(native-inputs (modify-inputs (package-native-inputs waybar) (prepend gcc-13))))) | 55 | ;(native-inputs (modify-inputs (package-native-inputs waybar) (prepend gcc-13))))) |
56 | |||
57 | (define hyprland-unbundle-wlroots-patch | ||
58 | (origin | ||
59 | (method url-fetch) | ||
60 | (uri (string-append "https://github.com/hyprwm/Hyprland" "/raw/" | ||
61 | "13f6f0b923ff3ec94a3bec886c28b90402ceef91" | ||
62 | "/nix/patches/meson-build.patch")) | ||
63 | (sha256 | ||
64 | (base32 "02sq5ymxxrxp93mccafc4ilpsvs4m8bxc3whp7bcc5v9dx41va8k")))) | ||
65 | |||
66 | (define-public hyprland-temp | ||
67 | (package | ||
68 | (inherit hyprland) | ||
69 | (version "12985fa0d8e43b1e33326dfb49be681970dfaea5") | ||
70 | (source (origin | ||
71 | (method git-fetch) | ||
72 | (uri (git-reference | ||
73 | (url "https://github.com/hyprwm/Hyprland") | ||
74 | (commit version))) | ||
75 | (file-name (git-file-name "hyprland" version)) | ||
76 | (modules '((guix build utils))) | ||
77 | (snippet | ||
78 | '(begin | ||
79 | (substitute* "meson.build" | ||
80 | ((".*hyprpm/src.*") "")) | ||
81 | (for-each delete-file-recursively | ||
82 | '("hyprpm" | ||
83 | "subprojects")) | ||
84 | (copy-file "src/version.h.in" "src/version.h"))) | ||
85 | (sha256 | ||
86 | (base32 | ||
87 | "13l95h5krmv7syidw9c4gn62ac5qcqg9pmfh6x8ydjws97h05jvz")) | ||
88 | (patches (list hyprland-unbundle-wlroots-patch)))))) | ||
89 | |||
90 | hyprland-temp | ||