summaryrefslogtreecommitdiff
path: root/home-config/fish/config.fish
diff options
context:
space:
mode:
Diffstat (limited to 'home-config/fish/config.fish')
-rw-r--r--home-config/fish/config.fish20
1 files changed, 16 insertions, 4 deletions
diff --git a/home-config/fish/config.fish b/home-config/fish/config.fish
index 5cbc322..c842712 100644
--- a/home-config/fish/config.fish
+++ b/home-config/fish/config.fish
@@ -1,3 +1,19 @@
1if status is-login
2 eval "$(guix package --search-paths \
3 -p ~/.config/guix/current \
4 -p ~/.guix-profile \
5 -p /run/current-system/profile)"
6
7 fish_add_path -Pp ~/.local/bin
8 fish_add_path -Pp ~/.guix-home/profile/bin
9 fish_add_path -Pp /run/setuid-programs
10 fish_add_path -Pp ~/.nix-profile/bin
11 set -gx EDITOR nvim
12 set -gax XDG_DATA_DIRS ~/.nix-profile/share
13 fenv source ~/.profile
14 # Bad
15 find ~/.config/fish/ -name "*tmp*" -exec {} +
16end
1if status is-interactive 17if status is-interactive
2 # Commands to run in interactive sessions can go here 18 # Commands to run in interactive sessions can go here
3 alias quit exit 19 alias quit exit
@@ -12,10 +28,6 @@ if status is-interactive
12 alias ls "ls -p --color=auto" 28 alias ls "ls -p --color=auto"
13 alias grep "grep --color=auto" 29 alias grep "grep --color=auto"
14 alias ll "ls -l" 30 alias ll "ls -l"
15 set -gx EDITOR nvim
16 set -gax XDG_DATA_DIRS ~/.nix-profile/share
17 fish_add_path ~/.local/bin
18 fish_add_path ~/.nix-profile/bin
19 31
20 zoxide init fish | source 32 zoxide init fish | source
21 33