summaryrefslogtreecommitdiff
path: root/home-config/nix-home-manager/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home-config/nix-home-manager/flake.nix')
-rw-r--r--home-config/nix-home-manager/flake.nix19
1 files changed, 17 insertions, 2 deletions
diff --git a/home-config/nix-home-manager/flake.nix b/home-config/nix-home-manager/flake.nix
index 0048eb2..6429214 100644
--- a/home-config/nix-home-manager/flake.nix
+++ b/home-config/nix-home-manager/flake.nix
@@ -12,15 +12,24 @@
12 url = "github:hyprwm/hyprpicker"; 12 url = "github:hyprwm/hyprpicker";
13 inputs.nixpkgs.follows = "nixpkgs"; 13 inputs.nixpkgs.follows = "nixpkgs";
14 }; 14 };
15 hyprland = {
16 url = "github:hyprwm/hyprland/v0.44.1";
17 inputs.nixpkgs.follows = "nixpkgs";
18 };
19 nixgl = {
20 url = "github:nix-community/nixGL";
21 inputs.nixpkgs.follows = "nixpkgs";
22 };
15 }; 23 };
16 24
17 outputs = { nixpkgs, home-manager, hyprpicker-git, ... }@inputs: 25 outputs = { nixpkgs, home-manager, hyprpicker-git, hyprland, nixgl, ... }@inputs:
18 let 26 let
19 system = "x86_64-linux"; 27 system = "x86_64-linux";
20 pkgs = nixpkgs.legacyPackages.${system}; 28 pkgs = nixpkgs.legacyPackages.${system};
21 overlays = [ 29 overlays = [
22 hyprpicker-git.overlays.default 30 hyprpicker-git.overlays.default
23 ]; 31 nixgl.overlay
32 ];
24 in { 33 in {
25 homeConfigurations."ryan" = home-manager.lib.homeManagerConfiguration { 34 homeConfigurations."ryan" = home-manager.lib.homeManagerConfiguration {
26 inherit pkgs; 35 inherit pkgs;
@@ -30,6 +39,12 @@
30 modules = [ 39 modules = [
31 ./home.nix 40 ./home.nix
32 {nixpkgs.overlays = overlays;} 41 {nixpkgs.overlays = overlays;}
42 {
43 _module.args = {
44 inherit hyprland;
45 inherit nixgl;
46 };
47 }
33 ]; 48 ];
34 49
35 # Optionally use extraSpecialArgs 50 # Optionally use extraSpecialArgs