summaryrefslogtreecommitdiff
path: root/home-config/nix-home-manager/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home-config/nix-home-manager/flake.nix')
-rw-r--r--home-config/nix-home-manager/flake.nix39
1 files changed, 39 insertions, 0 deletions
diff --git a/home-config/nix-home-manager/flake.nix b/home-config/nix-home-manager/flake.nix
new file mode 100644
index 0000000..8e1b937
--- /dev/null
+++ b/home-config/nix-home-manager/flake.nix
@@ -0,0 +1,39 @@
1{
2 description = "Home Manager configuration of ryan";
3
4 inputs = {
5 # Specify the source of Home Manager and Nixpkgs.
6 nixpkgs.url = "github:nixos/nixpkgs/nixos-unstable";
7 home-manager = {
8 url = "github:nix-community/home-manager";
9 inputs.nixpkgs.follows = "nixpkgs";
10 };
11 hyprpicker-git = {
12 url = "github:hyprwm/hyprpicker";
13 inputs.nixpkgs.follows = "nixpkgs";
14 };
15 };
16
17 outputs = { nixpkgs, home-manager, hyprpicker-git, ... }:
18 let
19 system = "x86_64-linux";
20 pkgs = nixpkgs.legacyPackages.${system};
21 overlays = [
22 hyprpicker-git.overlays.default
23 ];
24 in {
25 homeConfigurations."ryan" = home-manager.lib.homeManagerConfiguration {
26 inherit pkgs;
27
28 # Specify your home configuration modules here, for example,
29 # the path to your home.nix.
30 modules = [
31 ./home.nix
32 {nixpkgs.overlays = overlays;}
33 ];
34
35 # Optionally use extraSpecialArgs
36 # to pass through arguments to home.nix
37 };
38 };
39}