summaryrefslogtreecommitdiff
path: root/home-config/nix-home-manager/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home-config/nix-home-manager/flake.nix')
-rw-r--r--home-config/nix-home-manager/flake.nix7
1 files changed, 6 insertions, 1 deletions
diff --git a/home-config/nix-home-manager/flake.nix b/home-config/nix-home-manager/flake.nix
index 8e1b937..88405d0 100644
--- a/home-config/nix-home-manager/flake.nix
+++ b/home-config/nix-home-manager/flake.nix
@@ -12,9 +12,13 @@
12 url = "github:hyprwm/hyprpicker"; 12 url = "github:hyprwm/hyprpicker";
13 inputs.nixpkgs.follows = "nixpkgs"; 13 inputs.nixpkgs.follows = "nixpkgs";
14 }; 14 };
15 superfile = {
16 url = "github:MHNightCat/superfile";
17 inputs.nixpkgs.follows = "nixpkgs";
18 };
15 }; 19 };
16 20
17 outputs = { nixpkgs, home-manager, hyprpicker-git, ... }: 21 outputs = { nixpkgs, home-manager, hyprpicker-git, superfile, ... }:
18 let 22 let
19 system = "x86_64-linux"; 23 system = "x86_64-linux";
20 pkgs = nixpkgs.legacyPackages.${system}; 24 pkgs = nixpkgs.legacyPackages.${system};
@@ -34,6 +38,7 @@
34 38
35 # Optionally use extraSpecialArgs 39 # Optionally use extraSpecialArgs
36 # to pass through arguments to home.nix 40 # to pass through arguments to home.nix
41 extraSpecialArgs = {inherit inputs;};
37 }; 42 };
38 }; 43 };
39} 44}