diff options
Diffstat (limited to 'home-config')
-rw-r--r-- | home-config/aerc/aerc.conf | 2 | ||||
-rw-r--r-- | home-config/alacritty/alacritty.yml | 2 | ||||
-rw-r--r-- | home-config/home-configuration.scm | 4 | ||||
-rw-r--r-- | home-config/nix-home-manager/home.nix | 3 | ||||
-rw-r--r-- | home-config/nvim/config/after/ftplugin/mail/custom.vim | 2 | ||||
-rw-r--r-- | home-config/waybar/config | 5 |
6 files changed, 16 insertions, 2 deletions
diff --git a/home-config/aerc/aerc.conf b/home-config/aerc/aerc.conf index ac4cbcb..5ccd325 100644 --- a/home-config/aerc/aerc.conf +++ b/home-config/aerc/aerc.conf | |||
@@ -64,6 +64,8 @@ log-level=trace | |||
64 | # Default: date<20,name<17,flags>4,subject<* | 64 | # Default: date<20,name<17,flags>4,subject<* |
65 | #index-columns=date<20,name<17,flags>4,subject<* | 65 | #index-columns=date<20,name<17,flags>4,subject<* |
66 | 66 | ||
67 | spinner = '/,-,\,|' | ||
68 | |||
67 | # | 69 | # |
68 | # Each name in index-columns must have a corresponding column-$name setting. | 70 | # Each name in index-columns must have a corresponding column-$name setting. |
69 | # All column-$name settings accept golang text/template syntax. See | 71 | # All column-$name settings accept golang text/template syntax. See |
diff --git a/home-config/alacritty/alacritty.yml b/home-config/alacritty/alacritty.yml index becd2f6..4fbd991 100644 --- a/home-config/alacritty/alacritty.yml +++ b/home-config/alacritty/alacritty.yml | |||
@@ -1,3 +1,5 @@ | |||
1 | window: | ||
2 | opacity: 0.70 | ||
1 | font: | 3 | font: |
2 | size: 15 | 4 | size: 15 |
3 | normal: | 5 | normal: |
diff --git a/home-config/home-configuration.scm b/home-config/home-configuration.scm index f9fb2fd..9a67cf5 100644 --- a/home-config/home-configuration.scm +++ b/home-config/home-configuration.scm | |||
@@ -36,12 +36,14 @@ | |||
36 | "libnotify" | 36 | "libnotify" |
37 | "fzf" | 37 | "fzf" |
38 | "waypipe" | 38 | "waypipe" |
39 | "gnunet" | ||
39 | "qrencode" | 40 | "qrencode" |
40 | "binutils" | 41 | "binutils" |
41 | "gcc-toolchain" | 42 | "gcc-toolchain" |
42 | "borg" | 43 | "borg" |
43 | "restic" | 44 | "restic" |
44 | "rsync" | 45 | "rsync" |
46 | "cloc" | ||
45 | "pv" | 47 | "pv" |
46 | "python-msgpack" | 48 | "python-msgpack" |
47 | "libreoffice" | 49 | "libreoffice" |
@@ -49,6 +51,7 @@ | |||
49 | "gnupg" | 51 | "gnupg" |
50 | "lsof" | 52 | "lsof" |
51 | "pavucontrol" | 53 | "pavucontrol" |
54 | "netcat" | ||
52 | "bind:utils" | 55 | "bind:utils" |
53 | "font-cns11643" | 56 | "font-cns11643" |
54 | "syncthing" | 57 | "syncthing" |
@@ -110,6 +113,7 @@ | |||
110 | (service home-xdg-configuration-files-service-type | 113 | (service home-xdg-configuration-files-service-type |
111 | `(("nvim/init.vim" ,(local-file "nvim/config/init.vim")) | 114 | `(("nvim/init.vim" ,(local-file "nvim/config/init.vim")) |
112 | ("nvim/after/ftplugin/markdown/custom.vim" ,(local-file "nvim/config/after/ftplugin/markdown/custom.vim")) | 115 | ("nvim/after/ftplugin/markdown/custom.vim" ,(local-file "nvim/config/after/ftplugin/markdown/custom.vim")) |
116 | ("nvim/after/ftplugin/mail/custom.vim" ,(local-file "nvim/config/after/ftplugin/mail/custom.vim")) | ||
113 | ("sway" ,(local-file "sway" #:recursive? #t)) | 117 | ("sway" ,(local-file "sway" #:recursive? #t)) |
114 | ("hypr" ,(local-file "hypr" #:recursive? #t)) | 118 | ("hypr" ,(local-file "hypr" #:recursive? #t)) |
115 | ("waybar" ,(local-file "waybar" #:recursive? #t)) | 119 | ("waybar" ,(local-file "waybar" #:recursive? #t)) |
diff --git a/home-config/nix-home-manager/home.nix b/home-config/nix-home-manager/home.nix index f5833e4..8a37125 100644 --- a/home-config/nix-home-manager/home.nix +++ b/home-config/nix-home-manager/home.nix | |||
@@ -30,6 +30,9 @@ | |||
30 | yt-dlp | 30 | yt-dlp |
31 | xdg-desktop-portal-hyprland | 31 | xdg-desktop-portal-hyprland |
32 | pass | 32 | pass |
33 | rustup | ||
34 | gcc | ||
35 | pkg-config | ||
33 | 36 | ||
34 | # # It is sometimes useful to fine-tune packages, for example, by applying | 37 | # # It is sometimes useful to fine-tune packages, for example, by applying |
35 | # # overrides. You can do that directly here, just don't forget the | 38 | # # overrides. You can do that directly here, just don't forget the |
diff --git a/home-config/nvim/config/after/ftplugin/mail/custom.vim b/home-config/nvim/config/after/ftplugin/mail/custom.vim new file mode 100644 index 0000000..41ad2e4 --- /dev/null +++ b/home-config/nvim/config/after/ftplugin/mail/custom.vim | |||
@@ -0,0 +1,2 @@ | |||
1 | setlocal tw=0 | ||
2 | setlocal lbr | ||
diff --git a/home-config/waybar/config b/home-config/waybar/config index 651d2ab..3dff06a 100644 --- a/home-config/waybar/config +++ b/home-config/waybar/config | |||
@@ -9,8 +9,9 @@ | |||
9 | "hyprland/submap": { | 9 | "hyprland/submap": { |
10 | "format": " {}" | 10 | "format": " {}" |
11 | }, | 11 | }, |
12 | "wlr/workspaces": { | 12 | "hyprland/workspaces": { |
13 | "format": "{name}", | 13 | "format": "{id}", |
14 | "all-outputs": false, | ||
14 | "disable-scroll": true | 15 | "disable-scroll": true |
15 | }, | 16 | }, |
16 | "hyprland/window": { | 17 | "hyprland/window": { |