summaryrefslogtreecommitdiff
path: root/home-config
diff options
context:
space:
mode:
Diffstat (limited to 'home-config')
-rw-r--r--home-config/bashrc3
-rw-r--r--home-config/nix-home-manager/home.nix8
-rw-r--r--home-config/waybar/config19
3 files changed, 28 insertions, 2 deletions
diff --git a/home-config/bashrc b/home-config/bashrc
index d28af9d..0c61ee6 100644
--- a/home-config/bashrc
+++ b/home-config/bashrc
@@ -50,3 +50,6 @@ export XDG_DATA_DIRS=$XDG_DATA_DIRS:/var/lib/flatpak/exports/share:/home/ryan/.l
50#export SSH_AUTH_SOCK=$(gpgconf --list-dirs agent-ssh-socket) 50#export SSH_AUTH_SOCK=$(gpgconf --list-dirs agent-ssh-socket)
51#gpgconf --launch gpg-agent 51#gpgconf --launch gpg-agent
52export GPG_TTY=$(tty) 52export GPG_TTY=$(tty)
53
54# Setup zoxide for cd command provider
55eval "$(zoxide init --cmd cd bash)"
diff --git a/home-config/nix-home-manager/home.nix b/home-config/nix-home-manager/home.nix
index 5c0ee46..aa90213 100644
--- a/home-config/nix-home-manager/home.nix
+++ b/home-config/nix-home-manager/home.nix
@@ -15,6 +15,12 @@
15 # release notes. 15 # release notes.
16 home.stateVersion = "22.11"; # Please read the comment before changing. 16 home.stateVersion = "22.11"; # Please read the comment before changing.
17 17
18 # Enable nix flakes
19 nix = {
20 package = pkgs.nix;
21 settings.experimental-features = [ "nix-command" "flakes" ];
22 };
23
18 # This value will set some environment variables to allow home-manager to 24 # This value will set some environment variables to allow home-manager to
19 # function better outside of NixOS 25 # function better outside of NixOS
20 nixpkgs.config.allowUnfree = true; 26 nixpkgs.config.allowUnfree = true;
@@ -30,12 +36,12 @@
30 yt-dlp 36 yt-dlp
31 #pass 37 #pass
32 rustup 38 rustup
39 zoxide
33 nodePackages.pnpm 40 nodePackages.pnpm
34 gcc 41 gcc
35 pkg-config 42 pkg-config
36 wttrbar 43 wttrbar
37 swww 44 swww
38 hyprpicker
39 wl-clip-persist 45 wl-clip-persist
40 gifski 46 gifski
41 waypaper 47 waypaper
diff --git a/home-config/waybar/config b/home-config/waybar/config
index 8721a6a..99a7bef 100644
--- a/home-config/waybar/config
+++ b/home-config/waybar/config
@@ -5,7 +5,7 @@
5 5
6 "modules-left": ["hyprland/workspaces", "hyprland/submap"], 6 "modules-left": ["hyprland/workspaces", "hyprland/submap"],
7 "modules-center": ["hyprland/window"], 7 "modules-center": ["hyprland/window"],
8 "modules-right": ["tray", "custom/spotify", "custom/weather", "custom/mail", "custom/storage", "backlight", "bluetooth", "pulseaudio", "network", "idle_inhibitor", "battery", "clock"], 8 "modules-right": ["tray", "custom/spotify", "privacy", "custom/weather", "custom/mail", "custom/storage", "backlight", "bluetooth", "pulseaudio", "network", "idle_inhibitor", "battery", "clock"],
9 "hyprland/submap": { 9 "hyprland/submap": {
10 "format": " {}" 10 "format": " {}"
11 }, 11 },
@@ -59,6 +59,23 @@
59 "on-click": "foot -t alacritty doas nmtui", 59 "on-click": "foot -t alacritty doas nmtui",
60 "tooltip": false 60 "tooltip": false
61 }, 61 },
62 "privacy": {
63 "icon-spacing":4,
64 "icon-size":18,
65 "transition-duration":250,
66 "modules": [
67 {
68 "type":"screenshare",
69 "tooltip":true,
70 "tooltip-icon-size":24
71 },
72 {
73 "type":"audio-in",
74 "tooltip":true,
75 "tooltip-icon-size":24
76 }
77 ]
78 },
62 "pulseaudio": { 79 "pulseaudio": {
63 "format-alt": "{icon}", 80 "format-alt": "{icon}",
64 "format": "{volume} {icon}", 81 "format": "{volume} {icon}",