mirror of
https://git.in.rschanz.org/ryan77627/guix-config.git
synced 2024-11-07 07:36:09 -05:00
128 lines
3.8 KiB
Nix
128 lines
3.8 KiB
Nix
{ config, pkgs, hyprland, nixgl, ... }:
|
|
|
|
{
|
|
# Home Manager needs a bit of information about you and the paths it should
|
|
# manage.
|
|
home.username = "ryan";
|
|
home.homeDirectory = "/home/ryan";
|
|
|
|
# This value determines the Home Manager release that your configuration is
|
|
# compatible with. This helps avoid breakage when a new Home Manager release
|
|
# introduces backwards incompatible changes.
|
|
#
|
|
# You should not change this value, even if you update Home Manager. If you do
|
|
# want to update the value, then make sure to first check the Home Manager
|
|
# release notes.
|
|
home.stateVersion = "23.11"; # Please read the comment before changing.
|
|
|
|
# This value will set some environment variables to allow home-manager to
|
|
# function better outside of NixOS
|
|
nixpkgs.config.allowUnfree = true;
|
|
#targets.genericLinux.enable = true;
|
|
fonts.fontconfig.enable = true;
|
|
fonts.fontconfig.defaultFonts = {
|
|
monospace = [ "DejaVu Sans Mono" ];
|
|
sansSerif = [ "DejaVu Sans" ];
|
|
serif = [ "DejaVu Serif" ];
|
|
};
|
|
|
|
# wayland.windowManager.hyprland.enable = true;
|
|
|
|
# The home.packages option allows you to install Nix packages into your
|
|
# environment.
|
|
home.packages = with pkgs; [
|
|
# # Adds the 'hello' command to your environment. It prints a friendly
|
|
# # "Hello, world!" when run.
|
|
# pkgs.hello
|
|
yt-dlp
|
|
#pass
|
|
rustup
|
|
zoxide
|
|
nodePackages.pnpm
|
|
gcc
|
|
aerc
|
|
pkg-config
|
|
wttrbar
|
|
wl-clip-persist
|
|
gifski
|
|
waypaper
|
|
gdu
|
|
spotify-player
|
|
hyprpicker
|
|
xwayland
|
|
xdg-desktop-portal
|
|
xdg-desktop-portal-gtk
|
|
mpv
|
|
imv
|
|
libva
|
|
libvdpau
|
|
wpaperd
|
|
hypridle
|
|
latest.firefox-nightly-bin
|
|
eza
|
|
|
|
# Wrapped programs for some env variables
|
|
(pkgs.writeScriptBin "hyprlock" ''
|
|
#! ${pkgs.bash}/bin/bash
|
|
export LD_PRELOAD="/run/current-system/profile/lib/libpam.so.0:/run/current-system/profile/lib/libfontconfig.so:$LD_PRELOAD"
|
|
exec ${pkgs.hyprlock}/bin/hyprlock "$@"
|
|
'')
|
|
|
|
# Flakes specific things defined in flake.nix
|
|
hyprland.packages.${pkgs.system}.default
|
|
hyprland.packages.${pkgs.system}.xdg-desktop-portal-hyprland
|
|
nixgl.packages.${pkgs.system}.nixGLIntel
|
|
|
|
# Fonts!
|
|
noto-fonts
|
|
dejavu_fonts
|
|
liberation_ttf
|
|
noto-fonts-cjk-sans
|
|
noto-fonts-emoji
|
|
|
|
# # It is sometimes useful to fine-tune packages, for example, by applying
|
|
# # overrides. You can do that directly here, just don't forget the
|
|
# # parentheses. Maybe you want to install Nerd Fonts with a limited number of
|
|
# # fonts?
|
|
# (pkgs.nerdfonts.override { fonts = [ "FantasqueSansMono" ]; })
|
|
|
|
# # You can also create simple shell scripts directly inside your
|
|
# # configuration. For example, this adds a command 'my-hello' to your
|
|
# # environment:
|
|
# (pkgs.writeShellScriptBin "my-hello" ''
|
|
# echo "Hello, ${config.home.username}!"
|
|
# '')
|
|
];
|
|
|
|
# Home Manager is pretty good at managing dotfiles. The primary way to manage
|
|
# plain files is through 'home.file'.
|
|
home.file = {
|
|
# # Building this configuration will create a copy of 'dotfiles/screenrc' in
|
|
# # the Nix store. Activating the configuration will then make '~/.screenrc' a
|
|
# # symlink to the Nix store copy.
|
|
# ".screenrc".source = dotfiles/screenrc;
|
|
|
|
# # You can also set the file content immediately.
|
|
# ".gradle/gradle.properties".text = ''
|
|
# org.gradle.console=verbose
|
|
# org.gradle.daemon.idletimeout=3600000
|
|
# '';
|
|
};
|
|
|
|
# You can also manage environment variables but you will have to manually
|
|
# source
|
|
#
|
|
# ~/.nix-profile/etc/profile.d/hm-session-vars.sh
|
|
#
|
|
# or
|
|
#
|
|
# /etc/profiles/per-user/ryan/etc/profile.d/hm-session-vars.sh
|
|
#
|
|
# if you don't want to manage your shell through Home Manager.
|
|
home.sessionVariables = {
|
|
# EDITOR = "emacs";
|
|
};
|
|
|
|
# Let Home Manager install and manage itself.
|
|
programs.home-manager.enable = true;
|
|
}
|