mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-12-24 21:38:07 -05:00
gnu: reptyr: Update to 0.7.0.
* gnu/packages/screen.scm (reptyr): Update to 0.7.0. [source]: Remove patch. [arguments]: Add bash completion directory name. * gnu/packages/patches/reptyr-fix-gcc-7.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
This commit is contained in:
parent
6da31b3c7b
commit
01307bba9c
3 changed files with 12 additions and 49 deletions
|
@ -1218,7 +1218,6 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/readline-6.2-CVE-2014-2524.patch \
|
%D%/packages/patches/readline-6.2-CVE-2014-2524.patch \
|
||||||
%D%/packages/patches/red-eclipse-remove-gamma-name-hack.patch \
|
%D%/packages/patches/red-eclipse-remove-gamma-name-hack.patch \
|
||||||
%D%/packages/patches/reposurgeon-add-missing-docbook-files.patch \
|
%D%/packages/patches/reposurgeon-add-missing-docbook-files.patch \
|
||||||
%D%/packages/patches/reptyr-fix-gcc-7.patch \
|
|
||||||
%D%/packages/patches/ripperx-missing-file.patch \
|
%D%/packages/patches/ripperx-missing-file.patch \
|
||||||
%D%/packages/patches/rpcbind-CVE-2017-8779.patch \
|
%D%/packages/patches/rpcbind-CVE-2017-8779.patch \
|
||||||
%D%/packages/patches/rtags-separate-rct.patch \
|
%D%/packages/patches/rtags-separate-rct.patch \
|
||||||
|
|
|
@ -1,38 +0,0 @@
|
||||||
This patch allows reptyr to build with gcc 7. It is taken from reptyr mainline patches
|
|
||||||
fa0d63f and b45fd92.
|
|
||||||
|
|
||||||
https://github.com/nelhage/reptyr/commit/fa0d63ff8c488be15976e5353580b565e85586a1
|
|
||||||
https://github.com/nelhage/reptyr/commit/b45fd9238958fcf2d8f3d6fc23e6d491febea2ac
|
|
||||||
|
|
||||||
Patch by Nelson Elhage <nelhage@nelhage.com>.
|
|
||||||
|
|
||||||
diff --git a/attach.c b/attach.c
|
|
||||||
index bd8ef8c..8d9cbf8 100644
|
|
||||||
--- a/attach.c
|
|
||||||
+++ b/attach.c
|
|
||||||
@@ -389,8 +389,11 @@ int setup_steal_socket(struct steal_pty_state *steal) {
|
|
||||||
return errno;
|
|
||||||
|
|
||||||
steal->addr_un.sun_family = AF_UNIX;
|
|
||||||
- snprintf(steal->addr_un.sun_path, sizeof(steal->addr_un.sun_path),
|
|
||||||
- "%s/reptyr.sock", steal->tmpdir);
|
|
||||||
+ if (snprintf(steal->addr_un.sun_path, sizeof(steal->addr_un.sun_path),
|
|
||||||
+ "%s/reptyr.sock", steal->tmpdir) >= sizeof(steal->addr_un.sun_path)) {
|
|
||||||
+ error("tmpdir path too long!");
|
|
||||||
+ return ENAMETOOLONG;
|
|
||||||
+ }
|
|
||||||
|
|
||||||
if ((steal->sockfd = socket(AF_UNIX, SOCK_DGRAM, 0)) < 0)
|
|
||||||
return errno;
|
|
||||||
diff --git a/platform/linux/linux.h b/platform/linux/linux.h
|
|
||||||
index 9e6b78a..3ec5a99 100644
|
|
||||||
--- a/platform/linux/linux.h
|
|
||||||
+++ b/platform/linux/linux.h
|
|
||||||
@@ -40,6 +40,7 @@
|
|
||||||
#include <sys/ptrace.h>
|
|
||||||
#include <asm/ptrace.h>
|
|
||||||
#include <sys/types.h>
|
|
||||||
+#include <sys/sysmacros.h>
|
|
||||||
#include <sys/user.h>
|
|
||||||
#include <unistd.h>
|
|
||||||
#include <stdlib.h>
|
|
|
@ -5,7 +5,7 @@
|
||||||
;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
|
;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
|
||||||
;;; Copyright © 2016 Alex Griffin <a@ajgrf.com>
|
;;; Copyright © 2016 Alex Griffin <a@ajgrf.com>
|
||||||
;;; Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
|
;;; Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
|
||||||
;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
|
;;; Copyright © 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
|
||||||
;;;
|
;;;
|
||||||
;;; This file is part of GNU Guix.
|
;;; This file is part of GNU Guix.
|
||||||
;;;
|
;;;
|
||||||
|
@ -153,23 +153,25 @@ (define-public byobu
|
||||||
(define-public reptyr
|
(define-public reptyr
|
||||||
(package
|
(package
|
||||||
(name "reptyr")
|
(name "reptyr")
|
||||||
(version "0.6.2")
|
(version "0.7.0")
|
||||||
(source
|
(source
|
||||||
(origin
|
(origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (string-append "https://github.com/nelhage/reptyr/archive"
|
(uri (string-append "https://github.com/nelhage/reptyr/archive"
|
||||||
"/reptyr-" version ".tar.gz"))
|
"/reptyr-" version ".tar.gz"))
|
||||||
;; XXX: To be removed on next reptyr release.
|
|
||||||
(patches (search-patches "reptyr-fix-gcc-7.patch"))
|
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32 "10s9blv8xljzfdn4xly5y2q66kd0ldj3wnflymsxb5g6r3s3kidi"))))
|
||||||
"07pfl0rkgm8m3f3jy8r9l2yvnhf8lgllpsk3mh57mhzdxq8fagf7"))))
|
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(arguments
|
(arguments
|
||||||
'(#:tests? #f ; no tests
|
'(#:tests? #f ; no tests
|
||||||
#:make-flags (list "CC=gcc"
|
#:make-flags
|
||||||
(string-append "PREFIX=" %output))
|
(list "CC=gcc"
|
||||||
#:phases (modify-phases %standard-phases (delete 'configure))))
|
(string-append "PREFIX=" (assoc-ref %outputs "out"))
|
||||||
|
(string-append "BASHCOMPDIR=" (assoc-ref %outputs "out")
|
||||||
|
"/etc/bash_completion.d"))
|
||||||
|
#:phases
|
||||||
|
(modify-phases %standard-phases
|
||||||
|
(delete 'configure)))) ; no configure script
|
||||||
(home-page "https://github.com/nelhage/reptyr")
|
(home-page "https://github.com/nelhage/reptyr")
|
||||||
(synopsis "Tool for reparenting a running program to a new terminal")
|
(synopsis "Tool for reparenting a running program to a new terminal")
|
||||||
(description
|
(description
|
||||||
|
|
Loading…
Reference in a new issue