mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 07:26:13 -05:00
gnu: Add perl-5.14.
* gnu/packages/patches/perl-5.14-autosplit-default-time.patch, gnu/packages/patches/perl-5.14-module-pluggable-search.patch, gnu/packages/patches/perl-5.14-no-sys-dirs.patch: New files. * gnu/local.mk (dist_patch_DATA): Add them. * gnu/packages/perl.scm (perl-5.14): New variable.
This commit is contained in:
parent
26d9e6c904
commit
013086c3db
5 changed files with 272 additions and 0 deletions
|
@ -1629,6 +1629,9 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/p11-kit-hurd.patch \
|
%D%/packages/patches/p11-kit-hurd.patch \
|
||||||
%D%/packages/patches/patchutils-test-perms.patch \
|
%D%/packages/patches/patchutils-test-perms.patch \
|
||||||
%D%/packages/patches/patch-hurd-path-max.patch \
|
%D%/packages/patches/patch-hurd-path-max.patch \
|
||||||
|
%D%/packages/patches/perl-5.14-autosplit-default-time.patch \
|
||||||
|
%D%/packages/patches/perl-5.14-module-pluggable-search.patch \
|
||||||
|
%D%/packages/patches/perl-5.14-no-sys-dirs.patch \
|
||||||
%D%/packages/patches/perl-autosplit-default-time.patch \
|
%D%/packages/patches/perl-autosplit-default-time.patch \
|
||||||
%D%/packages/patches/perl-finance-quote-unuse-mozilla-ca.patch \
|
%D%/packages/patches/perl-finance-quote-unuse-mozilla-ca.patch \
|
||||||
%D%/packages/patches/perl-image-exiftool-CVE-2021-22204.patch \
|
%D%/packages/patches/perl-image-exiftool-CVE-2021-22204.patch \
|
||||||
|
|
15
gnu/packages/patches/perl-5.14-autosplit-default-time.patch
Normal file
15
gnu/packages/patches/perl-5.14-autosplit-default-time.patch
Normal file
|
@ -0,0 +1,15 @@
|
||||||
|
AutoSplit will fail to create an index for files whose modification time is 0
|
||||||
|
because its default time for a non-existent index is 1. Set this default time
|
||||||
|
to -1 instead.
|
||||||
|
|
||||||
|
--- perl-5.16.1/cpan/AutoLoader/lib/AutoSplit.pm.orig 2012-02-14 22:44:36.000000000 -0600
|
||||||
|
+++ perl-5.16.1/cpan/AutoLoader/lib/AutoSplit.pm 2015-09-09 19:59:22.208708921 -0500
|
||||||
|
@@ -361,7 +361,7 @@
|
||||||
|
my($al_idx_file) = catfile($autodir, $modpname, $IndexFile);
|
||||||
|
|
||||||
|
if ($check_mod_time){
|
||||||
|
- my($al_ts_time) = (stat("$al_idx_file"))[9] || 1;
|
||||||
|
+ my($al_ts_time) = (stat("$al_idx_file"))[9] || -1;
|
||||||
|
if ($al_ts_time >= $pm_mod_time and
|
||||||
|
$al_ts_time >= $self_mod_time){
|
||||||
|
print "AutoSplit skipped ($al_idx_file newer than $filename)\n"
|
25
gnu/packages/patches/perl-5.14-module-pluggable-search.patch
Normal file
25
gnu/packages/patches/perl-5.14-module-pluggable-search.patch
Normal file
|
@ -0,0 +1,25 @@
|
||||||
|
Fix core Perl module Module::Pluggable such that it can find plugins that live
|
||||||
|
in symlinked directories.
|
||||||
|
|
||||||
|
Patch borrowed/adapted from Nixpkgs.
|
||||||
|
|
||||||
|
--- perl-5.16.1/cpan/Module-Pluggable/lib/Module/Pluggable/Object.pm 2015-04-08 23:28:48.120164135 -0500
|
||||||
|
+++ perl-5.16.1/cpan/Module-Pluggable/lib/Module/Pluggable/Object.pm 2015-04-08 23:30:27.032166704 -0500
|
||||||
|
@@ -164,7 +164,7 @@
|
||||||
|
my $sp = catdir($dir, (split /::/, $searchpath));
|
||||||
|
|
||||||
|
# if it doesn't exist or it's not a dir then skip it
|
||||||
|
- next unless ( -e $sp && -d _ ); # Use the cached stat the second time
|
||||||
|
+ next unless ( -e $sp );
|
||||||
|
|
||||||
|
my @files = $self->find_files($sp);
|
||||||
|
|
||||||
|
@@ -279,7 +279,7 @@
|
||||||
|
(my $path = $File::Find::name) =~ s#^\\./##;
|
||||||
|
push @files, $path;
|
||||||
|
}
|
||||||
|
- }, $search_path );
|
||||||
|
+ }, "$search_path/." );
|
||||||
|
}
|
||||||
|
#chdir $cwd;
|
||||||
|
return @files;
|
156
gnu/packages/patches/perl-5.14-no-sys-dirs.patch
Normal file
156
gnu/packages/patches/perl-5.14-no-sys-dirs.patch
Normal file
|
@ -0,0 +1,156 @@
|
||||||
|
Don't long for headers and libraries in "traditional" locations.
|
||||||
|
|
||||||
|
Patch from Nixpkgs by Eelco Dolstra <eelco.dolstra@logicblox.com>.
|
||||||
|
|
||||||
|
diff -ru -x '*~' perl-5.14.2-orig/Configure perl-5.14.2/Configure
|
||||||
|
--- perl-5.14.2-orig/Configure 2011-09-26 11:44:34.000000000 +0200
|
||||||
|
+++ perl-5.14.2/Configure 2012-01-20 17:05:23.089223129 +0100
|
||||||
|
@@ -106,15 +106,7 @@
|
||||||
|
fi
|
||||||
|
|
||||||
|
: Proper PATH setting
|
||||||
|
-paths='/bin /usr/bin /usr/local/bin /usr/ucb /usr/local /usr/lbin'
|
||||||
|
-paths="$paths /opt/bin /opt/local/bin /opt/local /opt/lbin"
|
||||||
|
-paths="$paths /usr/5bin /etc /usr/gnu/bin /usr/new /usr/new/bin /usr/nbin"
|
||||||
|
-paths="$paths /opt/gnu/bin /opt/new /opt/new/bin /opt/nbin"
|
||||||
|
-paths="$paths /sys5.3/bin /sys5.3/usr/bin /bsd4.3/bin /bsd4.3/usr/ucb"
|
||||||
|
-paths="$paths /bsd4.3/usr/bin /usr/bsd /bsd43/bin /opt/ansic/bin /usr/ccs/bin"
|
||||||
|
-paths="$paths /etc /usr/lib /usr/ucblib /lib /usr/ccs/lib"
|
||||||
|
-paths="$paths /sbin /usr/sbin /usr/libexec"
|
||||||
|
-paths="$paths /system/gnu_library/bin"
|
||||||
|
+paths=''
|
||||||
|
|
||||||
|
for p in $paths
|
||||||
|
do
|
||||||
|
@@ -1311,8 +1303,7 @@
|
||||||
|
archname=''
|
||||||
|
: Possible local include directories to search.
|
||||||
|
: Set locincpth to "" in a hint file to defeat local include searches.
|
||||||
|
-locincpth="/usr/local/include /opt/local/include /usr/gnu/include"
|
||||||
|
-locincpth="$locincpth /opt/gnu/include /usr/GNU/include /opt/GNU/include"
|
||||||
|
+locincpth=""
|
||||||
|
:
|
||||||
|
: no include file wanted by default
|
||||||
|
inclwanted=''
|
||||||
|
@@ -1328,17 +1319,12 @@
|
||||||
|
archobjs=''
|
||||||
|
libnames=''
|
||||||
|
: change the next line if compiling for Xenix/286 on Xenix/386
|
||||||
|
-xlibpth='/usr/lib/386 /lib/386'
|
||||||
|
+xlibpth=''
|
||||||
|
: Possible local library directories to search.
|
||||||
|
-loclibpth="/usr/local/lib /opt/local/lib /usr/gnu/lib"
|
||||||
|
-loclibpth="$loclibpth /opt/gnu/lib /usr/GNU/lib /opt/GNU/lib"
|
||||||
|
+loclibpth=""
|
||||||
|
|
||||||
|
: general looking path for locating libraries
|
||||||
|
-glibpth="/lib /usr/lib $xlibpth"
|
||||||
|
-glibpth="$glibpth /usr/ccs/lib /usr/ucblib /usr/local/lib"
|
||||||
|
-test -f /usr/shlib/libc.so && glibpth="/usr/shlib $glibpth"
|
||||||
|
-test -f /shlib/libc.so && glibpth="/shlib $glibpth"
|
||||||
|
-test -d /usr/lib64 && glibpth="$glibpth /lib64 /usr/lib64 /usr/local/lib64"
|
||||||
|
+glibpth=""
|
||||||
|
|
||||||
|
: Private path used by Configure to find libraries. Its value
|
||||||
|
: is prepended to libpth. This variable takes care of special
|
||||||
|
@@ -1371,8 +1357,6 @@
|
||||||
|
libswanted="$libswanted m crypt sec util c cposix posix ucb bsd BSD"
|
||||||
|
: We probably want to search /usr/shlib before most other libraries.
|
||||||
|
: This is only used by the lib/ExtUtils/MakeMaker.pm routine extliblist.
|
||||||
|
-glibpth=`echo " $glibpth " | sed -e 's! /usr/shlib ! !'`
|
||||||
|
-glibpth="/usr/shlib $glibpth"
|
||||||
|
: Do not use vfork unless overridden by a hint file.
|
||||||
|
usevfork=false
|
||||||
|
|
||||||
|
@@ -2380,7 +2364,6 @@
|
||||||
|
zip
|
||||||
|
"
|
||||||
|
pth=`echo $PATH | sed -e "s/$p_/ /g"`
|
||||||
|
-pth="$pth /lib /usr/lib"
|
||||||
|
for file in $loclist; do
|
||||||
|
eval xxx=\$$file
|
||||||
|
case "$xxx" in
|
||||||
|
@@ -4785,7 +4768,7 @@
|
||||||
|
: Set private lib path
|
||||||
|
case "$plibpth" in
|
||||||
|
'') if ./mips; then
|
||||||
|
- plibpth="$incpath/usr/lib /usr/local/lib /usr/ccs/lib"
|
||||||
|
+ plibpth="$incpath/usr/lib"
|
||||||
|
fi;;
|
||||||
|
esac
|
||||||
|
case "$libpth" in
|
||||||
|
@@ -8390,13 +8373,8 @@
|
||||||
|
echo " "
|
||||||
|
case "$sysman" in
|
||||||
|
'')
|
||||||
|
- syspath='/usr/share/man/man1 /usr/man/man1'
|
||||||
|
- syspath="$syspath /usr/man/mann /usr/man/manl /usr/man/local/man1"
|
||||||
|
- syspath="$syspath /usr/man/u_man/man1"
|
||||||
|
- syspath="$syspath /usr/catman/u_man/man1 /usr/man/l_man/man1"
|
||||||
|
- syspath="$syspath /usr/local/man/u_man/man1 /usr/local/man/l_man/man1"
|
||||||
|
- syspath="$syspath /usr/man/man.L /local/man/man1 /usr/local/man/man1"
|
||||||
|
- sysman=`./loc . /usr/man/man1 $syspath`
|
||||||
|
+ syspath=''
|
||||||
|
+ sysman=''
|
||||||
|
;;
|
||||||
|
esac
|
||||||
|
if $test -d "$sysman"; then
|
||||||
|
@@ -19721,9 +19699,10 @@
|
||||||
|
case "$full_ar" in
|
||||||
|
'') full_ar=$ar ;;
|
||||||
|
esac
|
||||||
|
+full_ar=ar
|
||||||
|
|
||||||
|
: Store the full pathname to the sed program for use in the C program
|
||||||
|
-full_sed=$sed
|
||||||
|
+full_sed=sed
|
||||||
|
|
||||||
|
: see what type gids are declared as in the kernel
|
||||||
|
echo " "
|
||||||
|
diff -ru -x '*~' perl-5.14.2-orig/ext/Errno/Errno_pm.PL perl-5.14.2/ext/Errno/Errno_pm.PL
|
||||||
|
--- perl-5.14.2-orig/ext/Errno/Errno_pm.PL 2011-09-26 11:44:34.000000000 +0200
|
||||||
|
+++ perl-5.14.2/ext/Errno/Errno_pm.PL 2012-01-20 17:02:07.938138311 +0100
|
||||||
|
@@ -137,11 +137,7 @@
|
||||||
|
if ($dep =~ /(\S+errno\.h)/) {
|
||||||
|
$file{$1} = 1;
|
||||||
|
}
|
||||||
|
- } elsif ($^O eq 'linux' &&
|
||||||
|
- $Config{gccversion} ne '' &&
|
||||||
|
- $Config{gccversion} !~ /intel/i
|
||||||
|
- # might be using, say, Intel's icc
|
||||||
|
- ) {
|
||||||
|
+ } elsif (0) {
|
||||||
|
# Some Linuxes have weird errno.hs which generate
|
||||||
|
# no #file or #line directives
|
||||||
|
my $linux_errno_h = -e '/usr/include/errno.h' ?
|
||||||
|
diff -ru -x '*~' perl-5.14.2-orig/hints/freebsd.sh perl-5.14.2/hints/freebsd.sh
|
||||||
|
--- perl-5.14.2-orig/hints/freebsd.sh 2011-09-19 15:18:22.000000000 +0200
|
||||||
|
+++ perl-5.14.2/hints/freebsd.sh 2012-01-20 17:10:37.267924044 +0100
|
||||||
|
@@ -118,21 +118,21 @@
|
||||||
|
objformat=`/usr/bin/objformat`
|
||||||
|
if [ x$objformat = xaout ]; then
|
||||||
|
if [ -e /usr/lib/aout ]; then
|
||||||
|
- libpth="/usr/lib/aout /usr/local/lib /usr/lib"
|
||||||
|
- glibpth="/usr/lib/aout /usr/local/lib /usr/lib"
|
||||||
|
+ libpth=""
|
||||||
|
+ glibpth=""
|
||||||
|
fi
|
||||||
|
lddlflags='-Bshareable'
|
||||||
|
else
|
||||||
|
- libpth="/usr/lib /usr/local/lib"
|
||||||
|
- glibpth="/usr/lib /usr/local/lib"
|
||||||
|
+ libpth=""
|
||||||
|
+ glibpth=""
|
||||||
|
ldflags="-Wl,-E "
|
||||||
|
lddlflags="-shared "
|
||||||
|
fi
|
||||||
|
cccdlflags='-DPIC -fPIC'
|
||||||
|
;;
|
||||||
|
*)
|
||||||
|
- libpth="/usr/lib /usr/local/lib"
|
||||||
|
- glibpth="/usr/lib /usr/local/lib"
|
||||||
|
+ libpth=""
|
||||||
|
+ glibpth=""
|
||||||
|
ldflags="-Wl,-E "
|
||||||
|
lddlflags="-shared "
|
||||||
|
cccdlflags='-DPIC -fPIC'
|
|
@ -65,6 +65,7 @@ (define-module (gnu packages perl)
|
||||||
#:use-module (gnu packages databases)
|
#:use-module (gnu packages databases)
|
||||||
#:use-module (gnu packages fontutils)
|
#:use-module (gnu packages fontutils)
|
||||||
#:use-module (gnu packages freedesktop)
|
#:use-module (gnu packages freedesktop)
|
||||||
|
#:use-module (gnu packages gcc)
|
||||||
#:use-module (gnu packages gd)
|
#:use-module (gnu packages gd)
|
||||||
#:use-module (gnu packages gl)
|
#:use-module (gnu packages gl)
|
||||||
#:use-module (gnu packages gtk)
|
#:use-module (gnu packages gtk)
|
||||||
|
@ -258,6 +259,78 @@ (define-public perl
|
||||||
(home-page "https://www.perl.org/")
|
(home-page "https://www.perl.org/")
|
||||||
(license license:gpl1+))) ; or "Artistic"
|
(license license:gpl1+))) ; or "Artistic"
|
||||||
|
|
||||||
|
(define-public perl-5.14
|
||||||
|
(package
|
||||||
|
(name "perl")
|
||||||
|
(version "5.14.4")
|
||||||
|
(source (origin
|
||||||
|
(method url-fetch)
|
||||||
|
(uri (string-append "mirror://cpan/src/5.0/perl-"
|
||||||
|
version ".tar.gz"))
|
||||||
|
(sha256
|
||||||
|
(base32
|
||||||
|
"1js47zzna3v38fjnirf2vq6y0rjp8m86ysj5vagzgkig956d8gw0"))
|
||||||
|
(patches (search-patches
|
||||||
|
"perl-5.14-no-sys-dirs.patch"
|
||||||
|
"perl-5.14-autosplit-default-time.patch"
|
||||||
|
"perl-5.14-module-pluggable-search.patch"))))
|
||||||
|
(properties `((release-date . "2013-03-10")))
|
||||||
|
(build-system gnu-build-system)
|
||||||
|
(arguments
|
||||||
|
'(#:tests? #f
|
||||||
|
#:phases
|
||||||
|
(modify-phases %standard-phases
|
||||||
|
(replace 'configure
|
||||||
|
(lambda* (#:key inputs outputs #:allow-other-keys)
|
||||||
|
(let ((out (assoc-ref outputs "out"))
|
||||||
|
(libc (assoc-ref inputs "libc")))
|
||||||
|
;; Use the right path for `pwd'.
|
||||||
|
(substitute* "dist/Cwd/Cwd.pm"
|
||||||
|
(("/bin/pwd")
|
||||||
|
(which "pwd")))
|
||||||
|
|
||||||
|
(invoke "./Configure"
|
||||||
|
(string-append "-Dprefix=" out)
|
||||||
|
(string-append "-Dman1dir=" out "/share/man/man1")
|
||||||
|
(string-append "-Dman3dir=" out "/share/man/man3")
|
||||||
|
"-de" "-Dcc=gcc"
|
||||||
|
"-Uinstallusrbinperl"
|
||||||
|
"-Dinstallstyle=lib/perl5"
|
||||||
|
"-Duseshrplib"
|
||||||
|
(string-append "-Dlocincpth=" libc "/include")
|
||||||
|
(string-append "-Dloclibpth=" libc "/lib")
|
||||||
|
|
||||||
|
;; Force the library search path to contain only libc
|
||||||
|
;; because it is recorded in Config.pm and
|
||||||
|
;; Config_heavy.pl; we don't want to keep a reference
|
||||||
|
;; to everything that's in $LIBRARY_PATH at build
|
||||||
|
;; time (Binutils, bzip2, file, etc.)
|
||||||
|
(string-append "-Dlibpth=" libc "/lib")
|
||||||
|
(string-append "-Dplibpth=" libc "/lib")))))
|
||||||
|
|
||||||
|
(add-before 'strip 'make-shared-objects-writable
|
||||||
|
(lambda* (#:key outputs #:allow-other-keys)
|
||||||
|
;; The 'lib/perl5' directory contains ~50 MiB of .so. Make them
|
||||||
|
;; writable so that 'strip' actually strips them.
|
||||||
|
(let* ((out (assoc-ref outputs "out"))
|
||||||
|
(lib (string-append out "/lib")))
|
||||||
|
(for-each (lambda (dso)
|
||||||
|
(chmod dso #o755))
|
||||||
|
(find-files lib "\\.so$"))))))))
|
||||||
|
(native-inputs
|
||||||
|
(list gcc-7))
|
||||||
|
(native-search-paths (list (search-path-specification
|
||||||
|
(variable "PERL5LIB")
|
||||||
|
(files '("lib/perl5/site_perl")))))
|
||||||
|
(home-page "https://www.perl.org/")
|
||||||
|
(synopsis "Implementation of the Perl programming language")
|
||||||
|
(description
|
||||||
|
"Perl is a general-purpose programming language originally developed for
|
||||||
|
text manipulation and now used for a wide range of tasks including system
|
||||||
|
administration, web development, network programming, GUI development, and
|
||||||
|
more.")
|
||||||
|
(license license:gpl1+)))
|
||||||
|
|
||||||
(define-public perl-algorithm-c3
|
(define-public perl-algorithm-c3
|
||||||
(package
|
(package
|
||||||
(name "perl-algorithm-c3")
|
(name "perl-algorithm-c3")
|
||||||
|
|
Loading…
Reference in a new issue