mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 07:26:13 -05:00
gnu: wxmaxima: Update to 18.02.0.
* gnu/packages/maths.scm (wxmaxima): Update to 18.02.0. [source]: Add patch. [build-system]: Use the cmake-build-system. [native-inputs]: Remove autoconf and automake. [arguments]: Disable tests, remove 'autoconf' phase. * gnu/packages/patches/wxmaxima-do-not-use-old-gnuplot-parameters.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it.
This commit is contained in:
parent
e8ee100e8e
commit
0181df537f
3 changed files with 36 additions and 11 deletions
|
@ -4,7 +4,7 @@
|
|||
# Copyright © 2016 Mathieu Lirzin <mthl@gnu.org>
|
||||
# Copyright © 2013, 2014, 2015, 2016, 2017, 2018 Mark H Weaver <mhw@netris.org>
|
||||
# Copyright © 2016 Chris Marusich <cmmarusich@gmail.com>
|
||||
# Copyright © 2016, 2017 Kei Kebreau <kkebreau@posteo.net>
|
||||
# Copyright © 2016, 2017, 2018 Kei Kebreau <kkebreau@posteo.net>
|
||||
# Copyright © 2016, 2017 Rene Saavedra <rennes@openmailbox.org>
|
||||
# Copyright © 2016 Adonay "adfeno" Felipe Nogueira <https://libreplanet.org/wiki/User:Adfeno> <adfeno@openmailbox.org>
|
||||
# Copyright © 2016, 2017 Ricardo Wurmus <rekado@elephly.net>
|
||||
|
@ -1160,6 +1160,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/wpa-supplicant-fix-zeroed-keys.patch \
|
||||
%D%/packages/patches/wpa-supplicant-fix-nonce-reuse.patch \
|
||||
%D%/packages/patches/wpa-supplicant-krack-followups.patch \
|
||||
%D%/packages/patches/wxmaxima-do-not-use-old-gnuplot-parameters.patch \
|
||||
%D%/packages/patches/xboing-CVE-2004-0149.patch \
|
||||
%D%/packages/patches/xcb-proto-python3-print.patch \
|
||||
%D%/packages/patches/xcb-proto-python3-whitespace.patch \
|
||||
|
|
|
@ -2489,7 +2489,7 @@ (define-public maxima
|
|||
(define-public wxmaxima
|
||||
(package
|
||||
(name "wxmaxima")
|
||||
(version "17.10.1")
|
||||
(version "18.02.0")
|
||||
(source
|
||||
(origin
|
||||
(method url-fetch)
|
||||
|
@ -2498,12 +2498,12 @@ (define-public wxmaxima
|
|||
(file-name (string-append name "-" version ".tar.gz"))
|
||||
(sha256
|
||||
(base32
|
||||
"0qlzc31cqkwpfgrb9cif9bcnkj3rq487plg4rns7jxv6pq4609v1"))))
|
||||
(build-system gnu-build-system)
|
||||
"03kr2rgfp4hcf3is8m8d8f9hj660c3xgrc50vrrfpixx4syh6wvj"))
|
||||
(patches
|
||||
(search-patches "wxmaxima-do-not-use-old-gnuplot-parameters.patch"))))
|
||||
(build-system cmake-build-system)
|
||||
(native-inputs
|
||||
`(("autoconf" ,autoconf)
|
||||
("automake" ,automake)
|
||||
("gettext" ,gettext-minimal)))
|
||||
`(("gettext" ,gettext-minimal)))
|
||||
(inputs
|
||||
`(("wxwidgets" ,wxwidgets)
|
||||
("maxima" ,maxima)
|
||||
|
@ -2512,11 +2512,9 @@ (define-public wxmaxima
|
|||
("gtk+" ,gtk+)
|
||||
("shared-mime-info" ,shared-mime-info)))
|
||||
(arguments
|
||||
`(#:phases
|
||||
`(#:tests? #f ; no check target
|
||||
#:phases
|
||||
(modify-phases %standard-phases
|
||||
(add-after 'unpack 'autoconf
|
||||
(lambda _
|
||||
(zero? (system* "sh" "bootstrap"))))
|
||||
(add-after 'install 'wrap-program
|
||||
(lambda* (#:key inputs outputs #:allow-other-keys)
|
||||
(wrap-program (string-append (assoc-ref outputs "out")
|
||||
|
|
|
@ -0,0 +1,26 @@
|
|||
This fixes the wxplot2d plotting issue found at
|
||||
https://github.com/andrejv/wxmaxima/issues/973.
|
||||
|
||||
From 5a0693c97ceaa4935b908f1e478126896952f399 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Gunter=20K=C3=B6nigsmann?= <gunter@peterpall.de>
|
||||
Date: Mon, 19 Feb 2018 05:37:35 +0100
|
||||
Subject: [PATCH] Seems I accidentally made wxMaxima to default to parameters
|
||||
for old gnuplots. Resolves #973
|
||||
|
||||
---
|
||||
data/wxmathml.lisp.in | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/data/wxmathml.lisp.in b/data/wxmathml.lisp.in
|
||||
index a32e3fc3..4e19acaf 100644
|
||||
--- a/data/wxmathml.lisp.in
|
||||
+++ b/data/wxmathml.lisp.in
|
||||
@@ -43,7 +43,7 @@
|
||||
(defvar $wxsubscripts t
|
||||
"Recognize TeX-style subscripts")
|
||||
(defvar $wxplot_pngcairo nil "Use gnuplot's pngcairo terminal for new plots?")
|
||||
-(defmvar $wxplot_old_gnuplot t)
|
||||
+(defmvar $wxplot_old_gnuplot nil)
|
||||
|
||||
(defun $wxstatusbar (status)
|
||||
(format t "<statusbar>~a</statusbar>~%" status))
|
Loading…
Reference in a new issue