mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-12-26 06:18:07 -05:00
gnu: fontconfig: Update to 2.13.0.
* gnu/packages/patches/fontconfig-remove-debug-printf.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it. * gnu/packages/fontutils.scm (fontconfig): Update to 2.13.0. [source](patches): Remove. [propagated-inputs]: Add UTIL-LINUX.
This commit is contained in:
parent
7428581f8d
commit
019c0eda94
3 changed files with 6 additions and 23 deletions
|
@ -659,7 +659,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/fltk-xfont-on-demand.patch \
|
||||
%D%/packages/patches/foomatic-filters-CVE-2015-8327.patch \
|
||||
%D%/packages/patches/foomatic-filters-CVE-2015-8560.patch \
|
||||
%D%/packages/patches/fontconfig-remove-debug-printf.patch \
|
||||
%D%/packages/patches/freeimage-CVE-2015-0852.patch \
|
||||
%D%/packages/patches/freeimage-CVE-2016-5684.patch \
|
||||
%D%/packages/patches/freeimage-fix-build-with-gcc-5.patch \
|
||||
|
|
|
@ -28,6 +28,7 @@ (define-module (gnu packages fontutils)
|
|||
#:use-module (gnu packages compression)
|
||||
#:use-module (gnu packages check)
|
||||
#:use-module (gnu packages ghostscript)
|
||||
#:use-module (gnu packages linux)
|
||||
#:use-module (gnu packages perl)
|
||||
#:use-module (gnu packages pkg-config)
|
||||
#:use-module (gnu packages autotools)
|
||||
|
@ -231,18 +232,19 @@ (define-public woff2
|
|||
(define-public fontconfig
|
||||
(package
|
||||
(name "fontconfig")
|
||||
(version "2.12.6")
|
||||
(version "2.13.0")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append
|
||||
"https://www.freedesktop.org/software/fontconfig/release/fontconfig-"
|
||||
version ".tar.bz2"))
|
||||
(patches (search-patches "fontconfig-remove-debug-printf.patch"))
|
||||
(sha256 (base32
|
||||
"05zh65zni11kgnhg726gjbrd55swspdvhqbcnj5a5xh8gn03036g"))))
|
||||
"1fgf28zgsqh7x6dw30n6zi9z679gx6dyfyahp55z7dsm454yipci"))))
|
||||
(build-system gnu-build-system)
|
||||
;; In Requires or Requires.private of fontconfig.pc.
|
||||
(propagated-inputs `(("expat" ,expat)
|
||||
("freetype" ,freetype)))
|
||||
("freetype" ,freetype)
|
||||
("libuuid" ,util-linux)))
|
||||
(inputs `(("gs-fonts" ,gs-fonts)))
|
||||
(native-inputs
|
||||
`(("gperf" ,gperf)
|
||||
|
|
|
@ -1,18 +0,0 @@
|
|||
Fontconfig 2.12.5 and 2.12.6 was released with a stray debugging statement.
|
||||
See <https://lists.freedesktop.org/archives/fontconfig/2017-October/006079.html>.
|
||||
|
||||
Patch copied from upstream source repository:
|
||||
https://cgit.freedesktop.org/fontconfig/commit/?id=b56207a069be2574df455ede0a6ab61f44d5ca2b
|
||||
|
||||
diff --git a/fc-query/fc-query.c b/fc-query/fc-query.c
|
||||
index 842a8b6..6cd5abd 100644
|
||||
--- a/fc-query/fc-query.c
|
||||
+++ b/fc-query/fc-query.c
|
||||
@@ -170,7 +170,6 @@ main (int argc, char **argv)
|
||||
FcPattern *pat;
|
||||
|
||||
id = ((instance_num << 16) + face_num);
|
||||
- printf("id %d\n", id);
|
||||
if (FT_New_Face (ftLibrary, argv[i], id, &face))
|
||||
break;
|
||||
num_faces = face->num_faces;
|
Loading…
Reference in a new issue