mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2025-01-12 06:06:53 -05:00
Revert "gnu: sddm: Fix CMake build."
This reverts commit 8674abb1dd
.
This is no longer necessary after the upgrade to Qt-5.11.1.
This commit is contained in:
parent
2338755afa
commit
02062f42e6
3 changed files with 1 additions and 32 deletions
|
@ -1123,7 +1123,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/scotch-build-parallelism.patch \
|
||||
%D%/packages/patches/scotch-graph-diam-64.patch \
|
||||
%D%/packages/patches/scotch-graph-induce-type-64.patch \
|
||||
%D%/packages/patches/sddm-fix-build-with-qt-5.11-1024.patch \
|
||||
%D%/packages/patches/sdl-libx11-1.6.patch \
|
||||
%D%/packages/patches/seq24-rename-mutex.patch \
|
||||
%D%/packages/patches/sharutils-CVE-2018-1000097.patch \
|
||||
|
|
|
@ -6,7 +6,6 @@
|
|||
;;; Copyright © 2017 Sou Bunnbu <iyzsong@gmail.com>
|
||||
;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
|
||||
;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
|
||||
;;; Copyright © 2018 Stefan Stefanović <stefanx2ovic@gmail.com>
|
||||
;;;
|
||||
;;; This file is part of GNU Guix.
|
||||
;;;
|
||||
|
@ -144,8 +143,7 @@ (define-public sddm
|
|||
"sddm-" version ".tar.xz"))
|
||||
(sha256
|
||||
(base32
|
||||
"0ch6rdppgy2vbzw0c2x9a4c6ry46vx7p6b76d8xbh2nvxh23xv0k"))
|
||||
(patches (search-patches "sddm-fix-build-with-qt-5.11-1024.patch"))))
|
||||
"0ch6rdppgy2vbzw0c2x9a4c6ry46vx7p6b76d8xbh2nvxh23xv0k"))))
|
||||
(build-system cmake-build-system)
|
||||
(native-inputs
|
||||
`(("extra-cmake-modules" ,extra-cmake-modules)
|
||||
|
|
|
@ -1,28 +0,0 @@
|
|||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index 2efc649..8903b52 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -93,7 +95,7 @@
|
||||
find_package(XKB REQUIRED)
|
||||
|
||||
# Qt 5
|
||||
-find_package(Qt5 5.6.0 CONFIG REQUIRED Core DBus Gui Qml Quick LinguistTools)
|
||||
+find_package(Qt5 5.8.0 CONFIG REQUIRED Core DBus Gui Qml Quick LinguistTools Test)
|
||||
|
||||
# find qt5 imports dir
|
||||
get_target_property(QMAKE_EXECUTABLE Qt5::qmake LOCATION)
|
||||
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
|
||||
index c9d935a..bb85ddd 100644
|
||||
--- a/test/CMakeLists.txt
|
||||
+++ b/test/CMakeLists.txt
|
||||
@@ -2,9 +2,8 @@
|
||||
|
||||
include_directories(../src/common)
|
||||
|
||||
-
|
||||
set(ConfigurationTest_SRCS ConfigurationTest.cpp ../src/common/ConfigReader.cpp)
|
||||
add_executable(ConfigurationTest ${ConfigurationTest_SRCS})
|
||||
add_test(NAME Configuration COMMAND ConfigurationTest)
|
||||
|
||||
-qt5_use_modules(ConfigurationTest Test)
|
||||
+target_link_libraries(ConfigurationTest Qt5::Core Qt5::Test)
|
Loading…
Reference in a new issue