mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-12-24 21:38:07 -05:00
gnu: screen: Update to 4.9.0.
* gnu/packages/screen.scm (screen): Update to 4.9.0. [source]: Remove one patch. [native-inputs]: Remove input labels. Add autoconf, automake. * gnu/packages/patches/screen-CVE-2021-26937.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Remove it.
This commit is contained in:
parent
0831584259
commit
0306cdd8f5
3 changed files with 6 additions and 73 deletions
|
@ -1783,7 +1783,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/scheme48-tests.patch \
|
||||
%D%/packages/patches/scotch-build-parallelism.patch \
|
||||
%D%/packages/patches/scotch-integer-declarations.patch \
|
||||
%D%/packages/patches/screen-CVE-2021-26937.patch \
|
||||
%D%/packages/patches/screen-hurd-path-max.patch \
|
||||
%D%/packages/patches/sdl-libx11-1.6.patch \
|
||||
%D%/packages/patches/seed-webkit.patch \
|
||||
|
|
|
@ -1,66 +0,0 @@
|
|||
https://salsa.debian.org/debian/screen/-/raw/debian/4.8.0-5/debian/patches/99_CVE-2021-26937.patch
|
||||
|
||||
Description: [CVE-2021-26937] Fix out of bounds array access
|
||||
Author: Michael Schröder <mls@suse.de>
|
||||
Bug-Debian: https://bugs.debian.org/982435
|
||||
Bug: https://savannah.gnu.org/bugs/?60030
|
||||
Bug: https://lists.gnu.org/archive/html/screen-devel/2021-02/msg00000.html
|
||||
Bug-OSS-Security: https://www.openwall.com/lists/oss-security/2021/02/09/3
|
||||
Origin: https://lists.gnu.org/archive/html/screen-devel/2021-02/msg00010.html
|
||||
|
||||
--- a/encoding.c
|
||||
+++ b/encoding.c
|
||||
@@ -43,7 +43,7 @@
|
||||
# ifdef UTF8
|
||||
static int recode_char __P((int, int, int));
|
||||
static int recode_char_to_encoding __P((int, int));
|
||||
-static void comb_tofront __P((int, int));
|
||||
+static void comb_tofront __P((int));
|
||||
# ifdef DW_CHARS
|
||||
static int recode_char_dw __P((int, int *, int, int));
|
||||
static int recode_char_dw_to_encoding __P((int, int *, int));
|
||||
@@ -1263,6 +1263,8 @@
|
||||
{0x30000, 0x3FFFD},
|
||||
};
|
||||
|
||||
+ if (c >= 0xdf00 && c <= 0xdfff)
|
||||
+ return 1; /* dw combining sequence */
|
||||
return ((bisearch(c, wide, sizeof(wide) / sizeof(struct interval) - 1)) ||
|
||||
(cjkwidth &&
|
||||
bisearch(c, ambiguous,
|
||||
@@ -1330,11 +1332,12 @@
|
||||
}
|
||||
|
||||
static void
|
||||
-comb_tofront(root, i)
|
||||
-int root, i;
|
||||
+comb_tofront(i)
|
||||
+int i;
|
||||
{
|
||||
for (;;)
|
||||
{
|
||||
+ int root = i >= 0x700 ? 0x801 : 0x800;
|
||||
debug1("bring to front: %x\n", i);
|
||||
combchars[combchars[i]->prev]->next = combchars[i]->next;
|
||||
combchars[combchars[i]->next]->prev = combchars[i]->prev;
|
||||
@@ -1396,9 +1399,9 @@
|
||||
{
|
||||
/* full, recycle old entry */
|
||||
if (c1 >= 0xd800 && c1 < 0xe000)
|
||||
- comb_tofront(root, c1 - 0xd800);
|
||||
+ comb_tofront(c1 - 0xd800);
|
||||
i = combchars[root]->prev;
|
||||
- if (c1 == i + 0xd800)
|
||||
+ if (i == 0x800 || i == 0x801 || c1 == i + 0xd800)
|
||||
{
|
||||
/* completely full, can't recycle */
|
||||
debug("utf8_handle_comp: completely full!\n");
|
||||
@@ -1422,7 +1425,7 @@
|
||||
mc->font = (i >> 8) + 0xd8;
|
||||
mc->fontx = 0;
|
||||
debug3("combinig char %x %x -> %x\n", c1, c, i + 0xd800);
|
||||
- comb_tofront(root, i);
|
||||
+ comb_tofront(i);
|
||||
}
|
||||
|
||||
#else /* !UTF8 */
|
|
@ -2,7 +2,7 @@
|
|||
;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
|
||||
;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
|
||||
;;; Copyright © 2015, 2017 Eric Bavier <bavier@member.fsf.org>
|
||||
;;; Copyright © 2016, 2017, 2019, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
|
||||
;;; Copyright © 2016, 2017, 2019, 2020, 2021, 2022 Efraim Flashner <efraim@flashner.co.il>
|
||||
;;; Copyright © 2016 Alex Griffin <a@ajgrf.com>
|
||||
;;; Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
|
||||
;;; Copyright © 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
|
||||
|
@ -29,6 +29,7 @@ (define-module (gnu packages screen)
|
|||
#:use-module (guix git-download)
|
||||
#:use-module (guix build-system gnu)
|
||||
#:use-module (gnu packages)
|
||||
#:use-module (gnu packages autotools)
|
||||
#:use-module (gnu packages hurd)
|
||||
#:use-module (gnu packages ncurses)
|
||||
#:use-module (gnu packages perl)
|
||||
|
@ -39,18 +40,17 @@ (define-module (gnu packages screen)
|
|||
(define-public screen
|
||||
(package
|
||||
(name "screen")
|
||||
(version "4.8.0")
|
||||
(version "4.9.0")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "mirror://gnu/screen/screen-"
|
||||
version ".tar.gz"))
|
||||
(patches (search-patches "screen-hurd-path-max.patch"
|
||||
"screen-CVE-2021-26937.patch"))
|
||||
(patches (search-patches "screen-hurd-path-max.patch"))
|
||||
(sha256
|
||||
(base32 "18ascpjzsy70h6hk7wpg8zmzjwgdyrdr7c6z4pg5z4l9hhyv24bf"))))
|
||||
(base32 "1x1hqy4h47i7hk85f779lkwkm7gkq8h8mxwd0znkh5adpf0m4czr"))))
|
||||
(build-system gnu-build-system)
|
||||
(native-inputs
|
||||
`(("makeinfo" ,texinfo)))
|
||||
(list autoconf automake texinfo))
|
||||
(inputs
|
||||
(list ncurses perl))
|
||||
(arguments
|
||||
|
|
Loading…
Reference in a new issue