mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2025-01-13 06:36:37 -05:00
gnu: inkscape@1.1: Update to 1.1.1.
* gnu/packages/inkscape.scm (inkscape-1.1): Update to 1.1.1. [source]: Remove patch. Don't explicitly return #t from snippet. [arguments]: Don't explicitly return #t from phases. * gnu/packages/patches/inkscape-1.1-fix-build-witch-gcc7.5.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
This commit is contained in:
parent
57b7e1cfd0
commit
0489e488de
3 changed files with 7 additions and 39 deletions
|
@ -1297,7 +1297,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/inetutils-hurd.patch \
|
||||
%D%/packages/patches/inkscape-poppler-0.76.patch \
|
||||
%D%/packages/patches/instead-use-games-path.patch \
|
||||
%D%/packages/patches/inkscape-1.1-fix-build-witch-gcc7.5.patch \
|
||||
%D%/packages/patches/intel-xed-fix-nondeterminism.patch \
|
||||
%D%/packages/patches/intltool-perl-compatibility.patch \
|
||||
%D%/packages/patches/iputils-libcap-compat.patch \
|
||||
|
|
|
@ -120,17 +120,15 @@ (define-public inkscape
|
|||
(define-public inkscape-1.1
|
||||
(package
|
||||
(name "inkscape")
|
||||
(version "1.1")
|
||||
(version "1.1.1")
|
||||
(source
|
||||
(origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "https://media.inkscape.org/dl/"
|
||||
"resources/file/"
|
||||
"inkscape-" version ".tar.xz"))
|
||||
(patches (search-patches "inkscape-1.1-fix-build-witch-gcc7.5.patch"))
|
||||
(sha256
|
||||
(base32
|
||||
"1rlm2wqg8bgdxkdvnadh49wfp0mrbrk7d8n4vdcjyw6z7z7firki"))
|
||||
(base32 "1bvqg5xfs3m6r7qfdhmgzwhd1hx8wvg3nhvhmalwzcdm6ffhpjmf"))
|
||||
(modules '((guix build utils)
|
||||
(ice-9 format)))
|
||||
(snippet
|
||||
|
@ -211,8 +209,7 @@ (define-public inkscape-1.1
|
|||
;; Lift the requirement on the double-conversion library, as
|
||||
;; it is only needed by lib2geom, which is now unbundled.
|
||||
(substitute* "CMakeScripts/DefineDependsandFlags.cmake"
|
||||
((".*find_package\\(DoubleConversion.*") ""))
|
||||
#t))))
|
||||
((".*find_package\\(DoubleConversion.*") ""))))))
|
||||
(build-system cmake-build-system)
|
||||
(arguments
|
||||
`(#:tests? #t
|
||||
|
@ -227,8 +224,7 @@ (define-public inkscape-1.1
|
|||
(add-after 'unpack 'patch-icon-cache-generator
|
||||
(lambda _
|
||||
(substitute* "share/icons/application/CMakeLists.txt"
|
||||
(("gtk-update-icon-cache") "true"))
|
||||
#t))
|
||||
(("gtk-update-icon-cache") "true"))))
|
||||
(add-after 'unpack 'disable-latex-export-tests
|
||||
;; FIXME: For some reason the test.pdf_tex file generated by the
|
||||
;; "--export-latex" lacks "some text" in its content when run in
|
||||
|
@ -236,14 +232,12 @@ (define-public inkscape-1.1
|
|||
(lambda _
|
||||
(substitute* "testfiles/cli_tests/CMakeLists.txt"
|
||||
(("add_cli_test\\(export-latex")
|
||||
"message(TEST_DISABLED: export-latex"))
|
||||
#t))
|
||||
"message(TEST_DISABLED: export-latex"))))
|
||||
(add-after 'unpack 'set-home
|
||||
;; Mute Inkscape warnings during tests.
|
||||
(lambda _
|
||||
(setenv "HOME" (getcwd))
|
||||
(format #t "ARGS is set to: ~a" (getenv "ARGS"))
|
||||
#t))
|
||||
(format #t "ARGS is set to: ~a" (getenv "ARGS"))))
|
||||
;; Move the check phase after the install phase, as when run in the
|
||||
;; tests, Inkscape relies on files that are not yet installed, such
|
||||
;; as the "share/inkscape/ui/units.xml" file.
|
||||
|
@ -259,8 +253,7 @@ (define-public inkscape-1.1
|
|||
(lambda* (#:key outputs #:allow-other-keys)
|
||||
(let ((out (assoc-ref outputs "out")))
|
||||
(wrap-program (string-append out "/bin/inkscape")
|
||||
`("PYTHONPATH" ":" prefix (,(getenv "PYTHONPATH")))))
|
||||
#t)))))
|
||||
`("PYTHONPATH" ":" prefix (,(getenv "PYTHONPATH"))))))))))
|
||||
(inputs
|
||||
`(("aspell" ,aspell)
|
||||
("autotrace" ,autotrace)
|
||||
|
|
|
@ -1,24 +0,0 @@
|
|||
From 0ae15d7e89b984f72780ff7afa8e57dd6ae7765a Mon Sep 17 00:00:00 2001
|
||||
From: "Boris A. Dekshteyn" <boris.dekshteyn@gmail.com>
|
||||
Date: Mon, 14 Jun 2021 23:52:16 +1200
|
||||
Subject: [PATCH] Fix build witch GCC@7.5.
|
||||
|
||||
---
|
||||
src/object/sp-use-reference.h | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/src/object/sp-use-reference.h b/src/object/sp-use-reference.h
|
||||
index 5958632059..f07c2a3721 100644
|
||||
--- a/src/object/sp-use-reference.h
|
||||
+++ b/src/object/sp-use-reference.h
|
||||
@@ -14,6 +14,7 @@
|
||||
|
||||
#include "sp-item.h"
|
||||
#include "uri-references.h"
|
||||
+#include "display/curve.h"
|
||||
|
||||
#include <memory>
|
||||
|
||||
--
|
||||
2.32.0
|
||||
|
Loading…
Reference in a new issue