mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2025-01-24 03:29:40 -05:00
gnu: emacs-xelb: Fix compilation error with xcb-proto@1.15.
* gnu/packages/patches/emacs-xelb-ignore-length-element.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/emacs-xyz.scm (emacs-xelb): Use it.
This commit is contained in:
parent
4f4c38c881
commit
04a4fe2df2
3 changed files with 24 additions and 2 deletions
|
@ -1077,6 +1077,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/emacs-yasnippet-fix-tests.patch \
|
||||
%D%/packages/patches/emacs-kv-fix-tests.patch \
|
||||
%D%/packages/patches/emacs-pgtk-super-key-fix.patch \
|
||||
%D%/packages/patches/emacs-xelb-ignore-length-element.patch \
|
||||
%D%/packages/patches/enjarify-setup-py.patch \
|
||||
%D%/packages/patches/enlightenment-fix-setuid-path.patch \
|
||||
%D%/packages/patches/erlang-man-path.patch \
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
;;; GNU Guix --- Functional package management for GNU
|
||||
;;; Copyright © 2014 Taylan Ulrich Bayirli/Kammer <taylanbayirli@gmail.com>
|
||||
;;; Copyright © 2013-2022 Ludovic Courtès <ludo@gnu.org>
|
||||
;;; Copyright © 2013-2023 Ludovic Courtès <ludo@gnu.org>
|
||||
;;; Copyright © 2014, 2015, 2016, 2017, 2018 Mark H Weaver <mhw@netris.org>
|
||||
;;; Copyright © 2014, 2015, 2016, 2017, 2018, 2019 Alex Kost <alezost@gmail.com>
|
||||
;;; Copyright © 2015 Federico Beffa <beffa@fbengineering.ch>
|
||||
|
@ -17808,7 +17808,9 @@ (define-public emacs-xelb
|
|||
version ".tar"))
|
||||
(sha256
|
||||
(base32
|
||||
"1fp5mzl63sh0h3ws4l5p4qgvi7ny8a3fj6k4dhqa98xgw2bx03v7"))))
|
||||
"1fp5mzl63sh0h3ws4l5p4qgvi7ny8a3fj6k4dhqa98xgw2bx03v7"))
|
||||
(patches
|
||||
(search-patches "emacs-xelb-ignore-length-element.patch"))))
|
||||
(build-system emacs-build-system)
|
||||
;; The following functions and variables needed by emacs-xelb are
|
||||
;; not included in emacs-minimal:
|
||||
|
|
19
gnu/packages/patches/emacs-xelb-ignore-length-element.patch
Normal file
19
gnu/packages/patches/emacs-xelb-ignore-length-element.patch
Normal file
|
@ -0,0 +1,19 @@
|
|||
Work around build failure due to XCB "length" element.
|
||||
Patch from <https://sources.debian.org/patches/xelb/0.18-4/>.
|
||||
|
||||
Author: Martin <debacle@debian.org>
|
||||
Bug: https://github.com/ch11ng/xelb/issues/28
|
||||
Bug-Debian: https://bugs.debian.org/1017294
|
||||
|
||||
---
|
||||
--- a/el_client.el
|
||||
+++ b/el_client.el
|
||||
@@ -519,7 +519,7 @@
|
||||
(`list (xelb-parse-list node))
|
||||
(`exprfield (xelb-parse-exprfield node))
|
||||
(`switch (xelb-parse-switch node))
|
||||
- ((or `comment `doc)) ;simply ignored
|
||||
+ ((or `comment `doc `length)) ;simply ignored
|
||||
(x (error "Unsupported structure content: <%s>" x))))
|
||||
|
||||
;; The car of the result shall be renamed to prevent duplication of slot names
|
Loading…
Reference in a new issue