mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2025-01-11 21:59:08 -05:00
gnu: maturin: Update to 1.4.0.
* gnu/packages/rust-apps.scm (maturin): Update to 1.4.0. [source]: Add snippet to fix compilation. [cargo-inputs]: Add rust-path-slash-0.2. Replace rust-cargo-options-0.6 with 0.7, rust-cargo-metadata-0.16 with 0.18, rust-cbindgen-0.24 with 0.26, rust-dialoguer-0.10 with 0.11, rust-goblin-0.6 with 0.7, rust-indexmap-1 with 2, rust-itertools-0.10 with 0.12, rust-minijinja-0.34 with 1, rust-pyproject-toml-0.6 with 0.8, rust-python-pkginfo-0.5 with 0.6, rust-rustls-0.20 with 0.21, rust-rustls-pemfile-1 with 2, rust-toml-0.7 with 0.8, rust-toml-edit-0.19 with 0.21. Remove rust-same-file-1. [cargo-development-inputs]: Add rust-expect-test-1. Replace rust-which-4 with 5. * gnu/packages/patches/maturin-no-cross-compile.patch: Refresh patch. Change-Id: I1c943ad1a9a3cb315e5baa287f7ba5bc7bc15413
This commit is contained in:
parent
3f1c8dd7e2
commit
04b2a8d2a7
2 changed files with 39 additions and 32 deletions
|
@ -2,27 +2,27 @@ Remove dependencies on xwin and zig. We're not offering cross-compilation
|
|||
options using these crates.
|
||||
|
||||
diff --git a/Cargo.toml b/Cargo.toml
|
||||
index 6cbdca3..22ea5ef 100644
|
||||
index 6704e46..ff126a9 100644
|
||||
--- a/Cargo.toml
|
||||
+++ b/Cargo.toml
|
||||
@@ -76,16 +76,6 @@ version = "0.1.4"
|
||||
@@ -83,16 +83,6 @@ version = "0.1.16"
|
||||
[dependencies.cargo-options]
|
||||
version = "0.6.0"
|
||||
version = "0.7.2"
|
||||
|
||||
-[dependencies.cargo-xwin]
|
||||
-version = "0.14.3"
|
||||
-version = "0.16.2"
|
||||
-optional = true
|
||||
-default-features = false
|
||||
-
|
||||
-[dependencies.cargo-zigbuild]
|
||||
-version = "0.16.10"
|
||||
-version = "0.18.0"
|
||||
-optional = true
|
||||
-default-features = false
|
||||
-
|
||||
[dependencies.cargo_metadata]
|
||||
version = "0.15.3"
|
||||
version = "0.18.0"
|
||||
|
||||
@@ -310,8 +300,6 @@ version = "4.3.0"
|
||||
@@ -321,8 +311,6 @@ version = "5.0.0"
|
||||
[features]
|
||||
cli-completion = ["dep:clap_complete_command"]
|
||||
cross-compile = [
|
||||
|
@ -31,7 +31,7 @@ index 6cbdca3..22ea5ef 100644
|
|||
]
|
||||
default = [
|
||||
"full",
|
||||
@@ -330,7 +318,6 @@ log = ["tracing-subscriber"]
|
||||
@@ -341,7 +329,6 @@ log = ["tracing-subscriber"]
|
||||
native-tls = [
|
||||
"dep:native-tls",
|
||||
"ureq?/native-tls",
|
||||
|
@ -39,7 +39,7 @@ index 6cbdca3..22ea5ef 100644
|
|||
"dep:rustls-pemfile",
|
||||
]
|
||||
password-storage = [
|
||||
@@ -340,7 +327,6 @@ password-storage = [
|
||||
@@ -351,7 +338,6 @@ password-storage = [
|
||||
rustls = [
|
||||
"dep:rustls",
|
||||
"ureq?/tls",
|
||||
|
@ -47,7 +47,7 @@ index 6cbdca3..22ea5ef 100644
|
|||
"dep:rustls-pemfile",
|
||||
]
|
||||
scaffolding = [
|
||||
@@ -358,5 +344,3 @@ upload = [
|
||||
@@ -369,5 +355,3 @@ upload = [
|
||||
"wild",
|
||||
"dep:dirs",
|
||||
]
|
||||
|
|
|
@ -1037,15 +1037,21 @@ (define-public macchina
|
|||
(define-public maturin
|
||||
(package
|
||||
(name "maturin")
|
||||
(version "1.1.0")
|
||||
(version "1.4.0")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (crate-uri "maturin" version))
|
||||
(file-name (string-append name "-" version ".tar.gz"))
|
||||
(sha256
|
||||
(base32
|
||||
"0asdljd396kdsvnx9kbsr5s0x6w73b59kdpx732333dhm13qgn03"))
|
||||
(patches (search-patches "maturin-no-cross-compile.patch"))))
|
||||
"1ia5xziazpcpc1wwg8jlz5nmza87cz7nb039gg38jgw3704p4dls"))
|
||||
(patches (search-patches "maturin-no-cross-compile.patch"))
|
||||
(snippet
|
||||
#~(begin (use-modules (guix build utils))
|
||||
;; Remove support for x86_64h-apple-darwin.
|
||||
;; This target causes maturin to fail to build.
|
||||
(substitute* "src/target.rs"
|
||||
(("\\| Architecture::X86_64h ") ""))))))
|
||||
(build-system cargo-build-system)
|
||||
(arguments
|
||||
`(#:modules ((guix build cargo-build-system)
|
||||
|
@ -1073,44 +1079,44 @@ (define-public maturin
|
|||
("rust-base64" ,rust-base64-0.21)
|
||||
("rust-bytesize" ,rust-bytesize-1)
|
||||
("rust-cargo-config2" ,rust-cargo-config2-0.1)
|
||||
("rust-cargo-options" ,rust-cargo-options-0.6)
|
||||
;("rust-cargo-xwin" ,rust-cargo-xwin-0.14)
|
||||
;("rust-cargo-zigbuild" ,rust-cargo-zigbuild-0.16)
|
||||
("rust-cargo-metadata" ,rust-cargo-metadata-0.15)
|
||||
("rust-cbindgen" ,rust-cbindgen-0.24)
|
||||
("rust-cargo-options" ,rust-cargo-options-0.7)
|
||||
;("rust-cargo-xwin" ,rust-cargo-xwin-0.16)
|
||||
;("rust-cargo-zigbuild" ,rust-cargo-zigbuild-0.18)
|
||||
("rust-cargo-metadata" ,rust-cargo-metadata-0.18)
|
||||
("rust-cbindgen" ,rust-cbindgen-0.26)
|
||||
("rust-cc" ,rust-cc-1)
|
||||
("rust-clap" ,rust-clap-4)
|
||||
("rust-clap-complete-command" ,rust-clap-complete-command-0.5)
|
||||
("rust-configparser" ,rust-configparser-3)
|
||||
("rust-console" ,rust-console-0.15)
|
||||
("rust-dialoguer" ,rust-dialoguer-0.10)
|
||||
("rust-dialoguer" ,rust-dialoguer-0.11)
|
||||
("rust-dirs" ,rust-dirs-5)
|
||||
("rust-dunce" ,rust-dunce-1)
|
||||
("rust-fat-macho" ,rust-fat-macho-0.4)
|
||||
("rust-flate2" ,rust-flate2-1)
|
||||
("rust-fs-err" ,rust-fs-err-2)
|
||||
("rust-glob" ,rust-glob-0.3)
|
||||
("rust-goblin" ,rust-goblin-0.6)
|
||||
("rust-goblin" ,rust-goblin-0.7)
|
||||
("rust-ignore" ,rust-ignore-0.4)
|
||||
("rust-indexmap" ,rust-indexmap-1)
|
||||
("rust-itertools" ,rust-itertools-0.10)
|
||||
("rust-indexmap" ,rust-indexmap-2)
|
||||
("rust-itertools" ,rust-itertools-0.12)
|
||||
("rust-keyring" ,rust-keyring-2)
|
||||
("rust-lddtree" ,rust-lddtree-0.3)
|
||||
("rust-minijinja" ,rust-minijinja-0.34)
|
||||
("rust-minijinja" ,rust-minijinja-1)
|
||||
("rust-multipart" ,rust-multipart-0.18)
|
||||
("rust-native-tls" ,rust-native-tls-0.2)
|
||||
("rust-normpath" ,rust-normpath-1)
|
||||
("rust-once-cell" ,rust-once-cell-1)
|
||||
("rust-path-slash" ,rust-path-slash-0.2)
|
||||
("rust-pep440-rs" ,rust-pep440-rs-0.3)
|
||||
("rust-pep508-rs" ,rust-pep508-rs-0.2)
|
||||
("rust-platform-info" ,rust-platform-info-2)
|
||||
("rust-pyproject-toml" ,rust-pyproject-toml-0.6)
|
||||
("rust-python-pkginfo" ,rust-python-pkginfo-0.5)
|
||||
("rust-pyproject-toml" ,rust-pyproject-toml-0.8)
|
||||
("rust-python-pkginfo" ,rust-python-pkginfo-0.6)
|
||||
("rust-regex" ,rust-regex-1)
|
||||
("rust-rustc-version" ,rust-rustc-version-0.4)
|
||||
("rust-rustls" ,rust-rustls-0.20)
|
||||
("rust-rustls-pemfile" ,rust-rustls-pemfile-1)
|
||||
("rust-same-file" ,rust-same-file-1)
|
||||
("rust-rustls" ,rust-rustls-0.21)
|
||||
("rust-rustls-pemfile" ,rust-rustls-pemfile-2)
|
||||
("rust-semver" ,rust-semver-1)
|
||||
("rust-serde" ,rust-serde-1)
|
||||
("rust-serde-json" ,rust-serde-json-1)
|
||||
|
@ -1121,8 +1127,8 @@ (define-public maturin
|
|||
("rust-textwrap" ,rust-textwrap-0.16)
|
||||
("rust-thiserror" ,rust-thiserror-1)
|
||||
("rust-time" ,rust-time-0.3)
|
||||
("rust-toml" ,rust-toml-0.7)
|
||||
("rust-toml-edit" ,rust-toml-edit-0.19)
|
||||
("rust-toml" ,rust-toml-0.8)
|
||||
("rust-toml-edit" ,rust-toml-edit-0.21)
|
||||
("rust-tracing" ,rust-tracing-0.1)
|
||||
("rust-tracing-subscriber" ,rust-tracing-subscriber-0.3)
|
||||
("rust-ureq" ,rust-ureq-2)
|
||||
|
@ -1130,12 +1136,13 @@ (define-public maturin
|
|||
("rust-wild" ,rust-wild-2)
|
||||
("rust-zip" ,rust-zip-0.6))
|
||||
#:cargo-development-inputs
|
||||
(("rust-indoc" ,rust-indoc-2)
|
||||
(("rust-expect-test" ,rust-expect-test-1)
|
||||
("rust-indoc" ,rust-indoc-2)
|
||||
("rust-pretty-assertions" ,rust-pretty-assertions-1)
|
||||
("rust-rustversion" ,rust-rustversion-1)
|
||||
("rust-time" ,rust-time-0.3)
|
||||
("rust-trycmd" ,rust-trycmd-0.14)
|
||||
("rust-which" ,rust-which-4))
|
||||
("rust-which" ,rust-which-5))
|
||||
#:phases
|
||||
(modify-phases %standard-phases
|
||||
(add-after 'build 'build-python-module
|
||||
|
|
Loading…
Reference in a new issue