gnu: guile-gnutls: Update to 4.0.0.

* gnu/packages/tls.scm (guile-gnutls): Update to 4.0.0.
[source]: Remove “gnutls-cross.patch”.
[arguments]: Add #:make-flags.
* gnu/packages/patches/gnutls-cross.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Remove it.

Change-Id: Ic4432e2d5ca37af5aa20cdf7e4e456afe2b37537
This commit is contained in:
Ludovic Courtès 2023-12-20 19:00:15 +01:00
parent 45d66ce8e9
commit 052d12f040
No known key found for this signature in database
GPG key ID: 090B11993D9AEBB5
3 changed files with 5 additions and 84 deletions

View file

@ -1431,7 +1431,6 @@ dist_patch_DATA = \
%D%/packages/patches/gnupg-default-pinentry.patch \
%D%/packages/patches/gnupg-1-build-with-gcc10.patch \
%D%/packages/patches/gnutls-skip-trust-store-test.patch \
%D%/packages/patches/gnutls-cross.patch \
%D%/packages/patches/gobject-introspection-absolute-shlib-path.patch \
%D%/packages/patches/gobject-introspection-absolute-shlib-path-1.72.patch \
%D%/packages/patches/gobject-introspection-cc.patch \

View file

@ -1,82 +0,0 @@
Not sent upstream.
From e23de62e28f64599148ff06e439fac116a391299 Mon Sep 17 00:00:00 2001
From: "Jan (janneke) Nieuwenhuizen" <janneke@gnu.org>
Date: Fri, 10 Apr 2020 07:24:48 +0200
Subject: [PATCH] guile: Cross build fix.
To cross-build, both the host guile and the native guile-for-build
must be available. If the native guile is not available, no snarfing
is done and the guile cross build is skipped.
During the cross-build gnutls.scm does not load when compliling
extra.scm, becase of missing definitions from guile-gnutls-v-2.
* guile/modules/gnutls.in (protocol/ssl-3 protocol/tls-1.0,
protocol/tls-1.1, credentials/anonymous, cipher/rijndael-256-cbc,
cipher/rijndael-128-cbc, cipher/rijndael-cbc, cipher/arcfour-128,
certificate-verify/allow-any-x509-v1-ca-certificate,
certificate-verify/allow-x509-v1-ca-certificate): Define to #f
initially. When "GNUTLS_GUILE_CROSS_COMPILING" not set, set! to value
from "guile-gnutls-v-2" load-extension C module.
---
guile/modules/gnutls.in | 40 +++++++++++++++++++++++++++-------------
1 file changed, 27 insertions(+), 13 deletions(-)
diff --git a/guile/modules/gnutls.in b/guile/modules/gnutls.in
index 6461c404a..954e315de 100644
--- a/guile/modules/gnutls.in
+++ b/guile/modules/gnutls.in
@@ -564,22 +564,36 @@ This defines 'variable' as an alias for 'alias', and emits a warning when
(identifier? #'id)
#'alias))))))))))
-
;; Renaming.
-(define protocol/ssl-3 protocol/ssl3)
-(define protocol/tls-1.0 protocol/tls1-0)
-(define protocol/tls-1.1 protocol/tls1-1)
+(define protocol/ssl-3 #f)
+(define protocol/tls-1.0 #f)
+(define protocol/tls-1.1 #f)
;; Aliases.
-(define credentials/anonymous credentials/anon)
-(define cipher/rijndael-256-cbc cipher/aes-256-cbc)
-(define cipher/rijndael-128-cbc cipher/aes-128-cbc)
-(define cipher/rijndael-cbc cipher/aes-128-cbc)
-(define cipher/arcfour-128 cipher/arcfour)
-(define certificate-verify/allow-any-x509-v1-ca-certificate
- certificate-verify/allow-any-x509-v1-ca-crt)
-(define certificate-verify/allow-x509-v1-ca-certificate
- certificate-verify/allow-x509-v1-ca-crt)
+(define credentials/anonymous #f)
+(define cipher/rijndael-256-cbc #f)
+(define cipher/rijndael-128-cbc #f)
+(define cipher/rijndael-cbc #f)
+(define cipher/arcfour-128 #f)
+(define certificate-verify/allow-any-x509-v1-ca-certificate #f)
+(define certificate-verify/allow-x509-v1-ca-certificate #f)
+
+(unless (getenv "GNUTLS_GUILE_CROSS_COMPILING")
+ ;; Renaming.
+ (set! protocol/ssl-3 protocol/ssl3)
+ (set! protocol/tls-1.0 protocol/tls1-0)
+ (set! protocol/tls-1.1 protocol/tls1-1)
+
+ ;; Aliases.
+ (set! credentials/anonymous credentials/anon)
+ (set! cipher/rijndael-256-cbc cipher/aes-256-cbc)
+ (set! cipher/rijndael-128-cbc cipher/aes-128-cbc)
+ (set! cipher/rijndael-cbc cipher/aes-128-cbc)
+ (set! cipher/arcfour-128 cipher/arcfour)
+ (set! certificate-verify/allow-any-x509-v1-ca-certificate
+ certificate-verify/allow-any-x509-v1-ca-crt)
+ (set! certificate-verify/allow-x509-v1-ca-certificate
+ certificate-verify/allow-x509-v1-ca-crt))
;; Deprecated OpenPGP bindings.
(define-deprecated certificate-type/openpgp)
--
2.26.0

View file

@ -344,7 +344,11 @@ (define-public guile-gnutls
(string-append "--with-guile-site-ccache-dir="
"$(libdir)/guile/$(GUILE_EFFECTIVE_VERSION)/site-ccache")
(string-append "--with-guile-extension-dir="
"$(libdir)/guile/$(GUILE_EFFECTIVE_VERSION)/extensions"))))
"$(libdir)/guile/$(GUILE_EFFECTIVE_VERSION)/extensions"))
;; The 'gnutls' package currently lacks support for SRP, making this
;; test fail.
#:make-flags #~'("XFAIL_TESTS=tests/srp-base64.scm")))
(native-inputs
(list libtool
pkg-config