gnu: d-feet: Fix build errors when using Meson 1.1.0.

Fix the build error:

data/meson.build:15:0: ERROR: Function does not take positional arguments.
data/meson.build:27:0: ERROR: Function does not take positional arguments.

* gnu/packages/patches/d-feet-drop-unused-meson-argument.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it here.
* gnu/packages/gnome.scm (d-feet)[source]: Use it here.

Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
This commit is contained in:
Zhu Zihao 2023-05-19 19:51:41 +08:00 committed by Liliana Marie Prikler
parent b3492964c2
commit 07ac0cb722
No known key found for this signature in database
GPG key ID: 442A84B8C70E2F87
3 changed files with 41 additions and 1 deletions

View file

@ -1033,6 +1033,7 @@ dist_patch_DATA = \
%D%/packages/patches/curl-use-ssl-cert-env.patch \
%D%/packages/patches/cursynth-wave-rand.patch \
%D%/packages/patches/cvs-CVE-2017-12836.patch \
%D%/packages/patches/d-feet-drop-unused-meson-argument.patch \
%D%/packages/patches/date-output-pkg-config-files.patch \
%D%/packages/patches/datefudge-gettimeofday.patch \
%D%/packages/patches/dbacl-include-locale.h.patch \

View file

@ -76,6 +76,7 @@
;;; Copyright © 2023 Kaelyn Takata <kaelyn.alexi@protonmail.com>
;;; Copyright © 2023 Juliana Sims <juli@incana.org>
;;; Copyright © 2023 Dominik Delgado Steuter <d@delgado.nrw>
;;; Copyright © 2023 Zhu Zihao <all_but_last@163.com>
;;;
;;; This file is part of GNU Guix.
;;;
@ -7199,7 +7200,9 @@ (define-public d-feet
name "-" version ".tar.xz"))
(sha256
(base32
"1jqw5ndpgyb0zxh0g21ai1911lfrm56vz18xbccfqm4sk95wwcw7"))))
"1jqw5ndpgyb0zxh0g21ai1911lfrm56vz18xbccfqm4sk95wwcw7"))
(patches
(search-patches "d-feet-drop-unused-meson-argument.patch"))))
(build-system meson-build-system)
(arguments
(list

View file

@ -0,0 +1,36 @@
From 05465d486afdba116dbc22fc22c1e6573aea4f22 Mon Sep 17 00:00:00 2001
From: Jan Beich <jbeich@FreeBSD.org>
Date: Mon, 24 Jan 2022 12:11:57 +0000
Subject: [PATCH] meson: drop unused argument for i18n.merge_file()
Ignored in Meson < 0.60.0, deprecated since 0.60.1 and fatal since 0.61.0.
data/meson.build:15:0: ERROR: Function does not take positional arguments.
data/meson.build:27:0: ERROR: Function does not take positional arguments.
---
data/meson.build | 2 --
1 file changed, 2 deletions(-)
diff --git a/data/meson.build b/data/meson.build
index 026bd80..3b03b94 100644
--- a/data/meson.build
+++ b/data/meson.build
@@ -13,7 +13,6 @@ desktop_in = configure_file(
)
i18n.merge_file(
- desktop,
type: 'desktop',
input: desktop_in,
output: '@BASENAME@',
@@ -25,7 +24,6 @@ i18n.merge_file(
appdata = df_namespace + '.appdata.xml'
i18n.merge_file(
- appdata,
input: appdata + '.in',
output: '@BASENAME@',
po_dir: po_dir,
--
GitLab