gnu: fontconfig: Update to 2.13.93.

* gnu/packages/patches/fontconfig-hurd-path-max.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Un-register file.
* gnu/packages/fontutils.scm (fontconfig)[source]
{uri}: Use the .tar.xz archive.
{patches}: Remove field.  The patch was merged upstream.
[native-inputs]: Add python-minimal.
[phases]{skip-problematic-tests}: Add phase.
[configure-flags]: Do not set PYTHON to false.
* gnu/packages/fontutils.scm (fontconfig-with-documentation)
[native-inputs]: Add docbook-utils.
This commit is contained in:
Maxim Cournoyer 2020-12-27 22:56:00 -05:00
parent 7f9da31c31
commit 0ad27959d8
No known key found for this signature in database
GPG key ID: 1260E46482E63562
3 changed files with 20 additions and 31 deletions

View file

@ -997,7 +997,6 @@ dist_patch_DATA = \
%D%/packages/patches/foobillard++-pkg-config.patch \
%D%/packages/patches/foomatic-filters-CVE-2015-8327.patch \
%D%/packages/patches/foomatic-filters-CVE-2015-8560.patch \
%D%/packages/patches/fontconfig-hurd-path-max.patch \
%D%/packages/patches/fpc-reproducibility.patch \
%D%/packages/patches/fplll-std-fenv.patch \
%D%/packages/patches/freedink-engine-fix-sdl-hints.patch \

View file

@ -12,6 +12,7 @@
;;; Copyright © 2019, 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2020 Roel Janssen <roel@gnu.org>
;;; Copyright © 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@ -36,6 +37,7 @@ (define-module (gnu packages fontutils)
#:use-module (gnu packages check)
#:use-module (gnu packages compression)
#:use-module (gnu packages datastructures)
#:use-module (gnu packages docbook)
#:use-module (gnu packages flex)
#:use-module (gnu packages fonts)
#:use-module (gnu packages freedesktop)
@ -58,6 +60,7 @@ (define-module (gnu packages fontutils)
#:use-module (gnu packages xdisorg)
#:use-module (gnu packages xml)
#:use-module (gnu packages xorg)
#:use-module (gnu packages tex)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix download)
@ -319,15 +322,14 @@ (define-public fontconfig
(hidden-package
(package
(name "fontconfig-minimal")
(version "2.13.1")
(version "2.13.93")
(source (origin
(method url-fetch)
(uri (string-append
"https://www.freedesktop.org/software/fontconfig/release/fontconfig-"
version ".tar.bz2"))
(patches (search-patches "fontconfig-hurd-path-max.patch"))
(sha256 (base32
"0hb700a68kk0ip51wdlnjjc682kvlrmb6q920mzajykdk0mdsmgn"))))
(method url-fetch)
(uri (string-append
"https://www.freedesktop.org/software/"
"fontconfig/release/fontconfig-" version ".tar.xz"))
(sha256 (base32
"1850q4k80yxma5g3yxkvyv8i5a3xqzswwml8gjy3jmywx8qqd5pa"))))
(build-system gnu-build-system)
;; In Requires or Requires.private of fontconfig.pc.
(propagated-inputs `(("expat" ,expat)
@ -339,7 +341,8 @@ (define-public fontconfig
`(("font-dejavu" ,font-dejavu)))
(native-inputs
`(("gperf" ,gperf)
("pkg-config" ,pkg-config)))
("pkg-config" ,pkg-config)
("python" ,python-minimal))) ;to avoid a cycle through tk
(arguments
`(#:configure-flags
(list "--disable-docs"
@ -352,12 +355,16 @@ (define-public fontconfig
;; Register fonts from user and system profiles.
(string-append "--with-add-fonts="
"~/.guix-profile/share/fonts,"
"/run/current-system/profile/share/fonts")
;; python is not actually needed
"PYTHON=false")
"/run/current-system/profile/share/fonts"))
#:phases
(modify-phases %standard-phases
(add-before 'check 'skip-problematic-tests
(lambda _
(substitute* "test/run-test.sh"
;; The crbug1004254 test attempts to fetch fonts from the
;; network.
(("\\[ -x \"\\$BUILDTESTDIR\"/test-crbug1004254 \\]")
"false"))))
(replace 'install
(lambda _
;; Don't try to create /var/cache/fontconfig.

View file

@ -1,17 +0,0 @@
Avoid usage of PATH_MAX.
Taken from https://salsa.debian.org/freedesktop-team/fontconfig/-/blob/master/debian/patches/path_max.patch
Index: fontconfig-2.13.1/src/fccfg.c
===================================================================
--- fontconfig-2.13.1.orig/src/fccfg.c
+++ fontconfig-2.13.1/src/fccfg.c
@@ -2231,7 +2231,7 @@ FcConfigRealFilename (FcConfig *config,
if (n)
{
- FcChar8 buf[PATH_MAX];
+ FcChar8 buf[FC_PATH_MAX];
ssize_t len;
if (sysroot)