mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 07:26:13 -05:00
gnu: CMake: Update to 3.23.2.
* gnu/packages/cmake.scm (cmake-bootstrap): Update to 3.23.2. (%preserved-third-party-files): Preserve bundled ELF header files. * gnu/packages/patches/cmake-curl-certificates.patch: Adjust for upstream changes.
This commit is contained in:
parent
b1fa242cb1
commit
0b0750e831
2 changed files with 12 additions and 9 deletions
|
@ -142,6 +142,8 @@ (define %preserved-third-party-files
|
|||
;; be available along with the required headers.
|
||||
"Utilities/cmlibarchive/libarchive/archive_getdate.c"
|
||||
"Utilities/cmlibarchive/libarchive/archive_getdate.h"
|
||||
;; ELF headers.
|
||||
"Utilities/cmelf"
|
||||
;; CMake header wrappers.
|
||||
"Utilities/cm3p"))
|
||||
|
||||
|
@ -150,7 +152,7 @@ (define %preserved-third-party-files
|
|||
(define-public cmake-bootstrap
|
||||
(package
|
||||
(name "cmake-bootstrap")
|
||||
(version "3.21.4")
|
||||
(version "3.23.2")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "https://cmake.org/files/v"
|
||||
|
@ -158,7 +160,7 @@ (define-public cmake-bootstrap
|
|||
"/cmake-" version ".tar.gz"))
|
||||
(sha256
|
||||
(base32
|
||||
"0y2rk316j9m1iqimgwah0z1ii3ggli65dw6hdn4ckx0mqaahlmyr"))
|
||||
"1ai6zycs4zj49d46lzz9b6l0q5hvlkyix66zd90rlvs6ac0b85pk"))
|
||||
(patches (search-patches "cmake-curl-certificates.patch"))))
|
||||
(build-system gnu-build-system)
|
||||
(arguments
|
||||
|
|
|
@ -4,22 +4,23 @@ at all: <https://issues.guix.gnu.org/issue/37371>.
|
|||
This changes CMake such that commands honor SSL_CERT_FILE and SSL_CERT_DIR
|
||||
as well as /etc/ssl/certs.
|
||||
|
||||
--- cmake-3.13.1/Source/cmCurl.cxx 2019-09-10 17:27:36.926907260 +0200
|
||||
+++ cmake-3.13.1/Source/cmCurl.cxx 2019-09-10 17:52:35.475903919 +0200
|
||||
@@ -2,11 +2,8 @@
|
||||
diff --git a/Source/cmCurl.cxx b/Source/cmCurl.cxx
|
||||
index 28ee24dfe9..6b2bb09ff5 100644
|
||||
--- a/Source/cmCurl.cxx
|
||||
+++ b/Source/cmCurl.cxx
|
||||
@@ -2,10 +2,7 @@
|
||||
file Copyright.txt or https://cmake.org/licensing for details. */
|
||||
#include "cmCurl.h"
|
||||
|
||||
-#if !defined(CMAKE_USE_SYSTEM_CURL) && !defined(_WIN32) && \
|
||||
- !defined(__APPLE__) && !defined(CURL_CA_BUNDLE) && !defined(CURL_CA_PATH)
|
||||
# define CMAKE_FIND_CAFILE
|
||||
# include "cmSystemTools.h"
|
||||
-#endif
|
||||
#include "cmStringAlgorithms.h"
|
||||
#include "cmSystemTools.h"
|
||||
|
||||
// curl versions before 7.21.5 did not provide this error code
|
||||
@@ -30,6 +27,19 @@
|
||||
::CURLcode res = ::curl_easy_setopt(curl, CURLOPT_CAINFO, cafile);
|
||||
@@ -38,6 +35,19 @@ std::string cmCurlSetCAInfo(::CURL* curl, const std::string& cafile)
|
||||
::CURLcode res = ::curl_easy_setopt(curl, CURLOPT_CAINFO, cafile.c_str());
|
||||
check_curl_result(res, "Unable to set TLS/SSL Verify CAINFO: ");
|
||||
}
|
||||
+
|
||||
|
|
Loading…
Reference in a new issue