mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-12-26 06:18:07 -05:00
gnu: gnutls: Upgrade to 3.2.4.
* gnu/packages/gnutls.scm (gnutls): Update to 3.2.4; remove 'arguments' field, remove "patch/fix-tests" from the inputs. * gnu/packages/patches/gnutls-fix-tests-on-32-bits-system.patch: Remove. * gnu-system.am (dist_patch_DATA): Adjust accordingly.
This commit is contained in:
parent
1b0a8212d1
commit
0cb9b45674
3 changed files with 3 additions and 46 deletions
|
@ -208,7 +208,6 @@ dist_patch_DATA = \
|
||||||
gnu/packages/patches/glib-tests-prlimit.patch \
|
gnu/packages/patches/glib-tests-prlimit.patch \
|
||||||
gnu/packages/patches/glibc-bootstrap-system.patch \
|
gnu/packages/patches/glibc-bootstrap-system.patch \
|
||||||
gnu/packages/patches/glibc-no-ld-so-cache.patch \
|
gnu/packages/patches/glibc-no-ld-so-cache.patch \
|
||||||
gnu/packages/patches/gnutls-fix-tests-on-32-bits-system.patch \
|
|
||||||
gnu/packages/patches/grub-gets-undeclared.patch \
|
gnu/packages/patches/grub-gets-undeclared.patch \
|
||||||
gnu/packages/patches/guile-1.8-cpp-4.5.patch \
|
gnu/packages/patches/guile-1.8-cpp-4.5.patch \
|
||||||
gnu/packages/patches/guile-default-utf8.patch \
|
gnu/packages/patches/guile-default-utf8.patch \
|
||||||
|
|
|
@ -54,7 +54,7 @@ (define-public libtasn1
|
||||||
(define-public gnutls
|
(define-public gnutls
|
||||||
(package
|
(package
|
||||||
(name "gnutls")
|
(name "gnutls")
|
||||||
(version "3.2.1")
|
(version "3.2.4")
|
||||||
(source (origin
|
(source (origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri
|
(uri
|
||||||
|
@ -64,20 +64,14 @@ (define-public gnutls
|
||||||
version ".tar.xz"))
|
version ".tar.xz"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"1zi2kq3vcbqdy9khl7r6pgk4hgwibniasm9k6siasdvqjijq3ymb"))))
|
"0zvhzy87v9dfxfvmg1pl951kw55rp647cqdza8942fxq7spp158i"))))
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(arguments
|
|
||||||
`(#:patches (list (assoc-ref %build-inputs
|
|
||||||
"patch/fix-tests"))
|
|
||||||
#:patch-flags '("-p0")))
|
|
||||||
(native-inputs
|
(native-inputs
|
||||||
`(("pkg-config" ,pkg-config)))
|
`(("pkg-config" ,pkg-config)))
|
||||||
(inputs
|
(inputs
|
||||||
`(("guile" ,guile-2.0)
|
`(("guile" ,guile-2.0)
|
||||||
("zlib" ,guix:zlib)
|
("zlib" ,guix:zlib)
|
||||||
("perl" ,perl)
|
("perl" ,perl)))
|
||||||
("patch/fix-tests"
|
|
||||||
,(search-patch "gnutls-fix-tests-on-32-bits-system.patch"))))
|
|
||||||
(propagated-inputs
|
(propagated-inputs
|
||||||
`(("libtasn1" ,libtasn1)
|
`(("libtasn1" ,libtasn1)
|
||||||
("nettle" ,nettle)
|
("nettle" ,nettle)
|
||||||
|
|
|
@ -1,36 +0,0 @@
|
||||||
From b12040aeab5fbaf02677571db1d8bf1995bd5ee0 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Nikos Mavrogiannopoulos <nmav@gnutls.org>
|
|
||||||
Date: Sun, 2 Jun 2013 12:10:06 +0200
|
|
||||||
Subject: [PATCH] Avoid comparing the expiration date to prevent false positive
|
|
||||||
error in 32-bit systems.
|
|
||||||
|
|
||||||
---
|
|
||||||
tests/cert-tests/pem-decoding | 6 ++++--
|
|
||||||
1 files changed, 4 insertions(+), 2 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/tests/cert-tests/pem-decoding b/tests/cert-tests/pem-decoding
|
|
||||||
index fe769ec..f8c6372 100755
|
|
||||||
--- tests/cert-tests/pem-decoding
|
|
||||||
+++ tests/cert-tests/pem-decoding
|
|
||||||
@@ -61,7 +61,9 @@ if test "$rc" != "0"; then
|
|
||||||
exit $rc
|
|
||||||
fi
|
|
||||||
|
|
||||||
-diff $srcdir/complex-cert.pem tmp-pem.pem
|
|
||||||
+cat $srcdir/complex-cert.pem |grep -v "Not After:" >tmp1
|
|
||||||
+cat $srcdir/tmp-pem.pem |grep -v "Not After:" >tmp2
|
|
||||||
+diff tmp1 tmp2
|
|
||||||
rc=$?
|
|
||||||
|
|
||||||
if test "$rc" != "0"; then
|
|
||||||
@@ -69,6 +71,6 @@ if test "$rc" != "0"; then
|
|
||||||
exit $rc
|
|
||||||
fi
|
|
||||||
|
|
||||||
-rm -f tmp-pem.pem
|
|
||||||
+rm -f tmp-pem.pem tmp1 tmp2
|
|
||||||
|
|
||||||
exit 0
|
|
||||||
--
|
|
||||||
1.7.1
|
|
||||||
|
|
Loading…
Reference in a new issue