mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-12-25 05:48:07 -05:00
gnu: docbook-xsl: Disable recursion in string substitution.
Fixes <https://bugs.gnu.org/29782>. Reported by Gábor Boskovits. * gnu/packages/patches/docbook-xsl-nonrecursive-string-subst.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/docbook.scm (docbook-xsl)[source](patches): Use it. [native-inputs]: Add XZ. [arguments]: Adjust PATH accordingly.
This commit is contained in:
parent
0c86790bfd
commit
0f72f05238
3 changed files with 45 additions and 1 deletions
|
@ -600,6 +600,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/dfu-programmer-fix-libusb.patch \
|
||||
%D%/packages/patches/diffutils-gets-undeclared.patch \
|
||||
%D%/packages/patches/diffutils-getopt.patch \
|
||||
%D%/packages/patches/docbook-xsl-nonrecursive-string-subst.patch \
|
||||
%D%/packages/patches/doc++-include-directives.patch \
|
||||
%D%/packages/patches/doc++-segfault-fix.patch \
|
||||
%D%/packages/patches/doxygen-test.patch \
|
||||
|
|
|
@ -136,6 +136,8 @@ (define-public docbook-xsl
|
|||
(method url-fetch)
|
||||
(uri (string-append "mirror://sourceforge/docbook/docbook-xsl/"
|
||||
version "/docbook-xsl-" version ".tar.bz2"))
|
||||
;; Note: If removing all patches, the XZ dependency is no longer needed.
|
||||
(patches (search-patches "docbook-xsl-nonrecursive-string-subst.patch"))
|
||||
(sha256
|
||||
(base32
|
||||
"0s59lihif2fr7rznckxr2kfyrvkirv76r1zvidp9b5mj28p4apvj"))))
|
||||
|
@ -145,11 +147,12 @@ (define-public docbook-xsl
|
|||
(use-modules (guix build utils))
|
||||
|
||||
(let* ((bzip2 (assoc-ref %build-inputs "bzip2"))
|
||||
(xz (assoc-ref %build-inputs "xz"))
|
||||
(tar (assoc-ref %build-inputs "tar"))
|
||||
(source (assoc-ref %build-inputs "source"))
|
||||
(out (assoc-ref %outputs "out"))
|
||||
(xsl (string-append out "/xml/xsl")))
|
||||
(setenv "PATH" (string-append bzip2 "/bin"))
|
||||
(setenv "PATH" (string-append bzip2 "/bin" ":" xz "/bin"))
|
||||
(system* (string-append tar "/bin/tar") "xvf" source)
|
||||
|
||||
(mkdir-p xsl)
|
||||
|
@ -162,6 +165,7 @@ (define-public docbook-xsl
|
|||
name-version "/")))))
|
||||
#:modules ((guix build utils))))
|
||||
(native-inputs `(("bzip2" ,bzip2)
|
||||
("xz" ,xz)
|
||||
("tar" ,tar)))
|
||||
(home-page "http://docbook.org")
|
||||
(synopsis "DocBook XSL style sheets for document authoring")
|
||||
|
|
|
@ -0,0 +1,39 @@
|
|||
Use a non-recursive replace function when the parser supports it.
|
||||
|
||||
https://bugs.gnu.org/29782
|
||||
https://bugzilla.samba.org/show_bug.cgi?id=9515
|
||||
https://bugzilla.gnome.org/show_bug.cgi?id=736077 (for xsltproc)
|
||||
|
||||
Patch copied from Debian:
|
||||
https://anonscm.debian.org/cgit/collab-maint/docbook-xsl.git/tree/debian/patches/765567_non-recursive_string_subst.patch
|
||||
|
||||
Description: use EXSLT "replace" function when available
|
||||
A recursive implementation of string.subst is problematic,
|
||||
long strings with many matches will cause stack overflows.
|
||||
Author: Peter De Wachter <pdewacht@gmail.com>
|
||||
Bug-Debian: https://bugs.debian.org/750593
|
||||
|
||||
--- a/lib/lib.xsl
|
||||
+++ b/lib/lib.xsl
|
||||
@@ -10,7 +10,10 @@
|
||||
This module implements DTD-independent functions
|
||||
|
||||
******************************************************************** -->
|
||||
-<xsl:stylesheet xmlns:xsl="http://www.w3.org/1999/XSL/Transform" version="1.0">
|
||||
+<xsl:stylesheet xmlns:xsl="http://www.w3.org/1999/XSL/Transform"
|
||||
+ xmlns:str="http://exslt.org/strings"
|
||||
+ exclude-result-prefixes="str"
|
||||
+ version="1.0">
|
||||
|
||||
<xsl:template name="dot.count">
|
||||
<!-- Returns the number of "." characters in a string -->
|
||||
@@ -56,6 +59,9 @@
|
||||
<xsl:param name="replacement"/>
|
||||
|
||||
<xsl:choose>
|
||||
+ <xsl:when test="function-available('str:replace')">
|
||||
+ <xsl:value-of select="str:replace($string, string($target), string($replacement))"/>
|
||||
+ </xsl:when>
|
||||
<xsl:when test="contains($string, $target)">
|
||||
<xsl:variable name="rest">
|
||||
<xsl:call-template name="string.subst">
|
Loading…
Reference in a new issue