mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-12-26 06:18:07 -05:00
gnu: inkscape: Fix build with Poppler 22.9.0.
This fixes a regression introduced in c37a31e9ab
.
* gnu/packages/patches/inkscape-poppler-compat.patch: New file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/inkscape.scm (inkscape/stable)[source](patches): New field.
This commit is contained in:
parent
fc398e1a74
commit
135ad8988a
3 changed files with 47 additions and 0 deletions
|
@ -1305,6 +1305,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/imagemagick-ReadDCMImage-fix.patch \
|
||||
%D%/packages/patches/imagemagick-ReadDCMPixels-fix.patch \
|
||||
%D%/packages/patches/imagemagick-WriteTHUMBNAILImage-fix.patch \
|
||||
%D%/packages/patches/inkscape-poppler-compat.patch \
|
||||
%D%/packages/patches/instead-use-games-path.patch \
|
||||
%D%/packages/patches/intel-xed-fix-nondeterminism.patch \
|
||||
%D%/packages/patches/intltool-perl-compatibility.patch \
|
||||
|
|
|
@ -68,6 +68,7 @@ (define-public inkscape/stable
|
|||
(uri (string-append "https://media.inkscape.org/dl/"
|
||||
"resources/file/"
|
||||
"inkscape-" version ".tar.xz"))
|
||||
(patches (search-patches "inkscape-poppler-compat.patch"))
|
||||
(sha256
|
||||
(base32 "06scilds4p4bw337ss22nfdxy2kynv5yjw6vq6nlpjm7xfh7vkj6"))
|
||||
(modules '((guix build utils)
|
||||
|
|
45
gnu/packages/patches/inkscape-poppler-compat.patch
Normal file
45
gnu/packages/patches/inkscape-poppler-compat.patch
Normal file
|
@ -0,0 +1,45 @@
|
|||
Fix build with Poppler 22.9.0.
|
||||
|
||||
Taken from upstream:
|
||||
|
||||
https://gitlab.com/inkscape/inkscape/-/commit/fb00794923d19cfbb2ca4adca3ae8971553a06be
|
||||
|
||||
diff --git a/src/extension/internal/pdfinput/pdf-parser.cpp b/src/extension/internal/pdfinput/pdf-parser.cpp
|
||||
index cca1e840966c7940a1af472025535042b07e3e0f..80d64c9b866d5d3dd095636a9a02571b89061af1 100644
|
||||
--- a/src/extension/internal/pdfinput/pdf-parser.cpp
|
||||
+++ b/src/extension/internal/pdfinput/pdf-parser.cpp
|
||||
@@ -697,7 +697,11 @@ void PdfParser::opSetDash(Object args[], int /*numArgs*/)
|
||||
_POPPLER_FREE(obj);
|
||||
}
|
||||
}
|
||||
+#if POPPLER_CHECK_VERSION(22, 9, 0)
|
||||
+ state->setLineDash(std::vector<double> (dash, dash + length), args[1].getNum());
|
||||
+#else
|
||||
state->setLineDash(dash, length, args[1].getNum());
|
||||
+#endif
|
||||
builder->updateStyle(state);
|
||||
}
|
||||
|
||||
diff --git a/src/extension/internal/pdfinput/svg-builder.cpp b/src/extension/internal/pdfinput/svg-builder.cpp
|
||||
index 12f71dd9214b95dbad6fdf7642a96cdd57f2c64a..9fc56fe63c2feee986ad1ff5018e679a0bacb665 100644
|
||||
--- a/src/extension/internal/pdfinput/svg-builder.cpp
|
||||
+++ b/src/extension/internal/pdfinput/svg-builder.cpp
|
||||
@@ -389,10 +389,17 @@ void SvgBuilder::_setStrokeStyle(SPCSSAttr *css, GfxState *state) {
|
||||
sp_repr_css_set_property(css, "stroke-miterlimit", os_ml.str().c_str());
|
||||
|
||||
// Line dash
|
||||
- double *dash_pattern;
|
||||
int dash_length;
|
||||
double dash_start;
|
||||
+#if POPPLER_CHECK_VERSION(22, 9, 0)
|
||||
+ const double *dash_pattern;
|
||||
+ const std::vector<double> &dash = state->getLineDash(&dash_start);
|
||||
+ dash_pattern = dash.data();
|
||||
+ dash_length = dash.size();
|
||||
+#else
|
||||
+ double *dash_pattern;
|
||||
state->getLineDash(&dash_pattern, &dash_length, &dash_start);
|
||||
+#endif
|
||||
if ( dash_length > 0 ) {
|
||||
Inkscape::CSSOStringStream os_array;
|
||||
for ( int i = 0 ; i < dash_length ; i++ ) {
|
Loading…
Reference in a new issue