mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2025-01-11 21:59:08 -05:00
gnu: screen: Update to 5.0.0
* gnu/packages/patches/screen-hurd-path-max.patch: Update for screen 5.0.0. * gnu/packages/screen.scm (screen): Update to 5.0.0. [arguments]<#:configure-flags: Add "-D_GNU_SOURCE=1" to CFLAGS. [inputs]: Add linux-pam. Change-Id: Iebc5eff0128ff7f4d27a22cca1bd4a025aca3244 Signed-off-by: Ludovic Courtès <ludo@gnu.org>
This commit is contained in:
parent
49ece68b0b
commit
13e7bc4e01
2 changed files with 27 additions and 27 deletions
|
@ -6,29 +6,16 @@ Description: Set PATH_MAX to 4096 if undefined
|
||||||
Fixes FTBFS since 4.4.0 on GNU/Hurd. Updated to add one more occurrence for 4.5.0.
|
Fixes FTBFS since 4.4.0 on GNU/Hurd. Updated to add one more occurrence for 4.5.0.
|
||||||
Author: Axel Beckert <abe@debian.org>
|
Author: Axel Beckert <abe@debian.org>
|
||||||
Bug: https://savannah.gnu.org/bugs/?50089
|
Bug: https://savannah.gnu.org/bugs/?50089
|
||||||
Last-Updated: 2017-01-18
|
Updated: 2017-01-18
|
||||||
|
Updated: 2024-08-30 Update for Screen 5.0.0
|
||||||
|
|
||||||
--- a/tty.sh
|
diff --git a/screen.h b/screen.h
|
||||||
+++ b/tty.sh
|
index 308c365..e71bd7f 100644
|
||||||
@@ -1478,6 +1478,13 @@
|
|
||||||
return 0;
|
|
||||||
}
|
|
||||||
|
|
||||||
+/*
|
|
||||||
+ * Define PATH_MAX to 4096 if it's not defined, like on GNU/Hurd
|
|
||||||
+ */
|
|
||||||
+
|
|
||||||
+#ifndef PATH_MAX
|
|
||||||
+#define PATH_MAX 4096
|
|
||||||
+#endif
|
|
||||||
|
|
||||||
int CheckTtyname (char *tty)
|
|
||||||
{
|
|
||||||
--- a/screen.h
|
--- a/screen.h
|
||||||
+++ b/screen.h
|
+++ b/screen.h
|
||||||
@@ -109,6 +109,13 @@
|
@@ -63,6 +63,22 @@ struct mode {
|
||||||
# define DEFAULT_BUFFERFILE "/tmp/screen-exchange"
|
|
||||||
#endif
|
#endif
|
||||||
|
};
|
||||||
|
|
||||||
+/*
|
+/*
|
||||||
+ * Define PATH_MAX to 4096 if it's not defined, like on GNU/Hurd
|
+ * Define PATH_MAX to 4096 if it's not defined, like on GNU/Hurd
|
||||||
|
@ -37,6 +24,15 @@ Last-Updated: 2017-01-18
|
||||||
+#ifndef PATH_MAX
|
+#ifndef PATH_MAX
|
||||||
+#define PATH_MAX 4096
|
+#define PATH_MAX 4096
|
||||||
+#endif
|
+#endif
|
||||||
|
+
|
||||||
|
+/*
|
||||||
|
+ * similarly for MAXPATHLEN
|
||||||
|
+ */
|
||||||
|
+
|
||||||
|
+#ifndef MAXPATHLEN
|
||||||
|
+#define MAXPATHLEN PATH_MAX
|
||||||
|
+#endif
|
||||||
|
+
|
||||||
|
|
||||||
#if defined(hpux) && !(defined(VSUSP) && defined(VDSUSP) && defined(VWERASE) && defined(VLNEXT))
|
#include "ansi.h"
|
||||||
# define HPUX_LTCHARS_HACK
|
#include "image.h"
|
||||||
|
|
|
@ -37,6 +37,7 @@ (define-module (gnu packages screen)
|
||||||
#:use-module (gnu packages bash)
|
#:use-module (gnu packages bash)
|
||||||
#:use-module (gnu packages crypto)
|
#:use-module (gnu packages crypto)
|
||||||
#:use-module (gnu packages hurd)
|
#:use-module (gnu packages hurd)
|
||||||
|
#:use-module (gnu packages linux)
|
||||||
#:use-module (gnu packages ncurses)
|
#:use-module (gnu packages ncurses)
|
||||||
#:use-module (gnu packages perl)
|
#:use-module (gnu packages perl)
|
||||||
#:use-module (gnu packages python)
|
#:use-module (gnu packages python)
|
||||||
|
@ -46,24 +47,27 @@ (define-module (gnu packages screen)
|
||||||
(define-public screen
|
(define-public screen
|
||||||
(package
|
(package
|
||||||
(name "screen")
|
(name "screen")
|
||||||
(version "4.9.1")
|
(version "5.0.0")
|
||||||
(source (origin
|
(source (origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (string-append "mirror://gnu/screen/screen-"
|
(uri (string-append "mirror://gnu/screen/screen-"
|
||||||
version ".tar.gz"))
|
version ".tar.gz"))
|
||||||
(patches (search-patches "screen-hurd-path-max.patch"))
|
(patches (search-patches "screen-hurd-path-max.patch"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32 "0sdc0ms6qxm4gbx0caw7pwghj5aw1h8syvxdhkac0w95qkiz7ki6"))))
|
(base32 "0wa9v6p7cna2scpimpvk9pgxaah80f4q0f2kln37qp0f1b83jjph"))))
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(native-inputs
|
(native-inputs
|
||||||
(list autoconf automake texinfo))
|
(list autoconf automake texinfo))
|
||||||
(inputs
|
(inputs
|
||||||
(list libxcrypt ncurses perl))
|
(list libxcrypt linux-pam ncurses perl))
|
||||||
(arguments
|
(arguments
|
||||||
`(#:configure-flags
|
`(#:configure-flags
|
||||||
|
;; GNU_SOURCE must be defined for mallocmock_reset() to be defined
|
||||||
|
'("CFLAGS=-O2 -g -D_GNU_SOURCE=1"
|
||||||
|
|
||||||
;; By default, screen supports 16 colors, but we want 256 when
|
;; By default, screen supports 16 colors, but we want 256 when
|
||||||
;; ~/.screenrc contains 'term xterm-256color'.
|
;; ~/.screenrc contains 'term xterm-256color'.
|
||||||
'("--enable-colors256")))
|
"--enable-colors256")))
|
||||||
(home-page "https://www.gnu.org/software/screen/")
|
(home-page "https://www.gnu.org/software/screen/")
|
||||||
(synopsis "Full-screen window manager providing multiple terminals")
|
(synopsis "Full-screen window manager providing multiple terminals")
|
||||||
(description
|
(description
|
||||||
|
|
Loading…
Reference in a new issue