mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-12-24 05:18:07 -05:00
gnu: Add ttf2eot.
* gnu/packages/fontutils.scm (ttf2eot): New variable. * gnu/packages/patches/ttf2eot-cstddef.patch: New patch. * gnu-system.am (dist_patch_DATA): Add it.
This commit is contained in:
parent
508a85dfd6
commit
1555aee7d0
3 changed files with 50 additions and 0 deletions
|
@ -727,6 +727,7 @@ dist_patch_DATA = \
|
||||||
gnu/packages/patches/tidy-CVE-2015-5522+5523.patch \
|
gnu/packages/patches/tidy-CVE-2015-5522+5523.patch \
|
||||||
gnu/packages/patches/tinyxml-use-stl.patch \
|
gnu/packages/patches/tinyxml-use-stl.patch \
|
||||||
gnu/packages/patches/tk-find-library.patch \
|
gnu/packages/patches/tk-find-library.patch \
|
||||||
|
gnu/packages/patches/ttf2eot-cstddef.patch \
|
||||||
gnu/packages/patches/ttfautohint-source-date-epoch.patch \
|
gnu/packages/patches/ttfautohint-source-date-epoch.patch \
|
||||||
gnu/packages/patches/tophat-build-with-later-seqan.patch \
|
gnu/packages/patches/tophat-build-with-later-seqan.patch \
|
||||||
gnu/packages/patches/torsocks-dns-test.patch \
|
gnu/packages/patches/torsocks-dns-test.patch \
|
||||||
|
|
|
@ -144,6 +144,43 @@ (define-public woff-tools
|
||||||
(license (list license:mpl1.1 license:gpl2+ license:lgpl2.1+))
|
(license (list license:mpl1.1 license:gpl2+ license:lgpl2.1+))
|
||||||
(home-page "https://people.mozilla.com/~jkew/woff/")))
|
(home-page "https://people.mozilla.com/~jkew/woff/")))
|
||||||
|
|
||||||
|
(define-public ttf2eot
|
||||||
|
(package
|
||||||
|
(name "ttf2eot")
|
||||||
|
(version "0.0.2-2")
|
||||||
|
(source
|
||||||
|
(origin
|
||||||
|
(method url-fetch)
|
||||||
|
(uri (string-append "https://storage.googleapis.com/"
|
||||||
|
"google-code-archive-downloads/v2/"
|
||||||
|
"code.google.com/ttf2eot/"
|
||||||
|
"ttf2eot-" version ".tar.gz"))
|
||||||
|
(sha256
|
||||||
|
(base32
|
||||||
|
"1f4dzzmhn0208dvbm3ia5ar6ls9apwc6ampy5blmfxkigi6z0g02"))
|
||||||
|
(patches (list (search-patch "ttf2eot-cstddef.patch")))))
|
||||||
|
(build-system gnu-build-system)
|
||||||
|
(arguments
|
||||||
|
`(#:tests? #f ;no tests
|
||||||
|
#:phases
|
||||||
|
(modify-phases %standard-phases
|
||||||
|
(delete 'configure) ;no configuration
|
||||||
|
(replace 'install
|
||||||
|
(lambda* (#:key outputs #:allow-other-keys)
|
||||||
|
(let* ((out (assoc-ref outputs "out"))
|
||||||
|
(bin (string-append out "/bin")))
|
||||||
|
(install-file "ttf2eot" bin)))))))
|
||||||
|
(synopsis "Convert from TrueType to Embeddable Open Type")
|
||||||
|
(description
|
||||||
|
"This package contains a commandline wrapper around OpenTypeUtilities.cpp
|
||||||
|
from Chromium, used to make EOT (Embeddable Open Type) files from
|
||||||
|
TTF (TrueType/OpenType Font) files.")
|
||||||
|
;; While the README states "License: Derived from WebKit, so BSD/LGPL
|
||||||
|
;; 2/LGPL 2.1", the single derived source file includes only BSD in its
|
||||||
|
;; license header, and the wrapper source contains no license header.
|
||||||
|
(license license:bsd-2)
|
||||||
|
(home-page "https://code.google.com/archive/p/ttf2eot/")))
|
||||||
|
|
||||||
(define-public fontconfig
|
(define-public fontconfig
|
||||||
(package
|
(package
|
||||||
(name "fontconfig")
|
(name "fontconfig")
|
||||||
|
|
12
gnu/packages/patches/ttf2eot-cstddef.patch
Normal file
12
gnu/packages/patches/ttf2eot-cstddef.patch
Normal file
|
@ -0,0 +1,12 @@
|
||||||
|
From resolution of https://code.google.com/p/ttf2eot/issues/detail?id=26
|
||||||
|
|
||||||
|
--- ttf2eot-0.0.2-2/OpenTypeUtilities.cpp 2009-04-30 04:18:46.000000000 -0500
|
||||||
|
+++ ttf2eot-0.0.2-2/OpenTypeUtilities.cpp 2016-03-31 01:06:39.109996011 -0500
|
||||||
|
@@ -25,6 +25,7 @@
|
||||||
|
* OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||||
|
*/
|
||||||
|
|
||||||
|
+#include <cstddef>
|
||||||
|
#include <string.h>
|
||||||
|
#include <vector>
|
||||||
|
|
Loading…
Reference in a new issue