gnu: icu4c: Add patch for VTIMEZONE bug.

Icedove@115 does not properly work without this patch. See:
https://bugzilla.mozilla.org/show_bug.cgi?id=1843007

* gnu/packages/icu4c.scm (icu4c-73)[source]: Use patch.
* gnu/packages/patches/icu4c-icu-22132-fix-vtimezone.patch: New file.
* gnu/local.mk (dist_patch_DATA): Register patch.
Change-Id: Ie64d1e33afedbaedbaafaeb607a201eb671ac7bd

Change-Id: I6d753eacc7daac5663128b20a550044d0fd0ddb7
This commit is contained in:
Jonathan Brielmaier 2024-04-28 21:29:37 +02:00
parent 71f0676a29
commit 15a96bd6e9
No known key found for this signature in database
GPG key ID: ECFC83988B4E4B9F
3 changed files with 35 additions and 2 deletions

View file

@ -1511,6 +1511,7 @@ dist_patch_DATA = \
%D%/packages/patches/icecat-use-system-wide-dir.patch \ %D%/packages/patches/icecat-use-system-wide-dir.patch \
%D%/packages/patches/icedtea-7-hotspot-aarch64-use-c++98.patch \ %D%/packages/patches/icedtea-7-hotspot-aarch64-use-c++98.patch \
%D%/packages/patches/icedtea-7-hotspot-pointer-comparison.patch \ %D%/packages/patches/icedtea-7-hotspot-pointer-comparison.patch \
%D%/packages/patches/icu4c-icu-22132-fix-vtimezone.patch \
%D%/packages/patches/icu4c-fix-TestHebrewCalendarInTemporalLeapYear.patch \ %D%/packages/patches/icu4c-fix-TestHebrewCalendarInTemporalLeapYear.patch \
%D%/packages/patches/id3lib-CVE-2007-4460.patch \ %D%/packages/patches/id3lib-CVE-2007-4460.patch \
%D%/packages/patches/id3lib-UTF16-writing-bug.patch \ %D%/packages/patches/id3lib-UTF16-writing-bug.patch \

View file

@ -126,8 +126,9 @@ (define-public icu4c-73
(base32 (base32
"0iccpdvc0kvpww5a31k9gjkqigyz016i7v80r9zamd34w4fl6mx4")) "0iccpdvc0kvpww5a31k9gjkqigyz016i7v80r9zamd34w4fl6mx4"))
(patches (patches
(cons (append
(search-patch (search-patches
"icu4c-icu-22132-fix-vtimezone.patch"
"icu4c-fix-TestHebrewCalendarInTemporalLeapYear.patch") "icu4c-fix-TestHebrewCalendarInTemporalLeapYear.patch")
(origin-patches (package-source icu4c)))))))) (origin-patches (package-source icu4c))))))))

View file

@ -0,0 +1,31 @@
Source: https://unicode-org.atlassian.net/browse/ICU-22132?focusedCommentId=166752
Author: Sean Burke
License:
Fixes: https://bugzilla.mozilla.org/show_bug.cgi?id=1843007
diff --git a/icu4c/source/i18n/vtzone.cpp b/icu4c/source/i18n/vtzone.cpp
index 3035106701..5e738e11fa 100644
--- a/source/i18n/vtzone.cpp
+++ b/source/i18n/vtzone.cpp
@@ -1735,14 +1735,14 @@ VTimeZone::write(VTZWriter& writer, UErrorCode& status) const {
}
}
} else {
- UnicodeString icutzprop;
- UVector customProps(nullptr, uhash_compareUnicodeString, status);
+ UVector customProps(uprv_deleteUObject, uhash_compareUnicodeString, status);
if (olsonzid.length() > 0 && icutzver.length() > 0) {
- icutzprop.append(olsonzid);
- icutzprop.append(u'[');
- icutzprop.append(icutzver);
- icutzprop.append(u']');
- customProps.addElement(&icutzprop, status);
+ LocalPointer<UnicodeString> icutzprop(new UnicodeString(ICU_TZINFO_PROP), status);
+ icutzprop->append(olsonzid);
+ icutzprop->append(u'[');
+ icutzprop->append(icutzver);
+ icutzprop->append(u']');
+ customProps.adoptElement(icutzprop.orphan(), status);
}
writeZone(writer, *tz, &customProps, status);
}