mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 07:26:13 -05:00
gnu: websocketpp: Update to 0.8.2.
* gnu/packages/web.scm (websocketpp): Update to 0.8.2. [source]: Replace patch. * gnu/packages/patches/websocketpp-fix-for-boost-1.70.patch: Delete file. * gnu/packages/patches/websocketpp-fix-for-cmake-3.15.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it.
This commit is contained in:
parent
53428597a6
commit
1860b41523
4 changed files with 21 additions and 107 deletions
|
@ -1588,7 +1588,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/warsow-qfusion-fix-bool-return-type.patch \
|
||||
%D%/packages/patches/weasyprint-library-paths.patch \
|
||||
%D%/packages/patches/webkitgtk-share-store.patch \
|
||||
%D%/packages/patches/websocketpp-fix-for-boost-1.70.patch \
|
||||
%D%/packages/patches/websocketpp-fix-for-cmake-3.15.patch \
|
||||
%D%/packages/patches/wicd-bitrate-none-fix.patch \
|
||||
%D%/packages/patches/wicd-get-selected-profile-fix.patch \
|
||||
%D%/packages/patches/wicd-urwid-1.3.patch \
|
||||
|
|
|
@ -1,103 +0,0 @@
|
|||
This patch for Boost >= 1.70 was made by merging two patches that
|
||||
are in the 'develop' branch (c769c92 and f810ca2).
|
||||
|
||||
diff -u b/websocketpp/transport/asio/connection.hpp b/websocketpp/transport/asio/connection.hpp
|
||||
--- b/websocketpp/transport/asio/connection.hpp
|
||||
+++ b/websocketpp/transport/asio/connection.hpp
|
||||
@@ -311,9 +311,10 @@
|
||||
* needed.
|
||||
*/
|
||||
timer_ptr set_timer(long duration, timer_handler callback) {
|
||||
- timer_ptr new_timer = lib::make_shared<lib::asio::steady_timer>(
|
||||
- lib::ref(*m_io_service),
|
||||
- lib::asio::milliseconds(duration)
|
||||
+ timer_ptr new_timer(
|
||||
+ new lib::asio::steady_timer(
|
||||
+ *m_io_service,
|
||||
+ lib::asio::milliseconds(duration))
|
||||
);
|
||||
|
||||
if (config::enable_multithreading) {
|
||||
@@ -461,8 +462,7 @@
|
||||
m_io_service = io_service;
|
||||
|
||||
if (config::enable_multithreading) {
|
||||
- m_strand = lib::make_shared<lib::asio::io_service::strand>(
|
||||
- lib::ref(*io_service));
|
||||
+ m_strand.reset(new lib::asio::io_service::strand(*io_service));
|
||||
}
|
||||
|
||||
lib::error_code ec = socket_con_type::init_asio(io_service, m_strand,
|
||||
diff -u b/websocketpp/transport/asio/endpoint.hpp b/websocketpp/transport/asio/endpoint.hpp
|
||||
--- b/websocketpp/transport/asio/endpoint.hpp
|
||||
+++ b/websocketpp/transport/asio/endpoint.hpp
|
||||
@@ -195,8 +195,7 @@
|
||||
|
||||
m_io_service = ptr;
|
||||
m_external_io_service = true;
|
||||
- m_acceptor = lib::make_shared<lib::asio::ip::tcp::acceptor>(
|
||||
- lib::ref(*m_io_service));
|
||||
+ m_acceptor.reset(new lib::asio::ip::tcp::acceptor(*m_io_service));
|
||||
|
||||
m_state = READY;
|
||||
ec = lib::error_code();
|
||||
@@ -688,9 +687,7 @@
|
||||
* @since 0.3.0
|
||||
*/
|
||||
void start_perpetual() {
|
||||
- m_work = lib::make_shared<lib::asio::io_service::work>(
|
||||
- lib::ref(*m_io_service)
|
||||
- );
|
||||
+ m_work.reset(new lib::asio::io_service::work(*m_io_service));
|
||||
}
|
||||
|
||||
/// Clears the endpoint's perpetual flag, allowing it to exit when empty
|
||||
@@ -854,8 +851,7 @@
|
||||
|
||||
// Create a resolver
|
||||
if (!m_resolver) {
|
||||
- m_resolver = lib::make_shared<lib::asio::ip::tcp::resolver>(
|
||||
- lib::ref(*m_io_service));
|
||||
+ m_resolver.reset(new lib::asio::ip::tcp::resolver(*m_io_service));
|
||||
}
|
||||
|
||||
tcon->set_uri(u);
|
||||
unchanged:
|
||||
--- a/websocketpp/transport/asio/security/none.hpp
|
||||
+++ b/websocketpp/transport/asio/security/none.hpp
|
||||
@@ -168,8 +168,7 @@ protected:
|
||||
return socket::make_error_code(socket::error::invalid_state);
|
||||
}
|
||||
|
||||
- m_socket = lib::make_shared<lib::asio::ip::tcp::socket>(
|
||||
- lib::ref(*service));
|
||||
+ m_socket.reset(new lib::asio::ip::tcp::socket(*service));
|
||||
|
||||
if (m_socket_init_handler) {
|
||||
m_socket_init_handler(m_hdl, *m_socket);
|
||||
unchanged:
|
||||
--- a/websocketpp/transport/asio/security/tls.hpp
|
||||
+++ b/websocketpp/transport/asio/security/tls.hpp
|
||||
@@ -193,8 +193,7 @@ protected:
|
||||
if (!m_context) {
|
||||
return socket::make_error_code(socket::error::invalid_tls_context);
|
||||
}
|
||||
- m_socket = lib::make_shared<socket_type>(
|
||||
- _WEBSOCKETPP_REF(*service),lib::ref(*m_context));
|
||||
+ m_socket.reset(new socket_type(*service, *m_context));
|
||||
|
||||
if (m_socket_init_handler) {
|
||||
m_socket_init_handler(m_hdl, get_socket());
|
||||
only in patch2:
|
||||
unchanged:
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -202,7 +202,7 @@ if (BUILD_TESTS OR BUILD_EXAMPLES)
|
||||
endif ()
|
||||
|
||||
if (NOT Boost_USE_STATIC_LIBS)
|
||||
- add_definitions (/DBOOST_TEST_DYN_LINK)
|
||||
+ add_definitions (-DBOOST_TEST_DYN_LINK)
|
||||
endif ()
|
||||
|
||||
set (Boost_FIND_REQUIRED TRUE)
|
17
gnu/packages/patches/websocketpp-fix-for-cmake-3.15.patch
Normal file
17
gnu/packages/patches/websocketpp-fix-for-cmake-3.15.patch
Normal file
|
@ -0,0 +1,17 @@
|
|||
From: Tobias Geerinckx-Rice <me@tobias.gr>
|
||||
Date: Fri, 05 Jun 2020 18:37:51 +0200
|
||||
Subject: [PATCH] gnu: websocketpp: Fix build with CMake >= 3.15.
|
||||
|
||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index 57ed01e78..43c772d78 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -215,7 +215,7 @@
|
||||
set (Boost_USE_MULTITHREADED TRUE)
|
||||
set (Boost_ADDITIONAL_VERSIONS "1.39.0" "1.40.0" "1.41.0" "1.42.0" "1.43.0" "1.44.0" "1.46.1") # todo: someone who knows better spesify these!
|
||||
|
||||
- find_package (Boost 1.39.0 COMPONENTS "${WEBSOCKETPP_BOOST_LIBS}")
|
||||
+ find_package (Boost 1.39.0 COMPONENTS ${WEBSOCKETPP_BOOST_LIBS})
|
||||
|
||||
if (Boost_FOUND)
|
||||
# Boost is a project wide global dependency.
|
|
@ -1178,7 +1178,7 @@ (define-public wabt
|
|||
(define-public websocketpp
|
||||
(package
|
||||
(name "websocketpp")
|
||||
(version "0.8.1")
|
||||
(version "0.8.2")
|
||||
(source
|
||||
(origin
|
||||
(method git-fetch)
|
||||
|
@ -1187,8 +1187,8 @@ (define-public websocketpp
|
|||
(commit version)))
|
||||
(file-name (git-file-name name version))
|
||||
(sha256
|
||||
(base32 "12ffczcrryh74c1xssww35ic6yiy2l2xgdd30lshiq9wnzl2brgy"))
|
||||
(patches (search-patches "websocketpp-fix-for-boost-1.70.patch"))))
|
||||
(base32 "1ww4fhl8qf12hkv6jaild8zzsygdspxm1gqpk2f63gv1xfi31wpm"))
|
||||
(patches (search-patches "websocketpp-fix-for-cmake-3.15.patch"))))
|
||||
(build-system cmake-build-system)
|
||||
(inputs `(("boost" ,boost)
|
||||
("openssl" ,openssl)))
|
||||
|
|
Loading…
Reference in a new issue