mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-12-25 05:48:07 -05:00
gnu: fluxbox: Fix build.
* gnu/packages/patches/fluxbox-1.3.7-gcc.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/wm.scm (fluxbox)[source](patches): Add it.
This commit is contained in:
parent
85dbe6d13f
commit
18b6e309ce
3 changed files with 19 additions and 1 deletions
|
@ -1153,6 +1153,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/flatpak-fix-path.patch \
|
||||
%D%/packages/patches/flatpak-unset-gdk-pixbuf-for-sandbox.patch \
|
||||
%D%/packages/patches/fluxbox-1.3.7-no-dynamic-cursor.patch \
|
||||
%D%/packages/patches/fluxbox-1.3.7-gcc.patch \
|
||||
%D%/packages/patches/fontconfig-cache-ignore-mtime.patch \
|
||||
%D%/packages/patches/fontforge-hurd.patch \
|
||||
%D%/packages/patches/foobillard++-pkg-config.patch \
|
||||
|
|
16
gnu/packages/patches/fluxbox-1.3.7-gcc.patch
Normal file
16
gnu/packages/patches/fluxbox-1.3.7-gcc.patch
Normal file
|
@ -0,0 +1,16 @@
|
|||
Author: Danny Milosavljevic <dannym@scratchpost.org>
|
||||
Date: 2023-06-12
|
||||
License: expat
|
||||
|
||||
diff -ur orig/fluxbox-1.3.7/util/fluxbox-remote.cc fluxbox-1.3.7/util/fluxbox-remote.cc
|
||||
--- orig/fluxbox-1.3.7/util/fluxbox-remote.cc 1970-01-01 01:00:01.000000000 +0100
|
||||
+++ fluxbox-1.3.7/util/fluxbox-remote.cc 2023-05-01 01:11:52.225547895 +0200
|
||||
@@ -73,7 +73,7 @@
|
||||
if (strcmp(cmd, "result") == 0) {
|
||||
XTextProperty text_prop;
|
||||
if (XGetTextProperty(disp, root, &text_prop, atom_result) != 0
|
||||
- && text_prop.value > 0
|
||||
+ && text_prop.value != NULL
|
||||
&& text_prop.nitems > 0) {
|
||||
|
||||
printf("%s", text_prop.value);
|
|
@ -1073,7 +1073,8 @@ (define-public fluxbox
|
|||
(base32
|
||||
"1h1f70y40qd225dqx937vzb4k2cz219agm1zvnjxakn5jkz7b37w"))
|
||||
(patches
|
||||
(search-patches "fluxbox-1.3.7-no-dynamic-cursor.patch"))))
|
||||
(search-patches "fluxbox-1.3.7-no-dynamic-cursor.patch"
|
||||
"fluxbox-1.3.7-gcc.patch"))))
|
||||
(build-system gnu-build-system)
|
||||
(arguments
|
||||
`(#:make-flags '("CPPFLAGS=-U__TIME__") ;ugly, but for reproducibility
|
||||
|
|
Loading…
Reference in a new issue