mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 07:26:13 -05:00
gnu: vim: Fix CVE-2017-5953.
* gnu/packages/patches/vim-CVE-2017-5953.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/vim.scm (vim)[source]: Use it.
This commit is contained in:
parent
30f420c155
commit
1ae04e3511
3 changed files with 26 additions and 0 deletions
|
@ -954,6 +954,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/util-linux-tests.patch \
|
||||
%D%/packages/patches/upower-builddir.patch \
|
||||
%D%/packages/patches/valgrind-enable-arm.patch \
|
||||
%D%/packages/patches/vim-CVE-2017-5953.patch \
|
||||
%D%/packages/patches/vorbis-tools-CVE-2014-9638+CVE-2014-9639.patch \
|
||||
%D%/packages/patches/vorbis-tools-CVE-2014-9640.patch \
|
||||
%D%/packages/patches/vorbis-tools-CVE-2015-6749.patch \
|
||||
|
|
24
gnu/packages/patches/vim-CVE-2017-5953.patch
Normal file
24
gnu/packages/patches/vim-CVE-2017-5953.patch
Normal file
|
@ -0,0 +1,24 @@
|
|||
Fix CVE-2017-5953:
|
||||
|
||||
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-5953
|
||||
https://groups.google.com/forum/#!topic/vim_dev/t-3RSdEnrHY
|
||||
|
||||
Patch adapted from upstream commit, correcting the transcription error
|
||||
in the bounds check:
|
||||
|
||||
https://github.com/vim/vim/commit/399c297aa93afe2c0a39e2a1b3f972aebba44c9d
|
||||
|
||||
diff --git a/src/spellfile.c b/src/spellfile.c
|
||||
index c7d87c6..8b1a3a6 100644
|
||||
--- a/src/spellfile.c
|
||||
+++ b/src/spellfile.c
|
||||
@@ -1595,6 +1595,9 @@ spell_read_tree(
|
||||
len = get4c(fd);
|
||||
if (len < 0)
|
||||
return SP_TRUNCERROR;
|
||||
+ if (len >= 0x3fffffff)
|
||||
+ /* Invalid length, multiply with sizeof(int) would overflow. */
|
||||
+ return SP_FORMERROR;
|
||||
if (len > 0)
|
||||
{
|
||||
/* Allocate the byte array. */
|
|
@ -63,6 +63,7 @@ (define-public vim
|
|||
(uri (string-append "https://github.com/vim/vim/archive/v"
|
||||
version ".tar.gz"))
|
||||
(file-name (string-append name "-" version ".tar.gz"))
|
||||
(patches (search-patches "vim-CVE-2017-5953.patch"))
|
||||
(sha256
|
||||
(base32
|
||||
"04samk2bakyixbxyc3p0g6ypls45105sikibg0wc6lmak9bqjs85"))))
|
||||
|
|
Loading…
Reference in a new issue