mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-12-26 06:18:07 -05:00
gnu: spdlog: Fix tests.
* gnu/packages/patches/spdlog-fix-tests.patch: New file. * gnu/local.mk: Add it. * gnu/packages/logging.scm (spdlog)[source]: Use patch. Signed-off-by: Christopher Baines <mail@cbaines.net>
This commit is contained in:
parent
68b3d71806
commit
1ae56be99e
3 changed files with 28 additions and 0 deletions
|
@ -1964,6 +1964,7 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/source-highlight-gcc-compat.patch \
|
%D%/packages/patches/source-highlight-gcc-compat.patch \
|
||||||
%D%/packages/patches/softhsm-fix-openssl3-tests.patch \
|
%D%/packages/patches/softhsm-fix-openssl3-tests.patch \
|
||||||
%D%/packages/patches/spectre-meltdown-checker-externalize-fwdb.patch \
|
%D%/packages/patches/spectre-meltdown-checker-externalize-fwdb.patch \
|
||||||
|
%D%/packages/patches/spdlog-fix-tests.patch \
|
||||||
%D%/packages/patches/spectre-meltdown-checker-find-kernel.patch \
|
%D%/packages/patches/spectre-meltdown-checker-find-kernel.patch \
|
||||||
%D%/packages/patches/sphinxbase-fix-doxygen.patch \
|
%D%/packages/patches/sphinxbase-fix-doxygen.patch \
|
||||||
%D%/packages/patches/sssd-system-directories.patch \
|
%D%/packages/patches/sssd-system-directories.patch \
|
||||||
|
|
|
@ -220,6 +220,7 @@ (define-public spdlog
|
||||||
(url "https://github.com/gabime/spdlog")
|
(url "https://github.com/gabime/spdlog")
|
||||||
(commit (string-append "v" version))))
|
(commit (string-append "v" version))))
|
||||||
(file-name (git-file-name name version))
|
(file-name (git-file-name name version))
|
||||||
|
(patches (search-patches "spdlog-fix-tests.patch"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32 "0i3a1cqrg1sz0w50g7zz9x73rf838igqri12q8ijh4rzpq0qq3ch"))))
|
(base32 "0i3a1cqrg1sz0w50g7zz9x73rf838igqri12q8ijh4rzpq0qq3ch"))))
|
||||||
(build-system cmake-build-system)
|
(build-system cmake-build-system)
|
||||||
|
|
26
gnu/packages/patches/spdlog-fix-tests.patch
Normal file
26
gnu/packages/patches/spdlog-fix-tests.patch
Normal file
|
@ -0,0 +1,26 @@
|
||||||
|
Remove after next release and package update:
|
||||||
|
https://github.com/gabime/spdlog/commit/2ee8bac78e6525a8ad9a9196e65d502ce390d83a
|
||||||
|
|
||||||
|
From 2ee8bac78e6525a8ad9a9196e65d502ce390d83a Mon Sep 17 00:00:00 2001
|
||||||
|
From: xvitaly <vitaly@easycoding.org>
|
||||||
|
Date: Sun, 23 Jul 2023 10:15:25 +0200
|
||||||
|
Subject: [PATCH] Added missing square bracket to fix the level_to_string_view
|
||||||
|
test. (#2827)
|
||||||
|
|
||||||
|
---
|
||||||
|
tests/test_misc.cpp | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/tests/test_misc.cpp b/tests/test_misc.cpp
|
||||||
|
index 9f3cb1744..6199641ff 100644
|
||||||
|
--- a/tests/test_misc.cpp
|
||||||
|
+++ b/tests/test_misc.cpp
|
||||||
|
@@ -43,7 +43,7 @@ TEST_CASE("log_levels", "[log_levels]")
|
||||||
|
REQUIRE(log_info("Hello", spdlog::level::trace) == "Hello");
|
||||||
|
}
|
||||||
|
|
||||||
|
-TEST_CASE("level_to_string_view", "[convert_to_string_view")
|
||||||
|
+TEST_CASE("level_to_string_view", "[convert_to_string_view]")
|
||||||
|
{
|
||||||
|
REQUIRE(spdlog::level::to_string_view(spdlog::level::trace) == "trace");
|
||||||
|
REQUIRE(spdlog::level::to_string_view(spdlog::level::debug) == "debug");
|
Loading…
Reference in a new issue