gnu: valgrind: Adapt to glibc-2.22 and linux-libre-4.x.

* gnu/packages/patches/valgrind-glibc-2.21.patch: Rename to ...
  gnu/packages/patches/valgrind-glibc-2.22.patch: ... this, and add a case for
  glibc-2.22.
* gnu/packages/patches/valgrind-linux-libre-4.x.patch: New file.
* gnu-system.am (dist_patch_DATA): Add the new file, and rename the other one.
* gnu/packages/valgrind.scm (valgrind)[source]: Add new patch.
This commit is contained in:
Mark H Weaver 2015-09-15 18:18:46 -04:00
parent b76b1dcb96
commit 1d6c8db57c
4 changed files with 37 additions and 3 deletions

View file

@ -651,7 +651,8 @@ dist_patch_DATA = \
gnu/packages/patches/unzip-remove-build-date.patch \
gnu/packages/patches/util-linux-tests.patch \
gnu/packages/patches/upower-builddir.patch \
gnu/packages/patches/valgrind-glibc-2.21.patch \
gnu/packages/patches/valgrind-glibc-2.22.patch \
gnu/packages/patches/valgrind-linux-libre-4.x.patch \
gnu/packages/patches/vpnc-script.patch \
gnu/packages/patches/vtk-mesa-10.patch \
gnu/packages/patches/w3m-fix-compile.patch \

View file

@ -4,10 +4,13 @@ Initial Package Version: 3.10.1
Upstream Status: Unknown
Origin: Self
Description: Allows Valgrind to build with glibc-2.21
Later modified to support glibc-2.22 as well.
diff -Naur valgrind-3.10.1.old/configure valgrind-3.10.1.new/configure
--- valgrind-3.10.1.old/configure 2014-11-25 20:42:25.000000000 +0100
+++ valgrind-3.10.1.new/configure 2015-02-22 10:46:06.607826488 +0100
@@ -6842,6 +6842,16 @@
@@ -6842,6 +6842,26 @@
DEFAULT_SUPP="glibc-2.34567-NPTL-helgrind.supp ${DEFAULT_SUPP}"
DEFAULT_SUPP="glibc-2.X-drd.supp ${DEFAULT_SUPP}"
;;
@ -20,6 +23,16 @@ diff -Naur valgrind-3.10.1.old/configure valgrind-3.10.1.new/configure
+ DEFAULT_SUPP="glibc-2.X.supp ${DEFAULT_SUPP}"
+ DEFAULT_SUPP="glibc-2.34567-NPTL-helgrind.supp ${DEFAULT_SUPP}"
+ DEFAULT_SUPP="glibc-2.X-drd.supp ${DEFAULT_SUPP}"
+ ;;
+ 2.22)
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: 2.22 family" >&5
+$as_echo "2.22 family" >&6; }
+
+$as_echo "#define GLIBC_2_22 1" >>confdefs.h
+
+ DEFAULT_SUPP="glibc-2.X.supp ${DEFAULT_SUPP}"
+ DEFAULT_SUPP="glibc-2.34567-NPTL-helgrind.supp ${DEFAULT_SUPP}"
+ DEFAULT_SUPP="glibc-2.X-drd.supp ${DEFAULT_SUPP}"
+ ;;
darwin)
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: Darwin" >&5

View file

@ -0,0 +1,18 @@
Modify valgrind's configure script to accept linux-libre-4.x as being in the
same family as 3.x.
--- valgrind-3.10.1/configure 2015-09-15 18:02:20.710262686 -0400
+++ valgrind-3.10.1/configure 2015-09-15 18:02:59.831829731 -0400
@@ -5553,9 +5553,9 @@
kernel=`uname -r`
case "${kernel}" in
- 2.6.*|3.*)
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: 2.6.x/3.x family (${kernel})" >&5
-$as_echo "2.6.x/3.x family (${kernel})" >&6; }
+ 2.6.*|3.*|4.*)
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: 2.6.x/3.x/4.x family (${kernel})" >&5
+$as_echo "2.6.x/3.x/4.x family (${kernel})" >&6; }
$as_echo "#define KERNEL_2_6 1" >>confdefs.h

View file

@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013, 2014 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
;;;
;;; This file is part of GNU Guix.
;;;
@ -37,7 +38,8 @@ (define-public valgrind
(sha256
(base32
"15xrzhfnwwn7n1sfbkwvdbvs6zk0zx718n6zd5i1nrnvdp13s9gs"))
(patches (list (search-patch "valgrind-glibc-2.21.patch")))))
(patches (map search-patch '("valgrind-glibc-2.22.patch"
"valgrind-linux-libre-4.x.patch")))))
(build-system gnu-build-system)
(arguments
'(#:phases (alist-cons-after