mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 07:26:13 -05:00
gnu: vtk-7: Fix build.
* gnu/packages/patches/vtk-7-gcc-11-compat.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/image-processing.scm (vtk-7)[source]: Add patch for gcc-11.
This commit is contained in:
parent
6609f2f4a7
commit
1dc8cdaa72
3 changed files with 14 additions and 1 deletions
|
@ -2085,6 +2085,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/vte-CVE-2012-2738-pt1.patch \
|
||||
%D%/packages/patches/vte-CVE-2012-2738-pt2.patch \
|
||||
%D%/packages/patches/vtk-7-gcc-10-compat.patch \
|
||||
%D%/packages/patches/vtk-7-gcc-11-compat.patch \
|
||||
%D%/packages/patches/vtk-7-hdf5-compat.patch \
|
||||
%D%/packages/patches/vtk-7-python-compat.patch \
|
||||
%D%/packages/patches/wacomtablet-add-missing-includes.patch \
|
||||
|
|
|
@ -473,7 +473,8 @@ (define-public vtk-7
|
|||
"0nm7xwwj7rnsxjdv2ssviys8nhci4n9iiiqm2y14s520hl2dsp1d"))
|
||||
(patches (search-patches "vtk-7-python-compat.patch"
|
||||
"vtk-7-hdf5-compat.patch"
|
||||
"vtk-7-gcc-10-compat.patch"))))
|
||||
"vtk-7-gcc-10-compat.patch"
|
||||
"vtk-7-gcc-11-compat.patch"))))
|
||||
(arguments
|
||||
(substitute-keyword-arguments (package-arguments vtk)
|
||||
((#:configure-flags flags)
|
||||
|
|
11
gnu/packages/patches/vtk-7-gcc-11-compat.patch
Normal file
11
gnu/packages/patches/vtk-7-gcc-11-compat.patch
Normal file
|
@ -0,0 +1,11 @@
|
|||
Description: GCC 11 now enforces that comparison objects be invocable as const.
|
||||
--- a/Rendering/Label/vtkLabelHierarchy.cxx
|
||||
+++ b/Rendering/Label/vtkLabelHierarchy.cxx
|
||||
@@ -525,1 +525,1 @@
|
||||
- const vtkHierarchyNode & b)
|
||||
+ const vtkHierarchyNode & b) const
|
||||
--- a/Rendering/Label/vtkLabelHierarchyPrivate.h
|
||||
+++ b/Rendering/Label/vtkLabelHierarchyPrivate.h
|
||||
@@ -66,1 +66,1 @@
|
||||
- bool operator () ( const vtkIdType& a, const vtkIdType& b )
|
||||
+ bool operator () ( const vtkIdType& a, const vtkIdType& b ) const
|
Loading…
Reference in a new issue