mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2025-01-26 20:49:29 -05:00
gnu: ntfs-3g: Update to 2021.8.22 [security fixes].
The upstream security advisory is named NTFS3G-SA-2021-0001. Fixes CVE-2021-33285, CVE-2021-35269, CVE-2021-35268, CVE-2021-33289, CVE-2021-33286, CVE-2021-35266, CVE-2021-33287, CVE-2021-35267, CVE-2021-39251, CVE-2021-39252, CVE-2021-39253, CVE-2021-39254, CVE-2021-39255, CVE-2021-39256, CVE-2021-39257, CVE-2021-39258, CVE-2021-39259, CVE-2021-39260, CVE-2021-39261, CVE-2021-39262, CVE-2021-39263. For more information: https://seclists.org/oss-sec/2021/q3/139 * gnu/packages/linux.scm (ntfs-3g): Update to 2021.8.22. [source]: Remove obsolete patch. * gnu/packages/patches/ntfs-3g-CVE-2019-9755.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
This commit is contained in:
parent
1572737db3
commit
1e3262d74f
3 changed files with 4 additions and 78 deletions
|
@ -1508,7 +1508,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/nsis-source-date-epoch.patch \
|
||||
%D%/packages/patches/nss-increase-test-timeout.patch \
|
||||
%D%/packages/patches/nss-3.56-pkgconfig.patch \
|
||||
%D%/packages/patches/ntfs-3g-CVE-2019-9755.patch \
|
||||
%D%/packages/patches/nvi-assume-preserve-path.patch \
|
||||
%D%/packages/patches/nvi-dbpagesize-binpower.patch \
|
||||
%D%/packages/patches/nvi-db4.patch \
|
||||
|
|
|
@ -5971,15 +5971,14 @@ (define-public turbostat
|
|||
(define-public ntfs-3g
|
||||
(package
|
||||
(name "ntfs-3g")
|
||||
(version "2017.3.23")
|
||||
(version "2021.8.22")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "https://tuxera.com/opensource/"
|
||||
"ntfs-3g_ntfsprogs-" version ".tgz"))
|
||||
(patches (search-patches "ntfs-3g-CVE-2019-9755.patch"))
|
||||
(sha256
|
||||
(base32
|
||||
"1mb228p80hv97pgk3myyvgp975r9mxq56c6bdn1n24kngcfh4niy"))
|
||||
"1yrf42xr92qv3pads8lzp5nyssz6875ncfgg8v3jwjyr0nm87f2m"))
|
||||
(modules '((guix build utils)))
|
||||
(snippet '(begin
|
||||
;; Install under $prefix.
|
||||
|
@ -5988,8 +5987,8 @@ (define-public ntfs-3g
|
|||
"@sbindir@"))
|
||||
#t))))
|
||||
(build-system gnu-build-system)
|
||||
(inputs `(("util-linux" ,util-linux)
|
||||
("fuse" ,fuse))) ;libuuid
|
||||
(inputs `(("util-linux" ,util-linux) ; libuuid
|
||||
("fuse" ,fuse)))
|
||||
(native-inputs `(("pkg-config" ,pkg-config)))
|
||||
(arguments
|
||||
'(#:configure-flags (list "--disable-static"
|
||||
|
|
|
@ -1,72 +0,0 @@
|
|||
Fix CVE-2019-9755:
|
||||
|
||||
https://security-tracker.debian.org/tracker/CVE-2019-9755
|
||||
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-9755
|
||||
|
||||
Patch copied from upstream source repository:
|
||||
|
||||
https://sourceforge.net/p/ntfs-3g/ntfs-3g/ci/85c1634a26faa572d3c558d4cf8aaaca5202d4e9/
|
||||
|
||||
From 85c1634a26faa572d3c558d4cf8aaaca5202d4e9 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Jean-Pierre=20Andr=C3=A9?= <jean-pierre.andre@wanadoo.fr>
|
||||
Date: Wed, 19 Dec 2018 15:57:50 +0100
|
||||
Subject: [PATCH] Fixed reporting an error when failed to build the mountpoint
|
||||
|
||||
The size check was inefficient because getcwd() uses an unsigned int
|
||||
argument.
|
||||
---
|
||||
src/lowntfs-3g.c | 6 +++++-
|
||||
src/ntfs-3g.c | 6 +++++-
|
||||
2 files changed, 10 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/src/lowntfs-3g.c b/src/lowntfs-3g.c
|
||||
index 993867fa..0660439b 100644
|
||||
--- a/src/lowntfs-3g.c
|
||||
+++ b/src/lowntfs-3g.c
|
||||
@@ -4411,7 +4411,8 @@ int main(int argc, char *argv[])
|
||||
else {
|
||||
ctx->abs_mnt_point = (char*)ntfs_malloc(PATH_MAX);
|
||||
if (ctx->abs_mnt_point) {
|
||||
- if (getcwd(ctx->abs_mnt_point,
|
||||
+ if ((strlen(opts.mnt_point) < PATH_MAX)
|
||||
+ && getcwd(ctx->abs_mnt_point,
|
||||
PATH_MAX - strlen(opts.mnt_point) - 1)) {
|
||||
strcat(ctx->abs_mnt_point, "/");
|
||||
strcat(ctx->abs_mnt_point, opts.mnt_point);
|
||||
@@ -4419,6 +4420,9 @@ int main(int argc, char *argv[])
|
||||
/* Solaris also wants the absolute mount point */
|
||||
opts.mnt_point = ctx->abs_mnt_point;
|
||||
#endif /* defined(__sun) && defined (__SVR4) */
|
||||
+ } else {
|
||||
+ free(ctx->abs_mnt_point);
|
||||
+ ctx->abs_mnt_point = (char*)NULL;
|
||||
}
|
||||
}
|
||||
}
|
||||
diff --git a/src/ntfs-3g.c b/src/ntfs-3g.c
|
||||
index 6ce89fef..4e0912ae 100644
|
||||
--- a/src/ntfs-3g.c
|
||||
+++ b/src/ntfs-3g.c
|
||||
@@ -4148,7 +4148,8 @@ int main(int argc, char *argv[])
|
||||
else {
|
||||
ctx->abs_mnt_point = (char*)ntfs_malloc(PATH_MAX);
|
||||
if (ctx->abs_mnt_point) {
|
||||
- if (getcwd(ctx->abs_mnt_point,
|
||||
+ if ((strlen(opts.mnt_point) < PATH_MAX)
|
||||
+ && getcwd(ctx->abs_mnt_point,
|
||||
PATH_MAX - strlen(opts.mnt_point) - 1)) {
|
||||
strcat(ctx->abs_mnt_point, "/");
|
||||
strcat(ctx->abs_mnt_point, opts.mnt_point);
|
||||
@@ -4156,6 +4157,9 @@ int main(int argc, char *argv[])
|
||||
/* Solaris also wants the absolute mount point */
|
||||
opts.mnt_point = ctx->abs_mnt_point;
|
||||
#endif /* defined(__sun) && defined (__SVR4) */
|
||||
+ } else {
|
||||
+ free(ctx->abs_mnt_point);
|
||||
+ ctx->abs_mnt_point = (char*)NULL;
|
||||
}
|
||||
}
|
||||
}
|
||||
--
|
||||
2.21.0
|
||||
|
Loading…
Reference in a new issue