mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2025-01-11 13:49:23 -05:00
gnu: Add Qt 4.8.5.
* gnu/packages/qt.scm (qt-4): New variable. * gnu/packages/patches/qt4-tests.patch: New file, patch dropping tests requiring a running X server.
This commit is contained in:
parent
5151c2e1f4
commit
1e9ed0e3dc
2 changed files with 65 additions and 0 deletions
22
gnu/packages/patches/qt4-tests.patch
Normal file
22
gnu/packages/patches/qt4-tests.patch
Normal file
|
@ -0,0 +1,22 @@
|
||||||
|
Drop tests requiring a running X server, but not starting any.
|
||||||
|
|
||||||
|
diff -ru qt-everywhere-opensource-src-4.8.5.orig/src/3rdparty/webkit/Source/WebKit/qt/tests/tests.pro qt-everywhere-opensource-src-4.8.5/src/3rdparty/webkit/Source/WebKit/qt/tests/tests.pro
|
||||||
|
--- qt-everywhere-opensource-src-4.8.5.orig/src/3rdparty/webkit/Source/WebKit/qt/tests/tests.pro 2013-10-12 13:15:47.000000000 +0200
|
||||||
|
+++ qt-everywhere-opensource-src-4.8.5/src/3rdparty/webkit/Source/WebKit/qt/tests/tests.pro 2013-10-12 13:20:15.000000000 +0200
|
||||||
|
@@ -1,15 +1,4 @@
|
||||||
|
|
||||||
|
TEMPLATE = subdirs
|
||||||
|
-SUBDIRS = qwebframe qwebpage qwebelement qgraphicswebview qwebhistoryinterface qwebview qwebhistory qwebinspector hybridPixmap
|
||||||
|
+SUBDIRS =
|
||||||
|
|
||||||
|
-linux-* {
|
||||||
|
- # This test bypasses the library and links the tested code's object itself.
|
||||||
|
- # This stresses the build system in some corners so we only run it on linux.
|
||||||
|
- SUBDIRS += MIMESniffing
|
||||||
|
-}
|
||||||
|
-
|
||||||
|
-contains(QT_CONFIG, declarative): SUBDIRS += qdeclarativewebview
|
||||||
|
-SUBDIRS += benchmarks/painting benchmarks/loading
|
||||||
|
-contains(DEFINES, ENABLE_WEBGL=1) {
|
||||||
|
- SUBDIRS += benchmarks/webgl
|
||||||
|
-}
|
|
@ -21,6 +21,7 @@ (define-module (gnu packages qt)
|
||||||
#:use-module (guix packages)
|
#:use-module (guix packages)
|
||||||
#:use-module (guix download)
|
#:use-module (guix download)
|
||||||
#:use-module (guix build-system gnu)
|
#:use-module (guix build-system gnu)
|
||||||
|
#:use-module (gnu packages)
|
||||||
#:use-module (gnu packages bison)
|
#:use-module (gnu packages bison)
|
||||||
#:use-module (gnu packages compression)
|
#:use-module (gnu packages compression)
|
||||||
#:use-module (gnu packages fontutils)
|
#:use-module (gnu packages fontutils)
|
||||||
|
@ -139,3 +140,45 @@ (define-public qt
|
||||||
(description "Qt is a cross-platform application and UI framework for
|
(description "Qt is a cross-platform application and UI framework for
|
||||||
developers using C++ or QML, a CSS & JavaScript like language.")
|
developers using C++ or QML, a CSS & JavaScript like language.")
|
||||||
(license lgpl2.1)))
|
(license lgpl2.1)))
|
||||||
|
|
||||||
|
(define-public qt-4
|
||||||
|
(package (inherit qt)
|
||||||
|
(version "4.8.5")
|
||||||
|
(source (origin
|
||||||
|
(method url-fetch)
|
||||||
|
(uri (string-append "http://download.qt-project.org/official_releases/qt/"
|
||||||
|
(string-copy version 0 (string-rindex version #\.))
|
||||||
|
"/" version
|
||||||
|
"/single/qt-everywhere-opensource-src-"
|
||||||
|
version ".tar.gz"))
|
||||||
|
(sha256
|
||||||
|
(base32
|
||||||
|
"0f51dbgn1dcck8pqimls2qyf1pfmsmyknh767cvw87c3d218ywpb"))
|
||||||
|
(patches (list (search-patch "qt4-tests.patch")))))
|
||||||
|
(arguments
|
||||||
|
`(#:phases
|
||||||
|
(alist-replace
|
||||||
|
'configure
|
||||||
|
(lambda* (#:key outputs #:allow-other-keys)
|
||||||
|
(let ((out (assoc-ref outputs "out")))
|
||||||
|
(substitute* '("configure")
|
||||||
|
(("/bin/pwd") (which "pwd")))
|
||||||
|
;; do not pass "--enable-fast-install", which makes the
|
||||||
|
;; configure process fail
|
||||||
|
(zero? (system* "./configure"
|
||||||
|
"-verbose"
|
||||||
|
"-prefix" out
|
||||||
|
"-opensource"
|
||||||
|
"-confirm-license"
|
||||||
|
;; drop all special machine instructions
|
||||||
|
"-no-mmx"
|
||||||
|
"-no-3dnow"
|
||||||
|
"-no-sse"
|
||||||
|
"-no-sse2"
|
||||||
|
"-no-sse3"
|
||||||
|
"-no-ssse3"
|
||||||
|
"-no-sse4.1"
|
||||||
|
"-no-sse4.2"
|
||||||
|
"-no-avx"
|
||||||
|
"-no-neon"))))
|
||||||
|
%standard-phases)))))
|
||||||
|
|
Loading…
Reference in a new issue