mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-12-24 21:38:07 -05:00
gnu: python-afdko: Fix failing tests.
* gnu/packages/patches/python-afdko-suppress-copyright-test.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/fontutils.scm (python-afdko)[source](patches): New field.
This commit is contained in:
parent
2463e9f1fe
commit
1efe7de096
3 changed files with 22 additions and 0 deletions
|
@ -1715,6 +1715,7 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/python-3-fix-tests.patch \
|
%D%/packages/patches/python-3-fix-tests.patch \
|
||||||
%D%/packages/patches/python-3-hurd-configure.patch \
|
%D%/packages/patches/python-3-hurd-configure.patch \
|
||||||
%D%/packages/patches/python-3-no-static-lib.patch \
|
%D%/packages/patches/python-3-no-static-lib.patch \
|
||||||
|
%D%/packages/patches/python-afdko-suppress-copyright-test.patch \
|
||||||
%D%/packages/patches/python-aionotify-0.2.0-py3.8.patch \
|
%D%/packages/patches/python-aionotify-0.2.0-py3.8.patch \
|
||||||
%D%/packages/patches/python-argcomplete-1.11.1-fish31.patch \
|
%D%/packages/patches/python-argcomplete-1.11.1-fish31.patch \
|
||||||
%D%/packages/patches/python-cross-compile.patch \
|
%D%/packages/patches/python-cross-compile.patch \
|
||||||
|
|
|
@ -146,6 +146,7 @@ (define-public python-afdko
|
||||||
(uri (pypi-uri "afdko" version))
|
(uri (pypi-uri "afdko" version))
|
||||||
(sha256
|
(sha256
|
||||||
(base32 "0k1204vykgx32saa495s1lgmz1dixcp8bjiv486imx77killvm02"))
|
(base32 "0k1204vykgx32saa495s1lgmz1dixcp8bjiv486imx77killvm02"))
|
||||||
|
(patches (search-patches "python-afdko-suppress-copyright-test.patch"))
|
||||||
(modules '((guix build utils)))
|
(modules '((guix build utils)))
|
||||||
(snippet
|
(snippet
|
||||||
#~(begin
|
#~(begin
|
||||||
|
|
|
@ -0,0 +1,20 @@
|
||||||
|
Supress copyright check in tests which can differ based on current year.
|
||||||
|
|
||||||
|
https://github.com/adobe-type-tools/afdko/issues/1589
|
||||||
|
|
||||||
|
Adapted from upstream:
|
||||||
|
|
||||||
|
https://github.com/adobe-type-tools/afdko/commit/feebd77d9b6507a0b32f837535511be3c94d9c6f
|
||||||
|
|
||||||
|
diff --git a/tests/tx_test.py b/tests/tx_test.py
|
||||||
|
--- a/tests/tx_test.py
|
||||||
|
+++ b/tests/tx_test.py
|
||||||
|
@@ -1246,7 +1246,7 @@ def test_ufo_fontinfo_parsing(file, msg, ret_code):
|
||||||
|
if (ret_code == 0):
|
||||||
|
expected_path = generate_ps_dump(expected_path)
|
||||||
|
output_path = generate_ps_dump(output_path)
|
||||||
|
- assert differ([expected_path, output_path])
|
||||||
|
+ assert differ([expected_path, output_path, '-s'] + PFA_SKIP)
|
||||||
|
else:
|
||||||
|
arg = [TOOL, '-t1', '-f', ufo_input_path]
|
||||||
|
assert subprocess.call(arg) == 6
|
Loading…
Reference in a new issue