mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-12-25 05:48:07 -05:00
gnu: spice: Fix test failure on armhf-linux.
* gnu/packages/patches/spice-fix-test-armhf.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/spice.scm (spice)[source](patches): New field.
This commit is contained in:
parent
f9ea47a978
commit
20eb3b7e74
3 changed files with 21 additions and 0 deletions
|
@ -1382,6 +1382,7 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/snappy-add-O2-flag-in-CmakeLists.txt.patch \
|
%D%/packages/patches/snappy-add-O2-flag-in-CmakeLists.txt.patch \
|
||||||
%D%/packages/patches/sooperlooper-build-with-wx-30.patch \
|
%D%/packages/patches/sooperlooper-build-with-wx-30.patch \
|
||||||
%D%/packages/patches/soundconverter-remove-gconf-dependency.patch \
|
%D%/packages/patches/soundconverter-remove-gconf-dependency.patch \
|
||||||
|
%D%/packages/patches/spice-fix-test-armhf.patch \
|
||||||
%D%/packages/patches/steghide-fixes.patch \
|
%D%/packages/patches/steghide-fixes.patch \
|
||||||
%D%/packages/patches/supercollider-boost-1.70-build-fix.patch \
|
%D%/packages/patches/supercollider-boost-1.70-build-fix.patch \
|
||||||
%D%/packages/patches/superlu-dist-awpm-grid.patch \
|
%D%/packages/patches/superlu-dist-awpm-grid.patch \
|
||||||
|
|
19
gnu/packages/patches/spice-fix-test-armhf.patch
Normal file
19
gnu/packages/patches/spice-fix-test-armhf.patch
Normal file
|
@ -0,0 +1,19 @@
|
||||||
|
Fix test failure on armhf and ppc64el:
|
||||||
|
https://gitlab.freedesktop.org/spice/spice-server/issues/31
|
||||||
|
|
||||||
|
Taken from upstream:
|
||||||
|
https://gitlab.freedesktop.org/spice/spice/commit/19f9f454e0777d851f26d14df0c7984267c57015
|
||||||
|
|
||||||
|
diff --git a/server/tests/test-qxl-parsing.c b/server/tests/test-qxl-parsing.c
|
||||||
|
index 60ca8f88c62441e02577ced21e4f60a08ad4171a..234bdabc9ce619d0799b5136f1d72357b0b2f490 100644
|
||||||
|
--- a/server/tests/test-qxl-parsing.c
|
||||||
|
+++ b/server/tests/test-qxl-parsing.c
|
||||||
|
@@ -96,7 +96,7 @@ static void test_memslot_invalid_slot_id(void)
|
||||||
|
RedMemSlotInfo mem_info;
|
||||||
|
init_meminfo(&mem_info);
|
||||||
|
|
||||||
|
- memslot_get_virt(&mem_info, 1 << mem_info.memslot_id_shift, 16, 0);
|
||||||
|
+ memslot_get_virt(&mem_info, UINT64_C(1) << mem_info.memslot_id_shift, 16, 0);
|
||||||
|
}
|
||||||
|
|
||||||
|
static void test_memslot_invalid_addresses(void)
|
|
@ -197,6 +197,7 @@ (define-public spice
|
||||||
(uri (string-append
|
(uri (string-append
|
||||||
"https://www.spice-space.org/download/releases/"
|
"https://www.spice-space.org/download/releases/"
|
||||||
"spice-server/spice-" version ".tar.bz2"))
|
"spice-server/spice-" version ".tar.bz2"))
|
||||||
|
(patches (search-patches "spice-fix-test-armhf.patch"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"19r999py9v9c7md2bb8ysj809ag1hh6djl1ik8jcgx065s4b60xj"))))
|
"19r999py9v9c7md2bb8ysj809ag1hh6djl1ik8jcgx065s4b60xj"))))
|
||||||
|
|
Loading…
Reference in a new issue