mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-12-26 06:18:07 -05:00
gnu: supercollider: Update to 3.10.4.
* gnu/packages/audio.scm (supercollider): Update to 3.10.4. [source]: Remove patch. * gnu/packages/patches/supercollider-boost-1.70-build-fix.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
This commit is contained in:
parent
fa730a9780
commit
21e733ce4e
3 changed files with 4 additions and 36 deletions
|
@ -1388,7 +1388,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/soundconverter-remove-gconf-dependency.patch \
|
||||
%D%/packages/patches/spice-fix-test-armhf.patch \
|
||||
%D%/packages/patches/steghide-fixes.patch \
|
||||
%D%/packages/patches/supercollider-boost-1.70-build-fix.patch \
|
||||
%D%/packages/patches/superlu-dist-awpm-grid.patch \
|
||||
%D%/packages/patches/superlu-dist-fix-mpi-deprecations.patch \
|
||||
%D%/packages/patches/superlu-dist-scotchmetis.patch \
|
||||
|
|
|
@ -2249,24 +2249,22 @@ (define-public qjackrcd
|
|||
(define-public supercollider
|
||||
(package
|
||||
(name "supercollider")
|
||||
(version "3.10.3")
|
||||
(version "3.10.4")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append
|
||||
"https://github.com/supercollider/supercollider"
|
||||
"/releases/download/Version-" version
|
||||
"/SuperCollider-" version "-Source-linux.tar.bz2"))
|
||||
(patches
|
||||
(search-patches "supercollider-boost-1.70-build-fix.patch"))
|
||||
(sha256
|
||||
(base32
|
||||
"0srm6wbazidkrd4ckjy4ypyhkdwcnx2i7k9msjyngalh0mrc9zz1"))))
|
||||
"0x11g3pfw11m6v18qfpfl5w99dbmf73g4z7wvwhrj1a4qv2dn084"))))
|
||||
(build-system cmake-build-system)
|
||||
(arguments
|
||||
`(#:configure-flags '("-DSYSTEM_BOOST=on" "-DSYSTEM_YAMLCPP=on"
|
||||
"-DSC_QT=off"
|
||||
"-DSC_EL=off") ;scel is packaged individually as
|
||||
;emacs-scel.
|
||||
;emacs-scel
|
||||
#:modules ((guix build utils)
|
||||
(guix build cmake-build-system)
|
||||
(ice-9 ftw))
|
||||
|
@ -2275,8 +2273,7 @@ (define-public supercollider
|
|||
(add-after 'unpack 'rm-bundled-libs
|
||||
(lambda _
|
||||
;; The build system doesn't allow us to unbundle the following
|
||||
;; libraries. hidapi is also heavily patched and upstream not
|
||||
;; actively maintained.
|
||||
;; libraries. hidapi is also heavily patched.
|
||||
(let ((keep-dirs '("nova-simd" "nova-tt" "hidapi" "TLSF-2.4.6"
|
||||
"oscpack_1_1_0" "." "..")))
|
||||
(with-directory-excursion "./external_libraries"
|
||||
|
|
|
@ -1,28 +0,0 @@
|
|||
Patches taken from https://gitweb.gentoo.org/repo/gentoo.git/tree/media-sound/supercollider/files/supercollider-3.10.2-boost-1.70.patch?id=a420618dc766bba0654dbe0ef67008fdc5e901c6 to fix supercollider build with boost 1.70.
|
||||
|
||||
diff --git a/server/supernova/sc/sc_osc_handler.cpp b/server/supernova/sc/sc_osc_handler.cpp
|
||||
index 5116a1be87..96e937ec25 100644
|
||||
--- a/server/supernova/sc/sc_osc_handler.cpp
|
||||
+++ b/server/supernova/sc/sc_osc_handler.cpp
|
||||
@@ -728,7 +728,8 @@ void sc_osc_handler::tcp_connection::handle_message() {
|
||||
|
||||
|
||||
void sc_osc_handler::start_tcp_accept(void) {
|
||||
- tcp_connection::pointer new_connection = tcp_connection::create(tcp_acceptor_.get_io_service());
|
||||
+ tcp_connection::pointer new_connection =
|
||||
+ tcp_connection::create((boost::asio::io_context&)tcp_acceptor_.get_executor().context());
|
||||
|
||||
tcp_acceptor_.async_accept(
|
||||
new_connection->socket(),
|
||||
diff --git a/server/supernova/utilities/utils.hpp b/server/supernova/utilities/utils.hpp
|
||||
index 35b8ab5ad..a7c191f2d 100644
|
||||
--- a/server/supernova/utilities/utils.hpp
|
||||
+++ b/server/supernova/utilities/utils.hpp
|
||||
@@ -23,6 +23,7 @@
|
||||
|
||||
#include <type_traits>
|
||||
|
||||
+#include <boost/checked_delete.hpp>
|
||||
#include <boost/intrusive_ptr.hpp>
|
||||
#include <boost/noncopyable.hpp>
|
||||
#include <boost/detail/atomic_count.hpp>
|
Loading…
Reference in a new issue