mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 15:36:20 -05:00
gnu: beets: Update to 1.3.19.
* gnu/packages/music.scm (beets): Update to 1.3.19. [source]: Remove patch to skip failing tests. * gnu/packages/patches/beets-image-test-failure.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it. Signed-off-by: Leo Famulari <leo@famulari.name>
This commit is contained in:
parent
d1c9d3bb42
commit
23319ed674
3 changed files with 4 additions and 54 deletions
|
@ -445,7 +445,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/avidemux-install-to-lib.patch \
|
||||
%D%/packages/patches/awesome-reproducible-png.patch \
|
||||
%D%/packages/patches/bash-completion-directories.patch \
|
||||
%D%/packages/patches/beets-image-test-failure.patch \
|
||||
%D%/packages/patches/bigloo-gc-shebangs.patch \
|
||||
%D%/packages/patches/binutils-ld-new-dtags.patch \
|
||||
%D%/packages/patches/binutils-loongson-workaround.patch \
|
||||
|
|
|
@ -7,6 +7,7 @@
|
|||
;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
|
||||
;;; Copyright © 2016 Kei Kebreau <kei@openmailbox.org>
|
||||
;;; Copyright © 2016 John J. Foerch <jjfoerch@earthlink.net>
|
||||
;;; Copyright © 2016 Alex Griffin <a@ajgrf.com>
|
||||
;;;
|
||||
;;; This file is part of GNU Guix.
|
||||
;;;
|
||||
|
@ -1518,17 +1519,13 @@ (define-public python2-pylast
|
|||
(define-public beets
|
||||
(package
|
||||
(name "beets")
|
||||
(version "1.3.18")
|
||||
(version "1.3.19")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append
|
||||
"https://pypi.python.org/packages/"
|
||||
"14/6f/c9c79c5339ab3ecced265ca18adbf5bae3d4058bae737b6164d738fb4d2c/"
|
||||
name "-" version ".tar.gz"))
|
||||
(patches (search-patches "beets-image-test-failure.patch"))
|
||||
(uri (pypi-uri "beets" version))
|
||||
(sha256
|
||||
(base32
|
||||
"09pgyywa5llbc36y0lrr21ywgsp8m2zx6p8ncf8hxik28knd5kld"))))
|
||||
"1vi1dh3fr554bnm8y9pjy09hblw18v6cl2jppzwlp72afri1w93b"))))
|
||||
(build-system python-build-system)
|
||||
(arguments
|
||||
`(#:python ,python-2 ; only Python 2 is supported
|
||||
|
|
|
@ -1,46 +0,0 @@
|
|||
Fix test failure due to missing image library backend.
|
||||
|
||||
Cherry-picked from upstream:
|
||||
https://github.com/beetbox/beets/commit/07c95a1bf16bf86c640436208dda828cc7df0181
|
||||
|
||||
From 07c95a1bf16bf86c640436208dda828cc7df0181 Mon Sep 17 00:00:00 2001
|
||||
From: Adrian Sampson <adrian@radbox.org>
|
||||
Date: Thu, 2 Jun 2016 11:39:05 -0700
|
||||
Subject: [PATCH] Require an imaging backend for fuzzy ratio tests
|
||||
|
||||
These fail outright if we don't have a way to get image sizes (e.g.,
|
||||
ImageMagick).
|
||||
---
|
||||
test/test_art.py | 4 ++++
|
||||
1 file changed, 4 insertions(+)
|
||||
|
||||
diff --git a/test/test_art.py b/test/test_art.py
|
||||
index 02d26f4..1b12b76 100644
|
||||
--- a/test/test_art.py
|
||||
+++ b/test/test_art.py
|
||||
@@ -561,21 +561,25 @@ def test_respect_enforce_ratio_no(self):
|
||||
self._assertImageIsValidArt(self.IMG_500x490, True)
|
||||
|
||||
def test_respect_enforce_ratio_px_above(self):
|
||||
+ self._require_backend()
|
||||
self.plugin.enforce_ratio = True
|
||||
self.plugin.margin_px = 5
|
||||
self._assertImageIsValidArt(self.IMG_500x490, False)
|
||||
|
||||
def test_respect_enforce_ratio_px_below(self):
|
||||
+ self._require_backend()
|
||||
self.plugin.enforce_ratio = True
|
||||
self.plugin.margin_px = 15
|
||||
self._assertImageIsValidArt(self.IMG_500x490, True)
|
||||
|
||||
def test_respect_enforce_ratio_percent_above(self):
|
||||
+ self._require_backend()
|
||||
self.plugin.enforce_ratio = True
|
||||
self.plugin.margin_percent = (500 - 490) / 500 * 0.5
|
||||
self._assertImageIsValidArt(self.IMG_500x490, False)
|
||||
|
||||
def test_respect_enforce_ratio_percent_below(self):
|
||||
+ self._require_backend()
|
||||
self.plugin.enforce_ratio = True
|
||||
self.plugin.margin_percent = (500 - 490) / 500 * 1.5
|
||||
self._assertImageIsValidArt(self.IMG_500x490, True)
|
Loading…
Reference in a new issue