mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 15:36:20 -05:00
gnu: x265: Update to 3.0.
* gnu/packages/video.scm (x265): Update to 3.0. [source]: Remove patch. * gnu/packages/patches/x265-detect512-all-arches.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Remove it.
This commit is contained in:
parent
db7c901af1
commit
23c2598233
3 changed files with 3 additions and 42 deletions
|
@ -1333,7 +1333,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/wpa-supplicant-fix-nonce-reuse.patch \
|
||||
%D%/packages/patches/wpa-supplicant-krack-followups.patch \
|
||||
%D%/packages/patches/x265-arm-flags.patch \
|
||||
%D%/packages/patches/x265-detect512-all-arches.patch \
|
||||
%D%/packages/patches/xboing-CVE-2004-0149.patch \
|
||||
%D%/packages/patches/xf86-video-ark-remove-mibstore.patch \
|
||||
%D%/packages/patches/xf86-video-geode-glibc-2.20.patch \
|
||||
|
|
|
@ -1,37 +0,0 @@
|
|||
https://sources.debian.org/data/main/x/x265/2.9-3/debian/patches/0003-detect512-is-needed-on-all-architectures.patch
|
||||
|
||||
From: Adam Sampson <unknown@bitbucket>
|
||||
Date: Sun, 14 Oct 2018 14:04:18 +0200
|
||||
Subject: detect512 is needed on all architectures
|
||||
|
||||
---
|
||||
source/common/cpu.cpp | 9 +++++----
|
||||
1 file changed, 5 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/source/common/cpu.cpp b/source/common/cpu.cpp
|
||||
index 0681ff5..fa687da 100644
|
||||
--- a/source/common/cpu.cpp
|
||||
+++ b/source/common/cpu.cpp
|
||||
@@ -110,6 +110,11 @@ const cpu_name_t cpu_names[] =
|
||||
{ "", 0 },
|
||||
};
|
||||
|
||||
+bool detect512()
|
||||
+{
|
||||
+ return(enable512);
|
||||
+}
|
||||
+
|
||||
#if X265_ARCH_X86
|
||||
|
||||
extern "C" {
|
||||
@@ -123,10 +128,6 @@ uint64_t PFX(cpu_xgetbv)(int xcr);
|
||||
#pragma warning(disable: 4309) // truncation of constant value
|
||||
#endif
|
||||
|
||||
-bool detect512()
|
||||
-{
|
||||
- return(enable512);
|
||||
-}
|
||||
uint32_t cpu_detect(bool benableavx512 )
|
||||
{
|
||||
|
|
@ -399,7 +399,7 @@ (define-public mkvtoolnix
|
|||
(define-public x265
|
||||
(package
|
||||
(name "x265")
|
||||
(version "2.9")
|
||||
(version "3.0")
|
||||
(outputs '("out" "static"))
|
||||
(source
|
||||
(origin
|
||||
|
@ -408,9 +408,8 @@ (define-public x265
|
|||
"x265_" version ".tar.gz"))
|
||||
(sha256
|
||||
(base32
|
||||
"090hp4216isis8q5gb7bwzia8rfyzni54z21jnwm97x3hiy6ibpb"))
|
||||
(patches (search-patches "x265-arm-flags.patch"
|
||||
"x265-detect512-all-arches.patch"))
|
||||
"0qh65wdpasrspkm1y0dlfa123myax568yi0sas0lmg5b1hkgrff5"))
|
||||
(patches (search-patches "x265-arm-flags.patch"))
|
||||
(modules '((guix build utils)))
|
||||
(snippet '(begin
|
||||
(delete-file-recursively "source/compat/getopt")
|
||||
|
|
Loading…
Reference in a new issue