mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 15:36:20 -05:00
gnu: gobject-introspection: Update to 1.42.0 and add new patch.
* gnu/packages/glib.scm (gobject-introspection): Update to version 1.42.0. Add patch 'gobject-introspection-absolute-shlib-path.patch' provided by Luca Bruno <lucabru@src.gnome.org> for Nix.
This commit is contained in:
parent
561fb6c31f
commit
2474b81d96
2 changed files with 42 additions and 8 deletions
|
@ -203,17 +203,18 @@ (define glib
|
|||
(define gobject-introspection
|
||||
(package
|
||||
(name "gobject-introspection")
|
||||
(version "1.38.0")
|
||||
(version "1.42.0")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "http://ftp.gnome.org/pub/GNOME/sources/"
|
||||
"gobject-introspection/"
|
||||
(substring version 0 (string-rindex version #\.))
|
||||
"/gobject-introspection-"
|
||||
version ".tar.xz"))
|
||||
"gobject-introspection/" (version-major+minor version)
|
||||
"/gobject-introspection-" version ".tar.xz"))
|
||||
(sha256
|
||||
(base32 "0wvxyvgajmms2bb6k3pf1rdpnd79xdxamykzvxzmcyn1ag9yax9m"))
|
||||
(patches (list (search-patch "gobject-introspection-cc.patch")))))
|
||||
(base32 "1xwm7wmr9r9wp6xljb3bckx3a4siybavaq39w46ly7gpskxfv8iv"))
|
||||
(patches (list
|
||||
(search-patch "gobject-introspection-cc.patch")
|
||||
(search-patch
|
||||
"gobject-introspection-absolute-shlib-path.patch")))))
|
||||
(build-system gnu-build-system)
|
||||
(inputs
|
||||
`(("bison" ,bison)
|
||||
|
@ -234,7 +235,10 @@ (define gobject-introspection
|
|||
(files '("lib/girepository-1.0")))))
|
||||
(search-paths native-search-paths)
|
||||
(arguments
|
||||
`(#:phases
|
||||
`(;; The patch 'gobject-introspection-absolute-shlib-path.patch' causes
|
||||
;; some tests to fail.
|
||||
#:tests? #f
|
||||
#:phases
|
||||
(alist-cons-before
|
||||
'configure 'patch-paths
|
||||
(lambda _
|
||||
|
|
|
@ -0,0 +1,30 @@
|
|||
# Names of libraries included in typelib files are opened by dlopen. Here we
|
||||
# add the full path.
|
||||
#
|
||||
# This patch was provided by Luca Bruno <lucabru@src.gnome.org> for
|
||||
# 'gobject-introspection' 1.40.0 in Nix.
|
||||
--- ./giscanner/utils.py.orig 2014-08-14 22:05:05.055334080 +0200
|
||||
+++ ./giscanner/utils.py 2014-08-14 22:05:24.687497334 +0200
|
||||
@@ -110,17 +110,11 @@
|
||||
if dlname is None:
|
||||
return None
|
||||
|
||||
- # Darwin uses absolute paths where possible; since the libtool files never
|
||||
- # contain absolute paths, use the libdir field
|
||||
- if platform.system() == 'Darwin':
|
||||
- dlbasename = os.path.basename(dlname)
|
||||
- libdir = _extract_libdir_field(la_file)
|
||||
- if libdir is None:
|
||||
- return dlbasename
|
||||
- return libdir + '/' + dlbasename
|
||||
- # From the comments in extract_libtool(), older libtools had
|
||||
- # a path rather than the raw dlname
|
||||
- return os.path.basename(dlname)
|
||||
+ dlbasename = os.path.basename(dlname)
|
||||
+ libdir = _extract_libdir_field(la_file)
|
||||
+ if libdir is None:
|
||||
+ return dlbasename
|
||||
+ return libdir + '/' + dlbasename
|
||||
|
||||
|
||||
def extract_libtool(la_file):
|
Loading…
Reference in a new issue