mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-12-26 14:28:15 -05:00
gnu: vtk: Fix build failure.
* gnu/packages/image-processing.scm (vtk): Fix build failure. [source]: Add patch to fix build failure with recent versions of freetype. * gnu/packages/patches/vtk-fix-freetypetools-build-failure.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
This commit is contained in:
parent
5b74e21e12
commit
251b0f7a6f
3 changed files with 41 additions and 1 deletions
|
@ -31,7 +31,7 @@
|
|||
# Copyright © 2020 R Veera Kumar <vkor@vkten.in>
|
||||
# Copyright © 2020 Nicolò Balzarotti <nicolo@nixo.xyz>
|
||||
# Copyright © 2020 Michael Rohleder <mike@rohleder.de>
|
||||
# Copyright © 2020 Felix Gruber <felgru@posteo.net>
|
||||
# Copyright © 2020, 2021 Felix Gruber <felgru@posteo.net>
|
||||
# Copyright © 2020 Ryan Prior <rprior@protonmail.com>
|
||||
# Copyright © 2020 Jan Wielkiewicz <tona_kosmicznego_smiecia@interia.pl>
|
||||
# Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
|
||||
|
@ -1720,6 +1720,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/vsearch-unbundle-cityhash.patch \
|
||||
%D%/packages/patches/vte-CVE-2012-2738-pt1.patch \
|
||||
%D%/packages/patches/vte-CVE-2012-2738-pt2.patch \
|
||||
%D%/packages/patches/vtk-fix-freetypetools-build-failure.patch \
|
||||
%D%/packages/patches/warsow-qfusion-fix-bool-return-type.patch \
|
||||
%D%/packages/patches/webkitgtk-share-store.patch \
|
||||
%D%/packages/patches/webkitgtk-bind-all-fonts.patch \
|
||||
|
|
|
@ -13,6 +13,7 @@
|
|||
;;; Copyright © 2020 Pierre Neidhardt <mail@ambrevar.xyz>
|
||||
;;; Copyright © 2020 Brendan Tildesley <mail@brendan.scot>
|
||||
;;; Copyright © 2021 Oleh Malyi <astroclubzp@gmail.com>
|
||||
;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
|
||||
;;;
|
||||
;;; This file is part of GNU Guix.
|
||||
;;;
|
||||
|
@ -254,6 +255,8 @@ (define-public vtk
|
|||
(sha256
|
||||
(base32
|
||||
"1fspgp8k0myr6p2a6wkc21ldcswb4bvmb484m12mxgk1a9vxrhrl"))
|
||||
(patches
|
||||
(search-patches "vtk-fix-freetypetools-build-failure.patch"))
|
||||
(modules '((guix build utils)))
|
||||
(snippet
|
||||
'(begin
|
||||
|
|
|
@ -0,0 +1,36 @@
|
|||
This fixes a build failure in VTK when building against recent versions
|
||||
of freetype.
|
||||
|
||||
https://gitlab.kitware.com/vtk/vtk/-/merge_requests/7432
|
||||
|
||||
Patch by Ben Boeckel <ben.boeckel@kitware.com>
|
||||
|
||||
Subject: [PATCH] vtkFreeTypeTools: avoid using an internal macro
|
||||
|
||||
This macro has been removed upstream as it was always intended to be
|
||||
private.
|
||||
---
|
||||
Rendering/FreeType/vtkFreeTypeTools.cxx | 7 ++-----
|
||||
1 file changed, 2 insertions(+), 5 deletions(-)
|
||||
|
||||
diff --git a/Rendering/FreeType/vtkFreeTypeTools.cxx b/Rendering/FreeType/vtkFreeTypeTools.cxx
|
||||
index c54289dc60..03b899c4da 100644
|
||||
--- a/Rendering/FreeType/vtkFreeTypeTools.cxx
|
||||
+++ b/Rendering/FreeType/vtkFreeTypeTools.cxx
|
||||
@@ -387,11 +387,8 @@ FTC_CMapCache* vtkFreeTypeTools::GetCMapCache()
|
||||
}
|
||||
|
||||
//----------------------------------------------------------------------------
|
||||
-FT_CALLBACK_DEF(FT_Error)
|
||||
-vtkFreeTypeToolsFaceRequester(FTC_FaceID face_id,
|
||||
- FT_Library lib,
|
||||
- FT_Pointer request_data,
|
||||
- FT_Face* face)
|
||||
+static FT_Error vtkFreeTypeToolsFaceRequester(
|
||||
+ FTC_FaceID face_id, FT_Library lib, FT_Pointer request_data, FT_Face* face)
|
||||
{
|
||||
#if VTK_FTFC_DEBUG_CD
|
||||
printf("vtkFreeTypeToolsFaceRequester()\n");
|
||||
--
|
||||
2.30.1
|
||||
|
Loading…
Reference in a new issue