mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 07:26:13 -05:00
gnu: metabat: Update to 2.12.1.
* gnu/packages/patches/metabat-remove-compilation-date.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it. * gnu/packages/bioinformatics.scm (metabat): Update to 2.12.1. [source]: Remove it. Use url-fetch.
This commit is contained in:
parent
43d01672a1
commit
25bd1fc1c1
3 changed files with 7 additions and 26 deletions
|
@ -846,7 +846,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/mcrypt-CVE-2012-4527.patch \
|
||||
%D%/packages/patches/mesa-skip-disk-cache-test.patch \
|
||||
%D%/packages/patches/mesa-wayland-egl-symbols-check-mips.patch \
|
||||
%D%/packages/patches/metabat-remove-compilation-date.patch \
|
||||
%D%/packages/patches/metabat-fix-compilation.patch \
|
||||
%D%/packages/patches/mhash-keygen-test-segfault.patch \
|
||||
%D%/packages/patches/mingw-w64-5.0rc2-gcc-4.9.3.patch \
|
||||
|
|
|
@ -3475,19 +3475,17 @@ (define-public mash
|
|||
(define-public metabat
|
||||
(package
|
||||
(name "metabat")
|
||||
(version "2.11.3")
|
||||
(version "2.12.1")
|
||||
(source
|
||||
(origin
|
||||
(method git-fetch)
|
||||
(uri (git-reference
|
||||
(url "https://bitbucket.org/berkeleylab/metabat.git")
|
||||
(commit "d0ad65367ffc8e08d1a9dd1388d6170daa047e5c")))
|
||||
(file-name (string-append name "-" version "-checkout"))
|
||||
(method url-fetch)
|
||||
(uri (string-append "https://bitbucket.org/berkeleylab/metabat/get/v"
|
||||
version ".tar.gz"))
|
||||
(file-name (string-append name "-" version ".tar.gz"))
|
||||
(sha256
|
||||
(base32
|
||||
"1rlsrkz8iq8xah65222p055kzv5i3szz8bwysnvnh0pv72wvv6ww"))
|
||||
(patches (search-patches "metabat-remove-compilation-date.patch"
|
||||
"metabat-fix-compilation.patch"))))
|
||||
"1hmvdalz3zj5sqqklg0l4npjdv37cv2hsdi1al9iby2ndxjs1b73"))
|
||||
(patches (search-patches "metabat-fix-compilation.patch"))))
|
||||
(build-system gnu-build-system)
|
||||
(arguments
|
||||
`(#:phases
|
||||
|
|
|
@ -1,16 +0,0 @@
|
|||
Remove the reference to the compilation date so that the build is
|
||||
reproducible.
|
||||
|
||||
diff --git a/src/metabat.cpp b/src/metabat.cpp
|
||||
index 88e06de..c95cb1a 100644
|
||||
--- a/src/metabat.cpp
|
||||
+++ b/src/metabat.cpp
|
||||
@@ -49,7 +49,7 @@ int main(int ac, char* av[]) {
|
||||
po::notify(vm);
|
||||
|
||||
if (vm.count("help") || inFile.length() == 0 || outFile.length() == 0) {
|
||||
- cerr << "\nMetaBAT: Metagenome Binning based on Abundance and Tetranucleotide frequency (version " << version << "; " << __DATE__ << " " << __TIME__ << ")" << endl;
|
||||
+ cerr << "\nMetaBAT: Metagenome Binning based on Abundance and Tetranucleotide frequency (version " << version << "; unknown compilation date)" << endl;
|
||||
cerr << "by Don Kang (ddkang@lbl.gov), Jeff Froula, Rob Egan, and Zhong Wang (zhongwang@lbl.gov) \n" << endl;
|
||||
cerr << desc << endl << endl;
|
||||
|
Loading…
Reference in a new issue