mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 07:26:13 -05:00
gnu: Remove gstreamer-0.10 and gst-plugins-base-0.10.
* gnu/packages/gstreamer.scm (gstreamer-0.10, gst-plugins-base-0.10): Remove variables. * gnu/packages/patches/gstreamer-0.10-bison3.patch, gnu/packages/patches/gstreamer-0.10-silly-test.patch: Remove files. * gnu-system.am (dist_patch_DATA): Remove them.
This commit is contained in:
parent
3ec4bba4c9
commit
27c4f0cc03
4 changed files with 0 additions and 94 deletions
|
@ -440,8 +440,6 @@ dist_patch_DATA = \
|
|||
gnu/packages/patches/grep-CVE-2015-1345.patch \
|
||||
gnu/packages/patches/grub-gets-undeclared.patch \
|
||||
gnu/packages/patches/grub-freetype.patch \
|
||||
gnu/packages/patches/gstreamer-0.10-bison3.patch \
|
||||
gnu/packages/patches/gstreamer-0.10-silly-test.patch \
|
||||
gnu/packages/patches/guile-1.8-cpp-4.5.patch \
|
||||
gnu/packages/patches/guile-arm-fixes.patch \
|
||||
gnu/packages/patches/guile-default-utf8.patch \
|
||||
|
|
|
@ -124,32 +124,6 @@ (define-public gstreamer
|
|||
This package provides the core library and elements.")
|
||||
(license lgpl2.0+)))
|
||||
|
||||
(define-public gstreamer-0.10
|
||||
(package (inherit gstreamer)
|
||||
(version "0.10.36")
|
||||
(source
|
||||
(origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "http://gstreamer.freedesktop.org/src/gstreamer/gstreamer-"
|
||||
version ".tar.xz"))
|
||||
(sha256
|
||||
(base32
|
||||
"1nkid1n2l3rrlmq5qrf5yy06grrkwjh3yxl5g0w58w0pih8allci"))
|
||||
(patches
|
||||
(list (search-patch "gstreamer-0.10-bison3.patch")
|
||||
(search-patch "gstreamer-0.10-silly-test.patch")))))
|
||||
(propagated-inputs
|
||||
`(("libxml2" ,libxml2)))
|
||||
(inputs `(("glib" ,glib)))
|
||||
(native-inputs
|
||||
`(("bison" ,bison)
|
||||
("flex" ,flex)
|
||||
("perl" ,perl)
|
||||
("pkg-config" ,pkg-config)
|
||||
("glib" ,glib "bin")
|
||||
("python" ,python-2)))))
|
||||
|
||||
|
||||
(define-public gst-plugins-base
|
||||
(package
|
||||
(name "gst-plugins-base")
|
||||
|
@ -288,23 +262,3 @@ (define-public gst-libav
|
|||
"This GStreamer plugin supports a large number of audio and video
|
||||
compression formats through the use of the libav library.")
|
||||
(license gpl2+)))
|
||||
|
||||
(define-public gst-plugins-base-0.10
|
||||
(package (inherit gst-plugins-base)
|
||||
(version "0.10.36")
|
||||
(source
|
||||
(origin
|
||||
(method url-fetch)
|
||||
(uri (string-append
|
||||
"http://gstreamer.freedesktop.org/src/gst-plugins-base/gst-plugins-base-"
|
||||
version ".tar.xz"))
|
||||
(sha256
|
||||
(base32
|
||||
"0jp6hjlra98cnkal4n6bdmr577q8mcyp3c08s3a02c4hjhw5rr0z"))))
|
||||
(inputs
|
||||
`(("glib" ,glib)
|
||||
("gstreamer" ,gstreamer-0.10)))
|
||||
(native-inputs
|
||||
`(("pkg-config" ,pkg-config)
|
||||
("glib" ,glib "bin")
|
||||
("python" ,python-2)))))
|
||||
|
|
|
@ -1,32 +0,0 @@
|
|||
See https://bugzilla.gnome.org/show_bug.cgi?id=706462
|
||||
|
||||
Subject: [PATCH] Make grammar.y work with Bison 3
|
||||
|
||||
YYLEX_PARAM is no longer supported in Bison 3.
|
||||
---
|
||||
gst/parse/grammar.y | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/gst/parse/grammar.y b/gst/parse/grammar.y
|
||||
index 8a9019c..f533389 100644
|
||||
--- a/gst/parse/grammar.y
|
||||
+++ b/gst/parse/grammar.y
|
||||
@@ -26,7 +26,6 @@
|
||||
*/
|
||||
|
||||
#define YYERROR_VERBOSE 1
|
||||
-#define YYLEX_PARAM scanner
|
||||
|
||||
#define YYENABLE_NLS 0
|
||||
|
||||
@@ -659,6 +658,7 @@ static int yyerror (void *scanner, graph_t *graph, const char *s);
|
||||
%right '.'
|
||||
%left '!' '='
|
||||
|
||||
+%lex-param { void *scanner }
|
||||
%parse-param { void *scanner }
|
||||
%parse-param { graph_t *graph }
|
||||
%pure-parser
|
||||
--
|
||||
1.8.3.4
|
||||
|
|
@ -1,14 +0,0 @@
|
|||
See http://lists.freedesktop.org/archives/gstreamer-bugs/2013-January/098461.html
|
||||
|
||||
diff -ru gstreamer-0.10.36.orig/tests/check/Makefile.in gstreamer-0.10.36/tests/check/Makefile.in
|
||||
--- gstreamer-0.10.36.orig/tests/check/Makefile.in 2012-02-20 23:48:29.000000000 +0100
|
||||
+++ gstreamer-0.10.36/tests/check/Makefile.in 2013-10-30 21:55:48.000000000 +0100
|
||||
@@ -42,7 +42,7 @@
|
||||
gst/gstbus$(EXEEXT) gst/gstcaps$(EXEEXT) $(am__EXEEXT_2) \
|
||||
gst/gstdatetime$(EXEEXT) gst/gstinfo$(EXEEXT) \
|
||||
gst/gstiterator$(EXEEXT) gst/gstmessage$(EXEEXT) \
|
||||
- gst/gstminiobject$(EXEEXT) gst/gstobject$(EXEEXT) \
|
||||
+ gst/gstminiobject$(EXEEXT) \
|
||||
gst/gstpad$(EXEEXT) gst/gstparamspecs$(EXEEXT) \
|
||||
gst/gstpoll$(EXEEXT) gst/gstsegment$(EXEEXT) \
|
||||
gst/gstsystemclock$(EXEEXT) gst/gstclock$(EXEEXT) \
|
Loading…
Reference in a new issue