gnu: libsigrokdecode: Update to 0.5.3-0.e6962b3, fix build.

* gnu/packages/electronics.scm (libsigrokdecode): Update to 0.5.3-0.e6962b3.
[source]: Use git-fetch.  Remove patches.
[native-inputs]: Add libtool.
[arguments]<#:phases>: Remove bootstrap phase.
* gnu/packages/patches/libsigrokdecode-python3.9-fix.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Unregister it.

Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
This commit is contained in:
Lu Hui 2023-06-09 21:22:10 +08:00 committed by 宋文武
parent 1dce887776
commit 28fdf6cc16
No known key found for this signature in database
GPG key ID: D415BF253B515976
3 changed files with 41 additions and 62 deletions

View file

@ -1598,7 +1598,6 @@ dist_patch_DATA = \
%D%/packages/patches/mcrypt-CVE-2012-4527.patch \ %D%/packages/patches/mcrypt-CVE-2012-4527.patch \
%D%/packages/patches/libmemcached-build-with-gcc7.patch \ %D%/packages/patches/libmemcached-build-with-gcc7.patch \
%D%/packages/patches/libmhash-hmac-fix-uaf.patch \ %D%/packages/patches/libmhash-hmac-fix-uaf.patch \
%D%/packages/patches/libsigrokdecode-python3.9-fix.patch \
%D%/packages/patches/maturin-no-cross-compile.patch \ %D%/packages/patches/maturin-no-cross-compile.patch \
%D%/packages/patches/mecab-variable-param.patch \ %D%/packages/patches/mecab-variable-param.patch \
%D%/packages/patches/memtest86+-build-reproducibly.patch \ %D%/packages/patches/memtest86+-build-reproducibly.patch \

View file

@ -79,49 +79,48 @@ (define-public libserialport
(license license:lgpl3+))) (license license:lgpl3+)))
(define-public libsigrokdecode (define-public libsigrokdecode
(package (let ((commit "e6962b3fe8260382bb9932a1cfdd7ee7090ce267")
(name "libsigrokdecode") (revision "0"))
(version "0.5.3") (package
(source (origin (name "libsigrokdecode")
(method url-fetch) (version (git-version "0.5.3" revision commit))
(uri (string-append (source (origin
"http://sigrok.org/download/source/libsigrokdecode/libsigrokdecode-" (method git-fetch)
version ".tar.gz")) (uri (git-reference
(sha256 (url "https://github.com/sigrokproject/libsigrokdecode")
(base32 (commit commit)))
"1h1zi1kpsgf6j2z8j8hjpv1q7n49i3fhqjn8i178rka3cym18265")) (file-name (git-file-name name version))
(patches (sha256
(search-patches "libsigrokdecode-python3.9-fix.patch")))) (base32
(outputs '("out" "doc")) "0ik93p6k8hpv8ahchjnmir8paz2w718y1j8pnmrmagjx8vvqd9y6"))))
(arguments (outputs '("out" "doc"))
`(#:phases (arguments
(modify-phases %standard-phases `(#:phases
(replace 'bootstrap (modify-phases %standard-phases
(lambda _ (add-after 'build 'build-doc
(invoke "autoconf") (lambda _
(invoke "aclocal") (invoke "doxygen")
(invoke "automake" "-ac"))) #t))
(add-after 'build 'build-doc (add-after 'install 'install-doc
(lambda _ (lambda* (#:key outputs #:allow-other-keys)
(invoke "doxygen") (copy-recursively "doxy/html-api"
#t)) (string-append (assoc-ref outputs "doc")
(add-after 'install 'install-doc "/share/doc/libsigrokdecode"))
(lambda* (#:key outputs #:allow-other-keys) #t)))))
(copy-recursively "doxy/html-api" (native-inputs
(string-append (assoc-ref outputs "doc") (list check doxygen graphviz pkg-config automake autoconf libtool))
"/share/doc/libsigrokdecode")) ;; libsigrokdecode.pc lists "python" in Requires.private, and "glib" in
#t))))) ;; Requires.
(native-inputs (propagated-inputs
(list check doxygen graphviz pkg-config automake autoconf)) (list glib python))
;; libsigrokdecode.pc lists "python" in Requires.private, and "glib" in Requires. (build-system gnu-build-system)
(propagated-inputs (home-page "https://www.sigrok.org/wiki/Libsigrokdecode")
(list glib python)) (synopsis
(build-system gnu-build-system) "Library providing (streaming) protocol decoding functionality")
(home-page "https://www.sigrok.org/wiki/Libsigrokdecode") (description
(synopsis "Library providing (streaming) protocol decoding functionality") "Libsigrokdecode is a shared library written in C, which provides
(description "Libsigrokdecode is a shared library written in C, which provides
(streaming) protocol decoding functionality.") (streaming) protocol decoding functionality.")
(license license:gpl3+))) (license license:gpl3+))))
(define-public sigrok-firmware-fx2lafw (define-public sigrok-firmware-fx2lafw
(package (package

View file

@ -1,19 +0,0 @@
From: Dan Horák <dan@danny.cz>
Subject: Add support for Python 3.9
Origin: upstream, https://sigrok.org/gitweb/?p=libsigrokdecode.git;a=commitdiff;h=9b0ad5177bd692f7556a4756bdbd2da81d9c34ce
Bug-Debian: https://bugs.debian.org/972769
diff --git a/configure.ac b/configure.ac
index f9958b3..2917cb3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -100,7 +100,7 @@ SR_PKG_CHECK_SUMMARY([srd_pkglibs_summary])
# first, since usually only that variant will add "-lpython3.8".
# https://docs.python.org/3/whatsnew/3.8.html#debug-build-uses-the-same-abi-as-release-build
SR_PKG_CHECK([python3], [SRD_PKGLIBS],
- [python-3.8-embed], [python-3.8 >= 3.8], [python-3.7 >= 3.7], [python-3.6 >= 3.6], [python-3.5 >= 3.5], [python-3.4 >= 3.4], [python-3.3 >= 3.3], [python-3.2 >= 3.2], [python3 >= 3.2])
+ [python-3.9-embed], [python-3.8-embed], [python-3.8 >= 3.8], [python-3.7 >= 3.7], [python-3.6 >= 3.6], [python-3.5 >= 3.5], [python-3.4 >= 3.4], [python-3.3 >= 3.3], [python-3.2 >= 3.2], [python3 >= 3.2])
AS_IF([test "x$sr_have_python3" = xno],
[AC_MSG_ERROR([Cannot find Python 3 development headers.])])