mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 15:36:20 -05:00
gnu: duplicity: Update to 0.7.11.
* gnu/packages/backup.scm (duplicity): Update to 0.7.11. [source]: Remove patches. [inputs]: Add lftp, update gnupg, remove python-2, make python2-lockfile a propagated input, make python2-mock a native-input. [propagated-inputs]: Add python2-lockfile, python2-urllib3. [native-inputs]: Add python2-pexpect, python2-mock. [arguments]: Add build phase to embed gnupg store name. * gnu/packages/patches/duplicity-piped-password.patch: Delete it. * gnu/packages/patches/duplicity-test_selection-tmp.patch: Delete it. * gnu/local.mk (dist_patch_DATA): Remove patches. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
This commit is contained in:
parent
82110ef658
commit
2903ee1ea5
4 changed files with 18 additions and 50 deletions
|
@ -528,8 +528,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/doc++-include-directives.patch \
|
||||
%D%/packages/patches/doc++-segfault-fix.patch \
|
||||
%D%/packages/patches/doxygen-test.patch \
|
||||
%D%/packages/patches/duplicity-piped-password.patch \
|
||||
%D%/packages/patches/duplicity-test_selection-tmp.patch \
|
||||
%D%/packages/patches/elfutils-tests-ptrace.patch \
|
||||
%D%/packages/patches/elixir-disable-failing-tests.patch \
|
||||
%D%/packages/patches/einstein-build.patch \
|
||||
|
|
|
@ -34,6 +34,7 @@ (define-module (gnu packages backup)
|
|||
#:use-module (gnu packages compression)
|
||||
#:use-module (gnu packages databases)
|
||||
#:use-module (gnu packages dejagnu)
|
||||
#:use-module (gnu packages ftp)
|
||||
#:use-module (gnu packages glib)
|
||||
#:use-module (gnu packages gnupg)
|
||||
#:use-module (gnu packages gperf)
|
||||
|
@ -52,7 +53,7 @@ (define-module (gnu packages backup)
|
|||
(define-public duplicity
|
||||
(package
|
||||
(name "duplicity")
|
||||
(version "0.6.26")
|
||||
(version "0.7.11")
|
||||
(source
|
||||
(origin
|
||||
(method url-fetch)
|
||||
|
@ -62,18 +63,19 @@ (define-public duplicity
|
|||
version ".tar.gz"))
|
||||
(sha256
|
||||
(base32
|
||||
"0jh79syhr8n3l81jxlwsmwm1pklb4d923m2lgqbswyavh1fqmvwb"))
|
||||
(patches (search-patches "duplicity-piped-password.patch"
|
||||
"duplicity-test_selection-tmp.patch"))))
|
||||
"01zcq9cwn4pvj68rihgjvcdgccnxvz4jrba38sbv6nqz19cs2ixh"))))
|
||||
(build-system python-build-system)
|
||||
(native-inputs
|
||||
`(("util-linux" ,util-linux))) ;setsid command, for the tests
|
||||
`(("util-linux" ,util-linux) ;setsid command, for the tests
|
||||
("python-pexpect" ,python2-pexpect)
|
||||
("mock" ,python2-mock)))
|
||||
(propagated-inputs
|
||||
`(("lockfile" ,python2-lockfile)
|
||||
("urllib3" ,python2-urllib3)))
|
||||
(inputs
|
||||
`(("python" ,python-2)
|
||||
("librsync" ,librsync)
|
||||
("mock" ,python2-mock) ;for testing
|
||||
("lockfile" ,python2-lockfile)
|
||||
("gnupg" ,gnupg-1) ;gpg executable needed
|
||||
`(("librsync" ,librsync)
|
||||
("lftp" ,lftp)
|
||||
("gnupg" ,gnupg) ;gpg executable needed
|
||||
("util-linux" ,util-linux) ;for setsid
|
||||
("tzdata" ,tzdata)))
|
||||
(arguments
|
||||
|
@ -81,6 +83,12 @@ (define-public duplicity
|
|||
#:test-target "test"
|
||||
#:phases
|
||||
(modify-phases %standard-phases
|
||||
(add-before
|
||||
'build 'patch-source ; embed gpg store name
|
||||
(lambda* (#:key inputs #:allow-other-keys)
|
||||
(substitute* "duplicity/gpginterface.py"
|
||||
(("self.call = 'gpg'")
|
||||
(string-append "self.call = '" (assoc-ref inputs "gnupg") "/bin/gpg'")))))
|
||||
(add-before 'check 'check-setup
|
||||
(lambda* (#:key inputs #:allow-other-keys)
|
||||
(substitute* "testing/functional/__init__.py"
|
||||
|
|
|
@ -1,20 +0,0 @@
|
|||
This test, on three occasions, is failing with the error:
|
||||
|
||||
EOF: End Of File (EOF) in read_nonblocking(). Braindead platform.
|
||||
|
||||
--- duplicity-0.6.24/testing/functional/test_final.py 2014-09-28 13:14:52.146001614 -0500
|
||||
+++ duplicity-0.6.24/testing/functional/test_final.py 2014-09-28 13:13:20.333546342 -0500
|
||||
@@ -156,13 +156,6 @@
|
||||
self.run_duplicity(options=["remove-older-than", "50000", "--force", self.backend_url])
|
||||
self.assertEqual(self.get_backend_files(), second_chain)
|
||||
|
||||
- def test_piped_password(self):
|
||||
- """Make sure that prompting for a password works"""
|
||||
- self.set_environ("PASSPHRASE", None)
|
||||
- self.backup("full", "testfiles/empty_dir",
|
||||
- passphrase_input=[self.sign_passphrase, self.sign_passphrase])
|
||||
- self.restore(passphrase_input=[self.sign_passphrase])
|
||||
-
|
||||
|
||||
class OldFilenamesFinalTest(FinalTest):
|
||||
|
|
@ -1,18 +0,0 @@
|
|||
Reported upstream at https://bugs.launchpad.net/duplicity/+bug/1375019
|
||||
|
||||
--- duplicity-0.6.24/testing/unit/test_selection.py 2014-05-09 08:27:40.000000000 -0500
|
||||
+++ duplicity-0.6.24/testing/unit/test_selection.py 2014-09-28 12:28:53.932324380 -0500
|
||||
@@ -431,10 +431,10 @@
|
||||
[(), ('1',), ('1', '1'), ('1', '2'), ('1', '3')])
|
||||
|
||||
self.root = Path("/")
|
||||
- self.ParseTest([("--exclude", "/home/*"),
|
||||
- ("--include", "/home"),
|
||||
+ self.ParseTest([("--exclude", "/tmp/*"),
|
||||
+ ("--include", "/tmp"),
|
||||
("--exclude", "/")],
|
||||
- [(), ("home",)])
|
||||
+ [(), ("tmp",)])
|
||||
|
||||
if __name__ == "__main__":
|
||||
unittest.main()
|
Loading…
Reference in a new issue